cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
728
Views
0
Helpful
8
Replies

Cisco Router 1921 - High ping with default gateway from LAN

Renato Voice
Level 1
Level 1

Dear All,

 

I have a issue on  site with communication .

On branch site  i have a 1921 Router which is interconnected with a 2960-x Switch. Communication between Router and Switch is via sub interface (Router on stick). So  all end device as ( PC, Camera, Printer etc.) that are connected to the Switch as the default gateway have the router 1921 .On Router 1921 are configured sub interface for each vlan that are configuring on the Switch .

 

My  issue is,  i have high ping  with (high time ) and  drop pings with default gateway (Router) when i tried to ping gateway from all PC on LAN . High ping with gateway appearing when i generate any kind of traffic  as : download of any file on LAN or HQ Site or access on any application, access on Internet etc.

On Router i have configured also ZBF (Zone Based Firewall) and QOS

 

Can you tell me if it is normal that ping with gateway on Cisco 1921 increasing until 20-50  mms when we have traffic and to return to normal ping 1 mms when there is no traffic

 

Configuration are as below :

 

On Router : 

interface GigabitEthernet0/0.67
description Internal
encapsulation dot1Q 67
ip address 10.88.67.0 255.255.255.0
!
interface GigabitEthernet0/0.59
description other services 
encapsulation dot1Q 59
ip address 10.88.59.0 255.255.255.0

 

On Switch :

 

interface GigabitEthernet1/0/1
switchport access vlan 67
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 59
switchport mode access
spanning-tree portfast

 

interface GigabitEthernet1/0/3
switchport access vlan 3
switchport mode access

!
interface GigabitEthernet1/0/4
switchport access vlan 4
switchport mode access

!
interface GigabitEthernet1/0/5
description TRUNK 
switchport trunk allowed vlan 67,59
switchport mode trunk


Thank you for help

8 Replies 8

Hi,

I think the IP addresses configured on the sub interfaces are a typo, they should be other IP than zero.

interface GigabitEthernet0/0.67
description Internal
encapsulation dot1Q 67
ip address 10.88.67.0 255.255.255.0   <--- For example: 10.88.67.1 
!
interface GigabitEthernet0/0.59
description other services 
encapsulation dot1Q 59
ip address 10.88.59.0 255.255.255.0   <--- For example: 10.88.59.1 

 

Now your configuration looks fine except the above mentioned, it looks like a layer 1 issue, have you replaced the cable, SFPs or ports?

 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

 

Sorry for mistake the configuration are as below :

 

interface GigabitEthernet0/0.67
description Internal
encapsulation dot1Q 67
ip address 10.88.67.1 255.255.255.0
!
interface GigabitEthernet0/0.59
description other services 
encapsulation dot1Q 59
ip address 10.88.59.1 255.255.255.0

 

Also below you can see in more detail interface gi 0/0 where is connected the Switch LAN 

 

GigabitEthernet0/0 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is 6cb2.aeb9.4a50 (bia 6cb2.aeb9.4a50)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 548
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 2135000 bits/sec, 478 packets/sec
5 minute output rate 2511000 bits/sec, 493 packets/sec
26792098 packets input, 1271317341 bytes, 0 no buffer
Received 59292 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
396 input errors, 0 CRC, 0 frame, 396 overrun, 0 ignored
0 watchdog, 3379 multicast, 0 pause input
33233699 packets output, 2429497681 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
23708 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
2 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

Hi

In order to discard any problem between the PC and Router, try creating a SVI 59 or 67 on the switch and make a ping with source that VLAN, for example

 

Switch

interface vlan 67

ip address 10.88.67.250 255.255.255.0

no shutdown

 

ping 10.88.67.1 source vlan 67 repeat 1000

 

If you dont lose packets and the response time is ok, the problem could be the PC or its cable otherwise change the switchport or router port and cable and/or SFP.

 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

mlund
Level 7
Level 7

Hi

Yes it's normal for a router to increase the ping response time when other traffic is present.

The primary goal for the router is to forward traffic.

Answer ping is on a relatively low priority for the router.

Try to ping something else, maybe a server a a pc, so the router just have to route the packets.

/Mikael

Hi Mikael 

Thank you for all information. Can you tell me if existing any offical documentation from Cisco about this that Cisco Router has with low priority ping

 

Thank you help 

Thank you very much Mikael

Hi All,

 

If i have possibility to configuring Cisco Router to have high priority for ICMP even if i have more traffic 

Review Cisco Networking for a $25 gift card