cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
499
Views
10
Helpful
6
Replies

Cisco RV340 Dropping SMTP connections

chimera
Beginner
Beginner

Ok this is confounding me. I have setup a brand new RV340 and its working great with everything including port forwarding HTTPS to the internal exchange server. However, when forwarding SMTP packets the connection gets quickly dropped. Strangely when using a Windows telnet client, I can connect and send mail but not through Linux nor can the hosted email security gateway send mails through the router to the server. Any advice would be apprecaited thanks!

Also emails sent directly over the lan and bypassing the router are working fine. Additionally the web management interface is only partially showing up remotely and is non functional.

I have tried disabling all of the security features but it didn't make a difference. Perhaps there is something I have missed?

Should I just blank the router and start again?

6 Replies 6

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Not enough information regards your network to understand the issue.
Where exactly does this new router and the smtp gateway reside in your network are they separated by the internet or an internal firewall.
Can you post a topology of your network and if possible, the configuration of your router?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul. It is a basic setup.

 

Trend Micro cloud email security gateway --> SMTP --> Cisco RV340 --> Port forward 25 --> Exchange server.

There is no firewall anywhere except on the router.

If I telnet to the router it drops the connection. If I try to send an email via MX to the Cloud gateway it gets dropped when trying to establish a connection to the router. The router is replacing a working cyberoam. SMTP commands entered directly work over the LAN.

 

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

--> I have tried disabling all of the security features but it didn't make a difference. Perhaps there is something I have missed?

 

I think the RV340 has an AntiVirus options as well (Security > Threat/IPS > Antivirus), did you disable that as well ?

 

Also, make sure you are runniing the latest firmware release, 1.0.03.20.

 

 

Yes disabled the AV and I did update the firmware…

Hello,

 

the link below is from an older firmware version, but somewhere in the settings, there is an option to enable TTL/SSL email encryption, check if you have that enabled and if so, disable it (and use 'None')...

 

https://www.cisco.com/c/en/us/support/docs/smb/routers/cisco-rv-series-small-business-routers/smb5473-configure-email-settings-on-the-rv34x-series-router.html

Hi Georg,

     I belive that article is in regards to sending email from the router rather than email passing through the router to a server?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers