cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
667
Views
0
Helpful
2
Replies

Cisco892/K9 DHCP Server don't work?

jmmgrodrigues
Level 1
Level 1

I Have interface Gi0 as nat outside and interface Fa8 with no ip address.

I have created 3 subinterfaces on Fa8, listed below.

How can I make such that each of them DHCP server working?

 

int gi0

ip address 10.0.0.2 255.255.255.252

ip nat outside

...

 

int fa8.10

description VLAN10-Data

encapsulation dot1Q 10

ip address 10.0.10.14 255.255.255.240

ip nat inside

...

 

int fa8.20

description VLAN20-IPTV

encapsulation dot1Q 20

ip address 10.0.20.6 255.255.255.248

ip nat inside

 

int fa8.30

description VLAN30-Guests

encapsulation dot1Q 20

ip address 10.0.30.6 255.255.255.248

ip nat inside

...

 

ip dhcp excluded-address 10.0.10.14

ip dhcp excluded-address 10.0.20.6

ip dhcp excluded-address 10.0.30.6

 

ip dhcp pool Vlan 10

network  10.0.10.0 255.255.255.240

default-router  10.0.10.14

 

ip dhcp pool Vlan 20

network  10.0.20.0 255.255.255.240

default-router  10.0.20.6

 

ip dhcp pool Vlan 30

network  10.0.30.0 255.255.255.240

default-router  10.0.30.6

 

Nat is working well, I can ping/traceroute outside of the lan! I am not getting DHCP Server to assign addresses to the pc's through the ports Fa0 to 7. Can you help me, please?

1 Accepted Solution

Accepted Solutions

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

If you want to use fa0-7 as switchports then you will need to change your configuration from using routed sub-interfaces to SVIs:

!
int fa8.10
  no ip address
  no ip nat inside
int fa8.20
  no ip address
  no ip nat inside
int fa8.30
  no ip address
  no ip nat inside
!
int vlan 10
  ip address 10.0.10.14 255.255.255.240
  ip nat inside
!
int vlan 20
  ip address 10.0.20.6 255.255.255.248
  ip nat inside
!
int vlan 30
  ip address 10.0.30.6 255.255.255.248
  ip nat inside
!
int range fa0-7
  switchport mode access
  switchport access vlan10
  spanning-tree portfast
!

We will leave the rest of the fa8 sub-interface config so you can use that as a trunk link to connect to a switch.

 

cheers,

Seb.

View solution in original post

2 Replies 2

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

If you want to use fa0-7 as switchports then you will need to change your configuration from using routed sub-interfaces to SVIs:

!
int fa8.10
  no ip address
  no ip nat inside
int fa8.20
  no ip address
  no ip nat inside
int fa8.30
  no ip address
  no ip nat inside
!
int vlan 10
  ip address 10.0.10.14 255.255.255.240
  ip nat inside
!
int vlan 20
  ip address 10.0.20.6 255.255.255.248
  ip nat inside
!
int vlan 30
  ip address 10.0.30.6 255.255.255.248
  ip nat inside
!
int range fa0-7
  switchport mode access
  switchport access vlan10
  spanning-tree portfast
!

We will leave the rest of the fa8 sub-interface config so you can use that as a trunk link to connect to a switch.

 

cheers,

Seb.

Thanks Seb.! It worked! I did not understand how to get there. :)

Review Cisco Networking for a $25 gift card