cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1783
Views
20
Helpful
5
Replies

Class-map used by two policies in the same interface and router

alison.hou
Level 1
Level 1

Here is the configs:

class-map match-any Voice

match ip dscp ef

policy-map INBOUND

class Voice

   priority percent 40

   set dscp ef

class class-default

   fair-queue!

policy-map OUTBOUND

class Voice

   priority 1000

class class-default

   fair-queue!

interface ATM1/ima0.1 point-to-point

service-policy input INBOUND

service-policy output OUTBOUND

Can this work?

Alison

5 Replies 5

marcusauman
Level 1
Level 1

Yes you can reference a class map in multiple policies. Configuration looks good as well minus the ! at the end of your fair-queue statements.

Please rate if this was helpful.. Thanks

cadet alain
VIP Alumni
VIP Alumni

Hi,

of course you can use the same class-map on different policy-maps , that's why MQC was created for: modularity and reuse

BUT in your case your policy can't be applied inbound because you can only configure CBWFQ or LLQ outbound( bandwidth or priority command) because this is a congestion management feature and congestion occurs on egress queues.

Alain.

Don't forget to rate helpful posts.

Alain is correct. Good catch!

Thank you for the catch. My goal is to retrict traffic from a microsoft DS server in the data center to this remote site. The outbound qos policiy is the existing policy for voice. For the inbound, I am planning to add a class for micorsoftDS to give it 3% bandwidth. How should I do it if I can't use CBWFQ or LLQ for inbound.

class-map match-any Voice

match ip dscp ef

class-map microsoftDS

            match access group 102

!

policy-map VoIP_COS

  class Voice

    priority 1000

  class class-default

   fair-queue

!

policy-map LLQ_40percent

class Voice

   priority percent 40

   set dscp ef

class microsoftDS

   bandwidth percent 3

class class-default

   fair-queue!

access-list 102 permit tcp host 10.80.14.140 eq 445 any

access-list 102 permit udp host 10.80.14.140 eq 445 any

interface ATM1/ima0.1 point-to-point

service-policy input LLQ_40percent

service-policy output VoIP_COS

alison

Hi,

use the police keyword instead of priority.

Regards.

Alain.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card