cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
632
Views
0
Helpful
1
Replies

Config BGP add NEW ISP with dual AS IIX and INP

robmabayu
Beginner
Beginner

Hi master.

 

I have router ASR9K with single ISP (ISP-A) using BGP routing.

now, my company need to add new ISP (ISP-B) on Router.

 

The ISP-B carry single ip neigbor (peering) with dual AS,

for example AS-300 for Internasional (IIX) and AS-400 for (INP).

 

how about config single multihoming on my Router ASR9K ?

I'm create the plan config with using wieght for traffic outbound and as-path prepend of inboud traffic.

I attach topology plan

 

this is my config.

Current:

1.prefix-list-Current

prefix-set NETWORK
192.168.10.0/24
192.168.20.0/24
end-set
!
prefix-set IPV4_BLOCK
10.10.0.0/16 le 32,
172.16.0.0/12 le 32,
end-set




2. Route-Policy-Current

route-policy PREFIX_OUT
if destination in NETWORK then
pass
endif
end-policy
!
route-policy RP_INBOUND
apply RPL_DENY_IPV4_BOGONS
end-policy
!
route-policy RP_DENY_IPV4_BLOCK
if destination in IPV4_BLOCK then
drop
else
pass
endif
end-policy




3.  BGP Config - Current

router bgp 100
bgp router-id 1.1.1.1
address-family ipv4 unicast
network 192.168.10.0/24
network 192.168.20.0/24
!
neighbor 1.1.1.2
remote-as 200
address-family ipv4 unicast
route-policy RP_INBOUND in
route-policy PREFIX_OUT out
soft-reconfiguration inbound always
!
!
neighbor 2.2.2.1
remote-as 200
address-family ipv4 unicast
route-policy RPL_INBOUND in
route-policy PREFIX_OUT out
soft-reconfiguration inbound always
!
!





4. Route Static - Current router static
address-family ipv4 unicast
192.168.10.0/24 Null0
192.168.20.0/24 192.168.10.130




5. add attribute weight on existing BGP (ISP-A)

router bgp 100
bgp router-id 1.1.1.1
address-family ipv4 unicast
network 192.168.10.0/24
network 192.168.20.0/24
!
neighbor 1.1.1.2
remote-as 200
address-family ipv4 unicast

weight 80  (add attribute weight on BGP ISP-A)
route-policy RP_INBOUND in
route-policy PREFIX_OUT out
soft-reconfiguration inbound always
!



6. Create Route-Policy for ISP-B (new)

route-policy PREFIX_NETWORK_PREPEND_ISP-B
if destination in NETWORK then
prepend as-path 100 100
pass
else
drop
endif
end-policy
!
commit
!




7. add on BGP Config for New ISP-B

neighbor 3.3.3.2
remote-as 300
description INP-ISP-B
address-family ipv4 unicast
weight 60
route-policy RPL_INBOUND in
route-policy PREFIX_OFFICIAL_PREPEND_INDOSAT out
soft-reconfiguration inbound
!
neighbor 3.3.3.2
remote-as 400
description INIX-ISP-B
address-family ipv4 unicast
weight 60
route-policy RP_INBOUND in
route-policy PREFIX_NETWORK_PREPEND_ISP-B out
soft-reconfiguration inbound
!
commit
!


could you verify plan my config, is true or false, please give me suggestion

 

thanks

 

ubay

 

 

1 Accepted Solution

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @robmabayu ,

I don't think the proposed setup will work because neighbor 3.3.3.2 belongs to a single AS either AS300 or AS 400.

You will likely need to use two subinterfaces with different IP subnets

3.3.3.2 remote-as 300

 

3.3.3.6 remote-as 400

 

All the rest may work once this is fixed

 

Hope to help

Giuseppe

View solution in original post

1 Reply 1

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @robmabayu ,

I don't think the proposed setup will work because neighbor 3.3.3.2 belongs to a single AS either AS300 or AS 400.

You will likely need to use two subinterfaces with different IP subnets

3.3.3.2 remote-as 300

 

3.3.3.6 remote-as 400

 

All the rest may work once this is fixed

 

Hope to help

Giuseppe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: