cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3122
Views
0
Helpful
4
Replies
Highlighted
Beginner

Config Register value changes automatically

Hi,

Facing a unique problem in my cisco Router (2811) .. Router is well configured but suddenly it stops working , when logged in using console the configuration register is observed to be 0x2142.

How does it automatically changes register value during operation???

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

as per my knowledge,It should not change automatically.

Configuration register is 0x2102 (will be 0x0 at next reload)

  this line say that u have changed the value of register and after reload it will take your value.

config-register is a unique config command.  It actually does not  require a write mem to take effect.  The config-register is a persistent  rommon variable and is used to determine the boot sequence.  It should  not change on power cycle or reload.  If this variable is changing on  power cycle then I would suspect that something  is wrong with nvram or  the storage area defined to hold rommon variables.   You probably will  need to RMA the device.

please pase sh version output:

if it shows like this??   CRC32 failed for NVRAM at 0x54000000

it seems to me like you might have problems with your NVRAM

(CRC32 failed for NVRAM at 0x......

Erasing NVRAM area at 0x....)

then

So I'd try to

1) backup the running config to tftp server

2) wr erase - clears the NVRAM

3) wr - saves the running config to the start-up config

4) sh start-up - checks if the wr command was successful

5) sh ver

The error message might disappear.

If it remains, I'd reload the switch. It's a little dangerous - if the NVRAM is damaged, you might loose your complete config.

6) confreg .....- set the config reisters to proper value in ROM monitor mode

7) boot ..... - manually from ROM monitor

8) sh ver - check the registers and NVRAM problem

Regards,

Please rate if it helps.

View solution in original post

4 REPLIES 4
Highlighted
VIP Mentor

Hi Rahul,

have you changed the register vlaue manually and reload the router, if not then please do it ????

Cisco-Router(config)#config-register

Cisco-Router(config)#end

Cisco-Router#sh version

it will show like this:

Configuration register is 0x2142 (will be 0x2102 at next reload)

  then do this:

Cisco-Router#reload

Regards

Highlighted

ya i did tht changing the register value ...

However how does it automatically changes value in between operation ???

also one time it had this line

Configuration register is 0x2102 (will be 0x0 at next reload)

What does this mean ?

Highlighted

as per my knowledge,It should not change automatically.

Configuration register is 0x2102 (will be 0x0 at next reload)

  this line say that u have changed the value of register and after reload it will take your value.

config-register is a unique config command.  It actually does not  require a write mem to take effect.  The config-register is a persistent  rommon variable and is used to determine the boot sequence.  It should  not change on power cycle or reload.  If this variable is changing on  power cycle then I would suspect that something  is wrong with nvram or  the storage area defined to hold rommon variables.   You probably will  need to RMA the device.

please pase sh version output:

if it shows like this??   CRC32 failed for NVRAM at 0x54000000

it seems to me like you might have problems with your NVRAM

(CRC32 failed for NVRAM at 0x......

Erasing NVRAM area at 0x....)

then

So I'd try to

1) backup the running config to tftp server

2) wr erase - clears the NVRAM

3) wr - saves the running config to the start-up config

4) sh start-up - checks if the wr command was successful

5) sh ver

The error message might disappear.

If it remains, I'd reload the switch. It's a little dangerous - if the NVRAM is damaged, you might loose your complete config.

6) confreg .....- set the config reisters to proper value in ROM monitor mode

7) boot ..... - manually from ROM monitor

8) sh ver - check the registers and NVRAM problem

Regards,

Please rate if it helps.

View solution in original post

Highlighted

now its a new problem altogether...

i changed the config register values to 0x2012 did a reload and everything was working fine...

the very next day..the Router automatically stopped responding.. when logged in through console the IOS was automatically deleted from the flash. there was not a single file on flash.

I reinstalled the IOS through Tftp but again after some random time the ios is erased from the flash automatically without any power cycle or so.

please help

Content for Community-Ad