cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

228
Views
5
Helpful
2
Replies
Highlighted
Beginner

Configure NAT with specific destination IP address

Capture.PNG

with diagram:

I want Host A NAT to IP 111.1.1.2 when host A access to 2.2.2.2 and don't need NAT when Host A access to other IP.

NOTE: on router doesn't have other NAT rule.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Re: Configure NAT with specific destination IP address

Hello,

 

try the below configuration:

 

interface GigabitEthernet0/0
description Uplink to ISP
ip address 111.1.1.1 255.255.255.0
ip nat outside
!
interface GigabitEthernet0/1
description LAN Interface
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip nat inside source static 192.168.1.10 111.1.1.2 route-map HOST_NAT
ip route 0.0.0.0 0.0.0.0 111.1.1.254
!
route-map HOST_NAT permit 10
match ip address 101
!
access-list 101 permit ip host 192.168.1.10 host 2.2.2.2

View solution in original post

2 REPLIES 2
Highlighted
VIP Mentor

Re: Configure NAT with specific destination IP address

Hello,

 

try the below configuration:

 

interface GigabitEthernet0/0
description Uplink to ISP
ip address 111.1.1.1 255.255.255.0
ip nat outside
!
interface GigabitEthernet0/1
description LAN Interface
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip nat inside source static 192.168.1.10 111.1.1.2 route-map HOST_NAT
ip route 0.0.0.0 0.0.0.0 111.1.1.254
!
route-map HOST_NAT permit 10
match ip address 101
!
access-list 101 permit ip host 192.168.1.10 host 2.2.2.2

View solution in original post

Highlighted
VIP Mentor

Re: Configure NAT with specific destination IP address

Hello

The nat statement @Georg Pauwen has provided shuld accomodate your request -  However you say


@ratha chum wrote:

with diagram:

I want Host A NAT to IP 111.1.1.2 when host A access to 2.2.2.2 and don't need NAT when Host A access to other IP.


Can you confirm  192.168.1.0/24 subnet is then reachable externally, if this is the case then this specific internal host will also be.

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future