12-02-2020 02:27 PM
I have a simple network and I am practicing for the CCNA exam through practice in Packet tracer. I successfully managed to configure a Server to work as the DHCP but I am having difficulty in configuring Cisco router to act as a DHCP server.
Router 0
Router(config)#ip dhcp pool 192
Router(dhcp-config)#network 192.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.10.10.1
Router(dhcp-config)#dns-server 10.10.10.1
Router(dhcp-config)#exit
Router(config)#ip dhcp pool 172
Router(dhcp-config)#network 172.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 172.10.10.1
Router(dhcp-config)#dns-server 10.10.10.1
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.10.0/30 is directly connected, GigabitEthernet0/0
L 10.10.10.1/32 is directly connected, GigabitEthernet0/0
C 10.10.11.0/30 is directly connected, GigabitEthernet0/1
L 10.10.11.1/32 is directly connected, GigabitEthernet0/1
R 10.10.12.0/30 [120/1] via 10.10.10.2, 00:00:20, GigabitEthernet0/0
[120/1] via 10.10.11.2, 00:00:06, GigabitEthernet0/1
R1
Router(config)#interface gig 0/1
Router(config-if)#ip helper-address 10.10.10.1
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.10.0/30 is directly connected, GigabitEthernet0/0
L 10.10.10.2/32 is directly connected, GigabitEthernet0/0
R 10.10.11.0/30 [120/1] via 10.10.10.1, 00:00:06, GigabitEthernet0/0
C 10.10.12.0/30 is directly connected, GigabitEthernet0/2
L 10.10.12.2/32 is directly connected, GigabitEthernet0/2
192.10.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.10.10.0/24 is directly connected, GigabitEthernet0/1
L 192.10.10.1/32 is directly connected, GigabitEthernet0/1
RIP version 2 is configured on all routers.
Ive looked at numerous tutorials and Im not sure why this is not working as Ive completed the same steps. Thanks for the help!
Solved! Go to Solution.
12-02-2020 05:27 PM
Hi,
I saw your configurations on all routers and switches. You will need to make few changes so that the PCs will receive IP addresses and PING each other.
Here are the changes you need to make:-
==> On Router1
int gi0/1
no ip address
int gi0/1.1
encapsulation dot1q 1
ip address 192.10.10.1 255.255.255.0
ip helper-address 10.10.10.1
!
router rip
network 192.10.10.0
end
wr mem
==> On Router2
int gi0/0
no ip add
int gi0/0.1
encapsulation dot1q 1
ip add 172.10.10.1 255.255.255.0
ip helper-address 10.10.10.1
!
router rip
network 172.10.10.0
!
end
wr mem
The main issues were Layer3 to Layer2 connectivity between Routers and Switches, and Router0 does not know how to reach to both 192.10.10.0/24 and 172.10.10.0/24... I did not include detailed explanation on why you will need to make those changes. I just provided you the required changes.
HTH,
12-02-2020 02:57 PM
try exclude ip address and then check again.
12-02-2020 03:15 PM
Hello,
post the zipped Packet Tracer project (.pkt) file.
12-02-2020 04:08 PM
12-02-2020 05:27 PM
Hi,
I saw your configurations on all routers and switches. You will need to make few changes so that the PCs will receive IP addresses and PING each other.
Here are the changes you need to make:-
==> On Router1
int gi0/1
no ip address
int gi0/1.1
encapsulation dot1q 1
ip address 192.10.10.1 255.255.255.0
ip helper-address 10.10.10.1
!
router rip
network 192.10.10.0
end
wr mem
==> On Router2
int gi0/0
no ip add
int gi0/0.1
encapsulation dot1q 1
ip add 172.10.10.1 255.255.255.0
ip helper-address 10.10.10.1
!
router rip
network 172.10.10.0
!
end
wr mem
The main issues were Layer3 to Layer2 connectivity between Routers and Switches, and Router0 does not know how to reach to both 192.10.10.0/24 and 172.10.10.0/24... I did not include detailed explanation on why you will need to make those changes. I just provided you the required changes.
HTH,
12-04-2020 05:48 AM
Meheretab,
Thank you based in the info you provided I was able to make the changes and configure. You were right, router 0 did not know how to reach the other networks and adding the networks to router rip on Router 1 and 2 resolved the issue. Dot 1q was not needed as yet as I had not yet configured any VLAN information but it is on the to do list.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide