04-21-2021 12:30 AM - edited 04-21-2021 12:32 AM
Am doing some beginner labwork and am stumped on something that has to be really simple.....hasnt it!
I can configure ip addresses in router port f0/0 & 0/1 not a problem using the following series of commands
However when I try to do exactly the same for fa 1/0 I get this
The ‘?’ help menus at the route of the ‘int’ config are different too
Then on this interface
Why is this? Banging my head against this for a while now
This is what my network looks like -
Solved! Go to Solution.
04-21-2021 12:45 AM - edited 04-21-2021 12:46 AM
Hello Julian,
the fa1/0 is part of an etherswitch module and so it behaves like a L2 switch port ( note the switchport command)
You may have two options:
a)
int fas1/0
! the following command changes the port to a routed port
no switchport
ip address .......
b) USe an SVI
interface vlan 1
ip address x.x.x.x 255.255.255.0
no shut
int fas1/0
switchport
switchport mode access
One of the two methods should work
Hope to help
Giuseppe
04-21-2021 04:20 AM
Hello
it may be a pure l2 interface as such you would need to create a L3 vlan SVI interface as suggest by Giuseppe and assign the vlan to that interface.
04-21-2021 12:43 AM - edited 04-21-2021 12:43 AM
Hello
Looks like that interface is a Layer 2 interface at present, try the following:
int fa1/0
no switchport
04-21-2021 12:45 AM - edited 04-21-2021 12:46 AM
Hello Julian,
the fa1/0 is part of an etherswitch module and so it behaves like a L2 switch port ( note the switchport command)
You may have two options:
a)
int fas1/0
! the following command changes the port to a routed port
no switchport
ip address .......
b) USe an SVI
interface vlan 1
ip address x.x.x.x 255.255.255.0
no shut
int fas1/0
switchport
switchport mode access
One of the two methods should work
Hope to help
Giuseppe
04-21-2021 01:27 AM
Hi Paul
Thanks for the reply. Though that would be it however can you comment futher?
I have completed as the solution
However i have this now as output. I must be missing something!!!
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fas 1/0
Router(config-if)#no sw
Router(config-if)#no switchport
% Incomplete command.
Router(config-if)#
Really very much appreciate your help and already happy that i know the interface can be configured!!
Cheers
Julian
04-21-2021 02:06 AM
Hello Julian,
if no switchport does not work you need to use an SVI interface VLAN where you put the IP address that is option b) in my previous answer.
Be aware that Vlan 1 is default.
If you use VLAN x
then you need
inteface fas1/0
switchport
switchport mode access
switchport access vlan x
Hope to help
Giuseppe
04-21-2021 03:23 AM
04-21-2021 04:20 AM
Hello
it may be a pure l2 interface as such you would need to create a L3 vlan SVI interface as suggest by Giuseppe and assign the vlan to that interface.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide