cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
328
Views
1
Helpful
3
Replies

Configuring Frame Routed IPs given from the ISP

exulan
Level 1
Level 1
 
I am with Aussie Broadband in Australia, and they distribute additional IPs in a somewhat odd way. Aussie Broadband issues the primary address through DHCP, and then the additional IPs you lease are frame-routed via the primary. It's almost like you have to configure the interface as follows:

interface g0/0
ip address dhcp
ip address 203.XXX.XXX.1 255.255.255.248 secondary

However, from what I've seen, this isn't possible.

You can manually assign the DHCP address as static, but the connection drops after 30 minutes. To regain the connection, you must "shutdown" and then "no shutdown" the interface, essentially restarting it. The primary IP is 159.XXX.XXX.138, while 203.XXX.XXX.0/29 and 180.XXX.XXX.92/30 are the additional IPs that are frame-routed via the primary.

My end goal is really to be able to port forward/DNAT and SNAT to these additional IPs. I'm just stumped on how to do this.

 
1 Accepted Solution

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @exulan ,

you can use loopack interfaces to handle the public IP address pools

int loop 10

ip address 203.X.X.1 255.255.255.248

int loop 20

ip address 180.x.x.93 255.255.255.252

then you define your NAT pools and  your NAT statements as needed

Hope to help

Giuseppe

 

 

 

 

View solution in original post

3 Replies 3

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @exulan ,

you can use loopack interfaces to handle the public IP address pools

int loop 10

ip address 203.X.X.1 255.255.255.248

int loop 20

ip address 180.x.x.93 255.255.255.252

then you define your NAT pools and  your NAT statements as needed

Hope to help

Giuseppe

 

 

 

 

Thank you! It worked, I would have never thought of that.

! Configure the NAT Pools
ip nat pool 203 203.XXX.XXX.1 203.XXX.XXX.6 netmask 255.255.255.248
ip nat pool 180 180.XXX.XXX.92 180.XXX.XXX.95 netmask 255.255.255.252

! Setup the loopback interface for one of the frame routed IPs
interface Loopback2031
ip address 203.XXX.XXX.1 255.255.255.248


! Access Lists for the IPs
ip access-list extended Laptop_SNAT
permit ip host 10.199.15.30 any

ip access-list extended Main_Network
permit ip 10.199.15.100 0.0.0.155 any

ip access-list extended Server_Network
permit ip 10.38.48.100 0.0.0.155 any


! SNAT
ip nat inside source list Laptop interface Loopback2031 overload
ip nat inside source list Main_Network interface GigabitEthernet0/0 overload
ip nat inside source list Server_Network interface GigabitEthernet0/0 overload

! Port Forwarding
ip nat inside source static tcp 10.199.15.30 80 interface Loopback2031 80

Thanks for solving the main issue but I have encountered another problem, 

interface Loopback 203
ip address 203.129.29.0 255.255.255.248
ip address 203.129.29.1 255.255.255.248 secondary
ip address 203.129.29.2 255.255.255.248 secondary
ip address 203.129.29.3 255.255.255.248 secondary
ip address 203.129.29.4 255.255.255.248 secondary
ip address 203.129.29.5 255.255.255.248 secondary
ip address 203.129.29.6 255.255.255.248 secondary
ip address 203.129.29.7 255.255.255.248 secondary

interface Loopback 180
ip address 180.150.15.92 255.255.255.252
ip address 180.150.15.93 255.255.255.252 secondary
ip address 180.150.15.94 255.255.255.252 secondary
ip address 180.150.15.95 255.255.255.252 secondary

Might seem odd but is there anyway to use the broadcast and network address? I do know all addresses are usable since they worked on my Ubiquiti router. 

Review Cisco Networking for a $25 gift card