cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
295
Views
5
Helpful
2
Replies

Creating route map and increasing BGP AD distance so it takes EIGRP

Hi all,

Looking to create an inbound route map which increase BGP AD distance of the subnets shown below so that the EIGRP route is preferred. What is the configuration needed to amended the BGP route on these subnets to say 175 so the 170 EIGRP route takes priority?

# show ip route 10.91.13.0
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

10.91.13.0/24, ubest/mbest: 1/0
via 10.175.160.2, Vlan1680, [170/52480], 16:44:47, eigrp-1, external, tag 65533
via 10.175.237.18, [20/0], 3w0d, bgp-65530, external, tag 65533

# show run eigrp

router eigrp 1
router-id 10.175.167.42
passive-interface default
redistribute bgp 65530 route-map BGP_TO_EIGRP_RM

interface Vlan1680
ip router eigrp 1
no ip passive-interface eigrp 1

 

#show run bgp

router bgp 65530
router-id 10.175.167.42
address-family ipv4 unicast
network 0.0.0.0/0
redistribute eigrp 1 route-map EIGRP_TO_BGP_RM
neighbor 10.175.237.2
remote-as 65532
password 3 5d616a9985dd94a179f5eb05edae0e7dbb8eeb5a3dd56cd7
address-family ipv4 unicast
route-map NSX_FILTER_RM out
neighbor 10.175.237.18
remote-as 65533
password 3 5d616a9985dd94a179f5eb05edae0e7dbb8eeb5a3dd56cd7
address-family ipv4 unicast
route-map NSX_FILTER_RM out
neighbor 10.175.237.34
remote-as 65534
password 3 5d616a9985dd94a179f5eb05edae0e7dbb8eeb5a3dd56cd7
address-family ipv4 unicast
route-map NSX_FILTER_RM out

 

 

Need AD Bumping up on Nexus 1
10.91.12.0/24
10.91.13.0/24
10.91.14.0/24
10.91.15.0/24

Need AD bumping up on Nexus2
10.91.8.0/24
10.91.9.0/24
10.91.10.0/24
10.91.11.0/24

2 Replies 2

M02@rt37
VIP
VIP

Hello support1@lima.co.uk 

Bellow, example of a PL called [EIGRP-PREFIXES] and a RM called [BGP-ADJUST]

ip prefix-list EIGRP-PREFIXES seq 5 permit 10.91.12.0/24
ip prefix-list EIGRP-PREFIXES seq 10 permit 10.91.13.0/24
ip prefix-list EIGRP-PREFIXES seq 15 permit 10.91.14.0/24
ip prefix-list EIGRP-PREFIXES seq 20 permit 10.91.15.0/24

route-map BGP-ADJUST permit 10
match ip address prefix-list EIGRP-PREFIXES
set distance 175

After that apply in inbound the RM on your bgp neighbor

router bgp 65530
neighbor 10.175.237.18
address-family ipv4 unicast
route-map BGP-ADJUST in

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.
Review Cisco Networking for a $25 gift card