10-01-2012 03:46 PM - edited 03-04-2019 05:43 PM
I'm trying to configure a Cisco 3800 with a WIC-2AM-V2 to do DDR. I've gotten it to work before, but it was a while and now the config doesn't seem to work. I'm using an Lo0 interface and ip unnumbered on the Dialer interface. Using debug dialer and debug ppp and see nothing at all trying to dial out.
##############################################################
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname DDR
!
boot-start-marker
boot-end-marker
!
logging buffered 6000 debugging
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
voice-card 0
no dspfarm
!
!
chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
!
!
!
!
!
!
!
!
!
!
!
!
!
username ATC3262 password ###########
username ATC3262 autocommand ppp 192.168.128.6
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.128.5 255.255.255.252
!
interface GigabitEthernet0/0
ip address 10.10.100.152 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
description ******* BAD INTERFACE! DO NOT USE!!! *******
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface Async0/0/0
no ip address
encapsulation ppp
dialer in-band
dialer rotary-group 1
dialer-group 1
async dynamic address
async mode interactive
!
interface Async0/0/1
no ip address
encapsulation ppp
dialer in-band
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 120 either
dialer map ip 192.168.128.6 name ATC3262 1##########
dialer-group 1
ppp authentication chap callin
!
interface Dialer2
no ip address
!
router eigrp 99
passive-interface Loopback0
network 10.10.100.0 0.0.0.255
network 192.168.128.0
auto-summary
!
ip forward-protocol nd
ip route 10.100.1.0 255.255.255.248 192.168.128.6
!
!
ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line 0/0/0
modem InOut
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line 0/0/1
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 30 0
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
################################################################################
Thanks!
10-01-2012 10:12 PM
Todd
I have looked through the config that you posted. The first thing that I notice is your static route of
p route 10.100.1.0 255.255.255.248 192.168.128.6
The next hop address of 192.168.128.6 will be seen by the router as part of the subnet on the loopback interface and the router will attempt to forward there rather than sending the traffic through the dialer.
I am not sure why you are putting the address on the loopback and then using ip unnumbered on the dialer. The simple fix would be to put the address on the dialer instead of the loopback. If there is some good reason to use ip unnumbered then you need to change something in your static route.
HTH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide