10-17-2021 07:43 PM - edited 10-17-2021 08:17 PM
Hi, VRF usually are used at interface so that making packet special. Please the two below configurations. Is there any different impact on dhcp pool between the two configurations? Thank you
Configuration 1:
ip vrf test1
rd 100:10
!
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface vlan 100
ip vrf forwarding test1
ip address 192.168.1.1 255.255.255.0
Configuration 2:
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface vlan 100
ip address 192.168.1.1 255.255.255.0
Solved! Go to Solution.
10-17-2021 11:45 PM
Hello,
configuration 1 won't work with adding the line marked in bold to the DHCP pool. Other than that, the difference is obviously that the first configuration only works in conjunction with a VRF...what are you after exactly ?
Configuration 1:
ip vrf test1
rd 100:10
!
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
--> vrf test1
!
interface vlan 100
ip vrf forwarding test1
ip address 192.168.1.1 255.255.255.0
Configuration 2:
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface vlan 100
ip address 192.168.1.1 255.255.255.0
10-17-2021 11:45 PM
Hello,
configuration 1 won't work with adding the line marked in bold to the DHCP pool. Other than that, the difference is obviously that the first configuration only works in conjunction with a VRF...what are you after exactly ?
Configuration 1:
ip vrf test1
rd 100:10
!
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
--> vrf test1
!
interface vlan 100
ip vrf forwarding test1
ip address 192.168.1.1 255.255.255.0
Configuration 2:
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface vlan 100
ip address 192.168.1.1 255.255.255.0
10-18-2021 06:42 AM
Thank you for your reply. After change as below, configuration1 and 2 would have the same effect?
Configuration 1:
ip vrf test1
rd 100:10
!
ip dhcp pool test1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
vrf test1
!
interface vlan 100
ip vrf forwarding test1
ip address 192.168.1.1 255.255.255.0
10-18-2021 02:26 PM
Hello,
one of the configs is without, the other with the VRF, so the latter only works if your clients are part of the VRF context as well.
I am still not really sure what you are asking...
10-18-2021 04:23 PM
Thank you Georg!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide