cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4360
Views
70
Helpful
31
Replies

DHCP Pool on VLAN with PC fixed address

victorc7
Level 1
Level 1

Hello,

 

I am trying to configure on a Catalyst 1000 switch a DHCP Server on network 192.168.1.0/24 with a fixed IP address of 192.168.1.10 for a PC Network with a specific MAC address.

 

Here is the steps I followed :

1) Type commands on Switch

conf t

ip dhcp pool 192.168.1.0
	network 192.168.1.0 255.255.255.0
	default-router 192.168.1.1
	exit

int vlan 1
	ip address pool 192.168.1.0
	exit

ip dhcp pool PC
	host 192.168.1.10
	hardware-address 01xx.xxxx.xxxx.xx
	exit

do sh ip dhcp pool

 

2) Check on Switch

Pool 192.168.1.0 :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 0
 Excluded addresses             : 1
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased/Excluded/Total
 192.168.1.1          192.168.1.1      - 192.168.1.254     0     / 1     / 254

Pool PC :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 1
 Leased addresses               : 1
 Excluded addresses             : 1
 Pending event                  : none
 0 subnet is currently in the pool :
 Current index        IP address range                    Leased/Excluded/Total
 192.168.1.10         192.168.1.10     - 192.168.1.10      1     / 1     / 1

 

3) Type commands on Switch

do clear ip dhcp binding *

 

 

4) Type commands on PC

ipconfig /release && ipconfig /renew

No IP delivered

 

5) Type commands on Switch

do sh interfaces

 

6) Check

Vlan1 is up, line protocol is up
Hardware is EtherSVI, address is XXXX.XXXX.XXXX (bia XXXX.XXXX.XXXX)
Internet address will be autoconfigured from local DHCP pool
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:22:34, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 packets output, 0 bytes, 0 underruns
0 output errors, 2 interface resets
1704 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
GigabitEthernet1/0/1 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is XXXX.XXXX.XXXX (bia XXXX.XXXX.XXXX)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:01:18, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 3000 bits/sec, 3 packets/sec
34620 packets input, 8502653 bytes, 0 no buffer
Received 4427 broadcasts (3590 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 3590 multicast, 0 pause input
0 input packets with dribble condition detected
62613 packets output, 37744232 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

7) Type commands on Switch

int gigabitEthernet 1/0/1
	shutdown
	no shutdown
	exit
	
do sh ip dhcp binding

 

Check

Bindings from all pools not associated with VRF:
IP address      Client-ID/              Lease expiration        Type       State      Interface
                Hardware address/
                User name
192.168.1.10     01xx.xxxx.xxxx.xx       Infinite                Manual     Selecting  Unknown

 

9) Type commands on PC

ipconfig /renew

No IP delivered

 

10) Type commands on Switch

ip dhcp pool 192.168.1.0
	network 192.168.1.0 255.255.255.0
	default-router 192.168.1.1
	address 192.168.1.10 hardware-address 01xx.xxxx.xxxx.xx

% Address 192.168.1.10 is not valid in this pool.

	exit

int vlan 1
	ip address 192.168.1.2 255.255.255.0
	exit

 

11) Type commands on PC

ipconfig /renew

=> Got 192.168.1.3

 

12) Type commands on Switch and Check

(config)#do sh ip dhcp binding
Bindings from all pools not associated with VRF: IP address Client-ID/ Lease expiration Type State Interface Hardware address/ User name 192.168.1.1 XXXX.XXXX.XXXX Apr 22 2021 12:57 AM Automatic Active Vlan1 192.168.1.3 01xx.xxxx.xxxx.xx Apr 22 2021 12:58 AM Automatic Active Vlan1 192.168.1.10 01xx.xxxx.xxxx.xx Infinite Manual Selecting Unknown (config)#do sh ip dhcp pool Pool 192.168.1.0 : Utilization mark (high/low) : 100 / 0 Subnet size (first/next) : 0 / 0 Total addresses : 254 Leased addresses : 2 Excluded addresses : 1 Pending event : none 1 subnet is currently in the pool : Current index IP address range Leased/Excluded/Total 192.168.1.4 192.168.1.1 - 192.168.1.254 4 / 3 / 254 Pool PC : Utilization mark (high/low) : 100 / 0 Subnet size (first/next) : 0 / 0 Total addresses : 1 Leased addresses : 1 Excluded addresses : 1 Pending event : none 0 subnet is currently in the pool : Current index IP address range Leased/Excluded/Total 192.168.1.10 192.168.1.10 - 192.168.1.10 1 / 1 / 1  

 

So I have an IP address but not using the one that is matching to the correct fixed pool.

31 Replies 31

Hello

If you cannot ping the rtr sourced from vlan 10 you wont be able reach the internet either, You do seem to have a valid static route on the rtr however as the switch is now correctly configured i tend to think its the rtr that's negating access.

What rtr do you have, have you tried rebooting the rtr?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

It is a NB6VAC modem.

I tried rebooting, redo a Routed port method with a another IP and modify Route to match but no more results.

I tried to put all clients on vlan 1 also without results.

Switch can ping 192.168.0.2 from g1/0/9 but not from other Vlan.

Router can ping 192.168.0.4 but not 192.168.1.1.

It seems they cannot access to other subnetworks.

I think my last chance is to put them on the same subnetwork.

However, I have to keep control of fixed assigned IP on the switch.

Review Cisco Networking for a $25 gift card