02-02-2019 08:34 AM
See attached diagram diagram of lab topology.
So OSPF 100 routes/interfaces communicate fine with BGP 65001, and likewise between EIGRP100 and BGP65000.
But routes from OSPF and EIGRP are not being shared through the 2 BGP Autonomous Systems meaning nothing from EIGRP 100 can ping anything from OSPF 100 and vise versa. The 2 BGP AS communicate just fine.
I just have basic BGP configs and know I am missing something just not sure what - see below.
R5#sh running-config | section eigrp
router eigrp 100
network 5.5.5.5 0.0.0.0
network 203.2.2.0
redistribute bgp 65000
redistribute eigrp 100
R5#sh running-config | section bgp
redistribute bgp 65000
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
----------------------------------------
R2#sh run | section ospf
router ospf 100
redistribute bgp 65001 subnets
network 4.4.4.4 0.0.0.0 area 1
network 10.3.3.0 0.0.0.255 area 1
R2#sh run | section bgp
redistribute bgp 65001 subnets
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
neighbor 203.1.1.1 remote-as 65000
Solved! Go to Solution.
02-02-2019 10:36 AM - edited 02-02-2019 10:41 AM
Hi, not sure what happened to pasting the config but I did have redistibute statements in BGP. I added some metrics for BGP resdis under EIGRP. Still not working however. Sh ip route on both R2 and R5 shows all advertised routes for each protocol in the whole topology. Again I can ping everything from R2 going back, and ping everthing from R5 going back, but still can only ping everything between R2 and R5 but nothing beyond each other.
How does the below config look now?
R2:
router ospf 100
router-id 4.4.4.4
redistribute bgp 65001
network 4.4.4.4 0.0.0.0 area 1
network 10.3.3.0 0.0.0.255 area 1
!
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
----------------
R5
router eigrp 100
network 5.5.5.5 0.0.0.0
network 203.2.2.0
redistribute bgp 65000 metric 44200 2000 255 1 1500
eigrp router-id 5.5.5.5
!
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
02-02-2019 03:33 PM - edited 02-02-2019 03:34 PM
I am only advertising the directly connected links between the bgp neighbor routers.
When I do the sh ip bgp neighbor 203.1.1.2/1 advertised-routes on each router, it is displaying learned routes of its own from EIGRP (if R5) or OSPF (if R2). See below corresponding configs and SHOW below. I also attached another topology with some IPs to help and kinda drew circles to group the routing processes.
R5#sh run | section bgp
redistribute bgp 65000 metric 44200 2000 255 1 1500
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
R5#sh ip bgp neighbor 203.1.1.2 advertised-routes
BGP table version is 34, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 5.5.5.5/32 0.0.0.0 0 32768 i
*> 6.6.6.6/32 203.2.2.1 2297856 32768 ?
*> 7.7.7.7/32 203.2.2.1 2298112 32768 ?
*> 8.8.8.8/32 203.2.2.1 2810112 32768 ?
*>i11.11.11.11/32 203.3.3.2 0 100 0 i
*> 172.16.1.0/30 203.2.2.1 2682112 32768 ?
*> 203.2.2.0/30 0.0.0.0 0 32768 ?
*> 203.3.3.0/30 0.0.0.0 0 32768 i
-----------------------------------------------------------
R2#sh running-config | section bgp
redistribute bgp 65001
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
R2#sh ip bgp neighbor 203.1.1.1 advertised-routes
BGP table version is 34, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 10.3.3.1 130 32768 ?
*> 2.2.2.2/32 10.3.3.1 129 32768 ?
*> 3.3.3.3/32 10.3.3.1 65 32768 ?
*> 4.4.4.4/32 0.0.0.0 0 32768 i
*> 10.1.1.0/30 10.3.3.1 129 32768 ?
*> 10.2.2.0/30 10.3.3.1 128 32768 ?
*> 10.3.3.0/30 0.0.0.0 0 32768 ?
*> 11.1.1.0/30 10.3.3.1 130 32768 ?
*> 12.12.12.12/32 10.3.3.1 131 32768 ?
02-02-2019 03:34 PM
Hello
Just like to add , Try adding the R2 add network statements for both its bgp connected interfaces, and on R5 do the same in eigrp/bgp processes.
Also do you see these redistributed routes but cannot reach them or dont you even see them?
R3
sh ip route ospf
sh ip bgp
R2
sh ip bgp
sh ip route
R5
sh ip bgp
sh ip route
02-02-2019 05:51 PM
Hi CiscoBlueBelt,
Your updated diagram is a lot different from the first one you posted at the beginning. Since you didn't indicate your OSPF and EIGRP domains in the new diagram, may I ask, based on your config on R5, why you are running both BGP and EIGRP between R2 and R5 ?
Your latest diagram doesn't represent your configs. What I interpret is follows:
Diagram:
R2 - Participates in EIGRP (203.1.1.0), OSPF and BGP (203.1.1.0)
R5 - Participates in EIGRP and BGP
Configuration:
R2 - Participates in OSPF and BGP (203.1.1.0)
R5 - Participates in EIGRP (203.1.1.0) and BGP (203.1.1.0)
If R2 and R5 are EIGRP neighbors, then they would learn EIGRP networks. For OSPF and BGP behind R2 to learn EIGRP, they need EIGRP redistributed and BGP needs OSPF redistribution.
For BGP and EIGRP in R5 to learn OSPF, they need nothing, as R2 would send OSPF into both BGP and EIGRP.
02-02-2019 08:42 AM - edited 02-02-2019 08:42 AM
Couple of things stand out.
Firstly when you redistribute another routing protocol into EIGRP you need to specify a metric and secondly you don't seem to be redistributing OSPF into BGP at all.
Jon
02-02-2019 10:36 AM - edited 02-02-2019 10:41 AM
Hi, not sure what happened to pasting the config but I did have redistibute statements in BGP. I added some metrics for BGP resdis under EIGRP. Still not working however. Sh ip route on both R2 and R5 shows all advertised routes for each protocol in the whole topology. Again I can ping everything from R2 going back, and ping everthing from R5 going back, but still can only ping everything between R2 and R5 but nothing beyond each other.
How does the below config look now?
R2:
router ospf 100
router-id 4.4.4.4
redistribute bgp 65001
network 4.4.4.4 0.0.0.0 area 1
network 10.3.3.0 0.0.0.255 area 1
!
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
----------------
R5
router eigrp 100
network 5.5.5.5 0.0.0.0
network 203.2.2.0
redistribute bgp 65000 metric 44200 2000 255 1 1500
eigrp router-id 5.5.5.5
!
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
02-02-2019 10:42 AM
It's difficult to say because there are no IPs on your network diagram.
You have some network statements under BGP that don't look right, what are these doing if you are redistributing EIGRP and OSPF into BGP ?
On both BGP routers do a "sh ip bgp neigh <IP address of other BGP router> advertised-routes" and see if the routes are being advertised to the other router.
Jon
02-02-2019 03:33 PM
I am only advertising the directly connected links between the bgp neighbor routers.
When I do the sh ip bgp neighbor 203.1.1.2/1 advertised-routes on each router, it is displaying learned routes of its own from EIGRP (if R5) or OSPF (if R2). See below corresponding configs and SHOW below. I also attached another topology with some IPs to help and kinda drew circles to group the routing processes.
R5#sh run | section bgp
redistribute bgp 65000 metric 44200 2000 255 1 1500
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
R5#sh ip bgp neighbor 203.1.1.2 advertised-routes
BGP table version is 34, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 5.5.5.5/32 0.0.0.0 0 32768 i
*> 6.6.6.6/32 203.2.2.1 2297856 32768 ?
*> 7.7.7.7/32 203.2.2.1 2298112 32768 ?
*> 8.8.8.8/32 203.2.2.1 2810112 32768 ?
*>i11.11.11.11/32 203.3.3.2 0 100 0 i
*> 172.16.1.0/30 203.2.2.1 2682112 32768 ?
*> 203.2.2.0/30 0.0.0.0 0 32768 ?
*> 203.3.3.0/30 0.0.0.0 0 32768 i
-----------------------------------------------------------
R2#sh running-config | section bgp
redistribute bgp 65001
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
R2#sh ip bgp neighbor 203.1.1.1 advertised-routes
BGP table version is 34, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 10.3.3.1 130 32768 ?
*> 2.2.2.2/32 10.3.3.1 129 32768 ?
*> 3.3.3.3/32 10.3.3.1 65 32768 ?
*> 4.4.4.4/32 0.0.0.0 0 32768 i
*> 10.1.1.0/30 10.3.3.1 129 32768 ?
*> 10.2.2.0/30 10.3.3.1 128 32768 ?
*> 10.3.3.0/30 0.0.0.0 0 32768 ?
*> 11.1.1.0/30 10.3.3.1 130 32768 ?
*> 12.12.12.12/32 10.3.3.1 131 32768 ?
02-02-2019 03:33 PM - edited 02-02-2019 03:34 PM
I am only advertising the directly connected links between the bgp neighbor routers.
When I do the sh ip bgp neighbor 203.1.1.2/1 advertised-routes on each router, it is displaying learned routes of its own from EIGRP (if R5) or OSPF (if R2). See below corresponding configs and SHOW below. I also attached another topology with some IPs to help and kinda drew circles to group the routing processes.
R5#sh run | section bgp
redistribute bgp 65000 metric 44200 2000 255 1 1500
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 203.1.1.1
network 203.3.3.0 mask 255.255.255.252
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
R5#sh ip bgp neighbor 203.1.1.2 advertised-routes
BGP table version is 34, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 5.5.5.5/32 0.0.0.0 0 32768 i
*> 6.6.6.6/32 203.2.2.1 2297856 32768 ?
*> 7.7.7.7/32 203.2.2.1 2298112 32768 ?
*> 8.8.8.8/32 203.2.2.1 2810112 32768 ?
*>i11.11.11.11/32 203.3.3.2 0 100 0 i
*> 172.16.1.0/30 203.2.2.1 2682112 32768 ?
*> 203.2.2.0/30 0.0.0.0 0 32768 ?
*> 203.3.3.0/30 0.0.0.0 0 32768 i
-----------------------------------------------------------
R2#sh running-config | section bgp
redistribute bgp 65001
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 10.3.3.2
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
R2#sh ip bgp neighbor 203.1.1.1 advertised-routes
BGP table version is 34, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 10.3.3.1 130 32768 ?
*> 2.2.2.2/32 10.3.3.1 129 32768 ?
*> 3.3.3.3/32 10.3.3.1 65 32768 ?
*> 4.4.4.4/32 0.0.0.0 0 32768 i
*> 10.1.1.0/30 10.3.3.1 129 32768 ?
*> 10.2.2.0/30 10.3.3.1 128 32768 ?
*> 10.3.3.0/30 0.0.0.0 0 32768 ?
*> 11.1.1.0/30 10.3.3.1 130 32768 ?
*> 12.12.12.12/32 10.3.3.1 131 32768 ?
02-02-2019 01:10 PM - edited 02-02-2019 01:14 PM
R2:
router ospf 100
router-id 4.4.4.4
redistribute bgp 65001
For one, you're missing the subnets statement in the BGP redistribution command under the OSPF process.
Secondly, with no IPs in the diagram, it's difficult to understand your network statements. Hope you aren't advertising what you're redistributing?
02-02-2019 03:20 PM
Hi,
'next-hop-self' ?
02-02-2019 03:35 PM
02-02-2019 03:47 PM - edited 02-03-2019 12:43 AM
I was playing with EIGRP named mode config .. just extended to lab your question.
IOU5#sh run | b router router eigrp TEST ! address-family ipv4 unicast autonomous-system 100 ! topology base redistribute bgp 100 metric 10000 100 255 1 1500 exit-af-topology network 10.0.35.0 0.0.0.255 exit-address-family ! router bgp 100 bgp log-neighbor-changes redistribute eigrp 100 neighbor 20.20.20.1 remote-as 200
IOU6#sh run | b router router bgp 200 bgp log-neighbor-changes network 200.0.0.0 mask 255.255.255.252 neighbor 20.20.20.2 remote-as 100 neighbor 200.0.0.2 remote-as 200 neighbor 200.0.0.2 next-hop-self
IOU7#sh run | b router router ospf 1 redistribute bgp 200 subnets network 172.31.78.0 0.0.0.255 area 0 default-information originate ! router bgp 200 bgp log-neighbor-changes redistribute ospf 1 neighbor 200.0.0.1 remote-as 200 neighbor 200.0.0.1 next-hop-self
ip route 0.0.0.0 0.0.0.0 Null0
IOU1#ping 111.111.111.111 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 111.111.111.111, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms IOU1# IOU8#ping 10.0.12.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.0.12.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms IOU8#
02-02-2019 03:34 PM
Hello
Just like to add , Try adding the R2 add network statements for both its bgp connected interfaces, and on R5 do the same in eigrp/bgp processes.
Also do you see these redistributed routes but cannot reach them or dont you even see them?
R3
sh ip route ospf
sh ip bgp
R2
sh ip bgp
sh ip route
R5
sh ip bgp
sh ip route
02-02-2019 03:41 PM - edited 02-02-2019 04:19 PM
BGP is not running on R3, only R2 and R5 - see updated attached topology.
If I do sho ip route or the sh ip bgp, I can see all networks (the 1.1.1.1 or 2.2.2.2 etc. are loopback 0 for Routers 1 and router 2, etc.) but can't ping beyond the corresonding bgp neighbors which is R2 and R5 so R5 can ping R2, and R6-8, etc. and vise versa.
R2#sh ip bgp
BGP table version is 34, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 10.3.3.1 130 32768 ?
*> 2.2.2.2/32 10.3.3.1 129 32768 ?
*> 3.3.3.3/32 10.3.3.1 65 32768 ?
*> 4.4.4.4/32 0.0.0.0 0 32768 i
*> 5.5.5.5/32 203.1.1.1 0 0 65000 i
*> 6.6.6.6/32 203.1.1.1 2297856 0 65000 ?
*> 7.7.7.7/32 203.1.1.1 2298112 0 65000 ?
*> 8.8.8.8/32 203.1.1.1 2810112 0 65000 ?
*> 10.1.1.0/30 10.3.3.1 129 32768 ?
*> 10.2.2.0/30 10.3.3.1 128 32768 ?
*> 10.3.3.0/30 0.0.0.0 0 32768 ?
*> 11.1.1.0/30 10.3.3.1 130 32768 ?
*> 11.11.11.11/32 203.1.1.1 0 65000 i
*> 12.12.12.12/32 10.3.3.1 131 32768 ?
*> 172.16.1.0/30 203.1.1.1 2682112 0 65000 ?
*> 203.2.2.0/30 203.1.1.1 0 0 65000 ?
Network Next Hop Metric LocPrf Weight Path
*> 203.3.3.0/30 203.1.1.1 0 0 65000 i
-------------------------------------
R5#sh ip bgp
BGP table version is 34, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 203.1.1.2 130 0 65001 ?
*> 2.2.2.2/32 203.1.1.2 129 0 65001 ?
*> 3.3.3.3/32 203.1.1.2 65 0 65001 ?
*> 4.4.4.4/32 203.1.1.2 0 0 65001 i
*> 5.5.5.5/32 0.0.0.0 0 32768 i
*> 6.6.6.6/32 203.2.2.1 2297856 32768 ?
*> 7.7.7.7/32 203.2.2.1 2298112 32768 ?
*> 8.8.8.8/32 203.2.2.1 2810112 32768 ?
*> 10.1.1.0/30 203.1.1.2 129 0 65001 ?
*> 10.2.2.0/30 203.1.1.2 128 0 65001 ?
*> 10.3.3.0/30 203.1.1.2 0 0 65001 ?
*> 11.1.1.0/30 203.1.1.2 130 0 65001 ?
*>i11.11.11.11/32 203.3.3.2 0 100 0 i
*> 12.12.12.12/32 203.1.1.2 131 0 65001 ?
*> 172.16.1.0/30 203.2.2.1 2682112 32768 ?
*> 203.2.2.0/30 0.0.0.0 0 32768 ?
Network Next Hop Metric LocPrf Weight Path
* i203.3.3.0/30 203.3.3.2 0 100 0 i
*> 0.0.0.0 0 32768 i
02-02-2019 03:58 PM
You may have attached the wrong file :)
02-02-2019 04:21 PM - edited 02-02-2019 04:26 PM
Sorry I updated the last thread and here is it as well.
I also updated my configs, still can NOW ping everything from R2, but still can't ping beyond R2 from R5.
R2#sh run | b router
router ospf 100
router-id 4.4.4.4
redistribute bgp 65001 subnets
network 4.4.4.4 0.0.0.0 area 1
network 10.3.3.0 0.0.0.255 area 1
default-information originate
!
router bgp 65001
bgp router-id 4.4.4.4
bgp log-neighbor-changes
redistribute ospf 100
neighbor 203.1.1.1 remote-as 65000
-------------------------------------
R5#sh run | b router
router eigrp 100
network 5.5.5.5 0.0.0.0
network 203.1.1.0 0.0.0.3
network 203.2.2.0 0.0.0.3
redistribute bgp 65000 metric 10000 100 255 1 1500
eigrp router-id 5.5.5.5
!
router bgp 65000
bgp router-id 5.5.5.5
bgp log-neighbor-changes
redistribute eigrp 100
neighbor 203.1.1.2 remote-as 65001
neighbor 203.3.3.2 remote-as 65000
02-02-2019 05:51 PM
Hi CiscoBlueBelt,
Your updated diagram is a lot different from the first one you posted at the beginning. Since you didn't indicate your OSPF and EIGRP domains in the new diagram, may I ask, based on your config on R5, why you are running both BGP and EIGRP between R2 and R5 ?
Your latest diagram doesn't represent your configs. What I interpret is follows:
Diagram:
R2 - Participates in EIGRP (203.1.1.0), OSPF and BGP (203.1.1.0)
R5 - Participates in EIGRP and BGP
Configuration:
R2 - Participates in OSPF and BGP (203.1.1.0)
R5 - Participates in EIGRP (203.1.1.0) and BGP (203.1.1.0)
If R2 and R5 are EIGRP neighbors, then they would learn EIGRP networks. For OSPF and BGP behind R2 to learn EIGRP, they need EIGRP redistributed and BGP needs OSPF redistribution.
For BGP and EIGRP in R5 to learn OSPF, they need nothing, as R2 would send OSPF into both BGP and EIGRP.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide