03-20-2011 02:19 PM - edited 03-04-2019 11:48 AM
dear all ... i have one router and one switch cisco .. i connect the router with the switch by two trunk port ... then i creat many of VLAN .. i need to devided the traffic flow from the router to switch on to the two trunk .. how can do that ... regards
03-21-2011 01:14 PM
Sorry, but could you please rephrase the question. If you want any number of VLANs. all you can do is create sub-interface on the router port using an example below and configure as many vlans you need on the switch for eg.
Router (fa0/0)-------Trunk----------(Fa0/0)Switch
Both fa0/0 connects to each other.
Router Switch
Int fa 0/0 Int fa 0/0
no shut switchport
int fa 0/0.10 switch trunk encap dot1q
encap dot1q 10 switch mode trunk
ip add x.x.x.x x.x.x.x no shutdown
int fa 0/0.20
encap dot1q 20
ip add y.y.y.y y.y.y.y
int fa 0/0.30
encap dot1q 30
ip add z.z.z.z z.z.z.z
.............
............
...so on...
If this post help. Do rate it.
--
Sebastian Fernandez
03-22-2011 09:08 AM
thank you very much ... i need divide the traffic on the two interface using bonding ... how can that ?? each interface carry 1Gbps
03-21-2011 08:38 PM
Hi Tariq,
I think you are looking for etherchannel solution.
I am not completely sure as how to setup between switch and router. I am having similar setup in my network but the router is juniper one.
I am sure it will support cisco too.
Below is sample config for cisco. You can now create sub interface on router (e.g int po15.101, int po15.102 etc) for corresponding vlan configured on switch.
========================================
Switch
interface Port-channel15
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 15 mode on
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 15 mode on
Router:
interface Port-channel15
no ip address
interface GigabitEthernet0/0
no ip address
channel-group 15
!
interface GigabitEthernet0/1
no ip address
channel-group 15
====================================
Regards
Mahesh
03-22-2011 09:06 AM
thank you very much ... i need divide the traffic on the two interface using bonding ... how can that ??
03-24-2011 12:06 PM
ok thank you very much
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide