cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
377
Views
0
Helpful
2
Replies
AvidPontoon
Beginner

DMVPN OSPF Routing table wiped

Hi All,

 

I have the attached an image of my topology.

 

Down in the left corner is 'London' and I am using the top 'dallas' as the hub for DMVPN.

 

I am having a problem in London where the ospf routing table is being wiped on the router.

 

This is what the ospf routing table looks like on CUST_LON without an OSPF adjacency with the Layer 3 switch below it:

 

CUST_LON# show ip route ospf 
O IA 192.168.0.0/24 [110/11121] via 172.16.1.3, 00:00:00, Tunnel0
O IA 192.168.2.0/24 [110/11121] via 172.16.1.1, 00:00:00, Tunnel0

 

These two networks shown are behind the DALLAS and SYDNEY routers. Unfortunately when the switch below the CUST_LON router forms an OSPF adjacency, the 'show ip route ospf' comes back blank with no routes so the VPN does not work.

 

CUST_LON#show ip route ospf     

CUST_LON#

 

I don't understand what is happening, here is another helpful output (1.1.1.1 is switch and 9.9.9.11 is the hub router):

 

CUST_LON# show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   2WAY/DROTHER    00:00:31    192.168.1.254   FastEthernet0/1
9.9.9.11        255   FULL/DR         00:00:34    172.16.1.1      Tunnel0

 

L3Switch# show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
9.9.9.10          0   2WAY/DROTHER    00:00:33    192.168.1.1     Vlan1

 

I have attached the configs from the Switch and CUST_LON.

 

Please could someone tell me why the ospf routing table is wiped when the switch forms an adjacency and how to fix it?

2 REPLIES 2
Kevin Rivest
Beginner

The first issue is either f0/1 on CUST_LON or the VLAN 1 SVI on the switch need to have a non-0 priority set. If they are both set to zero with OSPF broadcast network type neither will become DR and the adjacency state will stay in 2way.  This means CUST_LON will not learn routes from the switch or vice versa.

 

The second issue, I am guessing since I see the routes on CUST_LON being learnt as inter-area, is that you have a discontiguous area 0. Your networks on the switch are in area 0 and your tunnel network is in area 11 and set as a stub network. I am guessing the networks behind CUST_DALLAS and CUST_SYDNEY are also in area 0. That means you have area 0 islands trying to ride on top of a stub area 11. That would not work even if it was not a stub area unless you bridge them together with virtual links. Area 0 must be unbroken. I would recommend that you change the networks sitting behind the routers to area 11 and set the tunnel networks in area 0.

 

Make the following changes.

 

CUST_LON :

 

interface Tunnel0
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip nhrp map 172.16.1.1 46.101.3.2
ip nhrp map multicast 46.101.3.2
ip nhrp network-id 10
ip nhrp nhs 172.16.1.1
ip ospf network broadcast
ip ospf priority 10
ip ospf 1 area 0
tunnel source FastEthernet0/0
tunnel mode gre multipoint

!

interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip ospf priority 1
duplex auto
speed auto

!
router ospf 1
log-adjacency-changes
area 11 stub
network 172.16.0.0 0.0.255.255 area 0
network 192.168.1.0 0.0.0.255 area 11

SWITCH :

 

router ospf 1
router-id 1.1.1.1

area 11 stub
network 192.168.1.0 0.0.0.255 area 11
network 192.168.100.0 0.0.0.255 area 11

 

CUST_DALLAS :

 

interface tunnel0

ip ospf 1 area 0

!

interface FastEthernet0/1

ip ospf 1 area 11

 

CUST_SYDNEY :

 

interface tunnel0

ip ospf 1 area 0

!

interface FastEthernet0/1

ip ospf 1 area 11

 

Hopefully that fixes everything for you.

Deepak Kumar
VIP Advocate

Hi,

Let start your solution with the question "What is the aim of DR in the Broadcast network in OSPF?"

 

Within OSPF, the role of the Designated Router (DR) and a Backup Designated Router (BDR) is to act as a central point for exchanging of OSPF information between multiple routers on the same, multiaccess broadcast network segment. Non-DR and non-BDR routers only exchange routing information with the DR and BDR, rather than exchanging updates with every other router upon the segment. This, in turn significantly reduces the amount of OSPF routing updates that need to be sent.

 

Now try to understand what is happing with your lab?

L3 Switch Configuration:

interface Vlan1
 ip address 192.168.1.254 255.255.255.0
 ip ospf priority 0  -----> You forced to Switch ,Don't put your self in DR/BDR ELECTION Process

Router Configuration:

interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip ospf priority 0 --->You forced to Router ,Don't put your self in DR/BDR ELECTION Process
 duplex auto
 speed auto

Now both Switch and route is not a part of DR/BDR election process means both are waiting for any other router who will become DR\BDR and after that, both will send an update to elected DR router. 

 

2-WAY: Each router (Router and Switch) form the 2-way neighbor state. This means that they both send/receive each other's HELLO's, but no routing updates are exchanged between one another.

 

Solution:

A router is a central point between DMVPN and Internal Network so make it DR:

 

interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip ospf priority 10
 duplex auto
 speed auto
Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!