- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-23-2018 04:17 AM - edited 03-05-2019 10:09 AM
Hi all,
I am implementing a solution for a client that requires the use of two wan links, with the secondary one as backup and main as primary. I also need to implement QOS on 20mb link with 19 for data and 1mb for voice.
Please could anyone provide some help as to the best way to implement this?
Just finished my CCNA, but this is a bit out of my depth.
Thanks in advance.
Solved! Go to Solution.
- Labels:
-
Other Routing
Accepted Solutions

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-24-2018 04:09 AM
Hi
regarding primary and backup it's not clear to me if you are intended to use one router or two, which kind of routing protocol are you going to use over the WAN links and the LAN architecture. Please give some more detail or, even better, attach a network diagram.
QoS for VoIP over WAN link is not easy because it depends on many things, for example the WAN characteristics. Usually I have also to "mark" Voice packet to ensure that QoS is applied all over the WAN network. Generally speaking I would suggest you to configure hierarchical QoS: first shape traffic to 20Mbps and then give 1M to voice using LLQ and 19M to other data traffic. If WAN link support some burst you could configure something like this:
class-map match-all VoIP
match access-group name VoIP-acl
<configure the ACL to match VoIP for example matching the voice VLAN>
policy-map qos
class VoIP
priority 1000
class class-default
bandwidth 19000
policy-map shaping
class class-default
shape average 20000000
service-policy qos
Better config could distinguish between VoIP signaling and RTP stream and you should use QoS also over the LAN, probably you have enough bandwidth but I have to ensure also low delay and jitter.
Bye,
e
Please rate if useful
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-14-2018 12:14 AM - edited 04-14-2018 12:17 AM
Hi,
I guess you can't configure an IGP to receive the default network from ISP1 (did you ask them if it is possible ?) so track could be appropriate. Obviously for production network you will configure a dialer for pppoe.
Over the WAN interface apply the LLQ (see my previous post) using
interf ...
service-policy shaping out
Bye,
enrico.
PS: rate if useful

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-24-2018 04:09 AM
Hi
regarding primary and backup it's not clear to me if you are intended to use one router or two, which kind of routing protocol are you going to use over the WAN links and the LAN architecture. Please give some more detail or, even better, attach a network diagram.
QoS for VoIP over WAN link is not easy because it depends on many things, for example the WAN characteristics. Usually I have also to "mark" Voice packet to ensure that QoS is applied all over the WAN network. Generally speaking I would suggest you to configure hierarchical QoS: first shape traffic to 20Mbps and then give 1M to voice using LLQ and 19M to other data traffic. If WAN link support some burst you could configure something like this:
class-map match-all VoIP
match access-group name VoIP-acl
<configure the ACL to match VoIP for example matching the voice VLAN>
policy-map qos
class VoIP
priority 1000
class class-default
bandwidth 19000
policy-map shaping
class class-default
shape average 20000000
service-policy qos
Better config could distinguish between VoIP signaling and RTP stream and you should use QoS also over the LAN, probably you have enough bandwidth but I have to ensure also low delay and jitter.
Bye,
e
Please rate if useful
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-01-2018 05:14 PM
Thanks E.
So sorry for my late reply.
The Primary link is going to go through PPPoE and the backup link via 4g.
I am trying to give voip priority queue at the egress port with 1mb and data lower priority with 19mb.
I have simulated two wan links in GNS3 to get this running. Please could you look at my config below and let me know how I can go about implementing this?
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
ip dhcp excluded-address 10.0.0.1 10.0.0.10
!
ip dhcp pool LAN1
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 8 ip sla 1 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description Towards Customer LAN
ip address 10.0.0.1 255.255.255.0
ip nat inside
duplex full
!
interface POS1/0
description Primary Link to ISP1
ip address 200.55.60.2 255.255.255.0
ip nat outside
shutdown
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
interface FastEthernet3/0
no ip address
shutdown
duplex full
!
interface POS4/0
description Backup Link to ISP2
ip address 201.55.60.2 255.255.255.252
ip nat outside
!
ip nat inside source route-map NAT_ISP1 interface POS1/0 overload
ip nat inside source route-map NAT_ISP2 interface POS4/0 overload
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 200.55.60.1 track 8
ip route 0.0.0.0 0.0.0.0 201.55.60.1 10
!
ip sla 1
icmp-echo 200.55.60.1 source-ip 200.55.60.2
ip sla schedule 1 life forever start-time now
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
!
route-map NAT_ISP2 permit 10
match ip address 101
match interface POS4/0
!
route-map NAT_ISP1 permit 10
match ip address 101
match interface POS1/0
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-14-2018 12:14 AM - edited 04-14-2018 12:17 AM
Hi,
I guess you can't configure an IGP to receive the default network from ISP1 (did you ask them if it is possible ?) so track could be appropriate. Obviously for production network you will configure a dialer for pppoe.
Over the WAN interface apply the LLQ (see my previous post) using
interf ...
service-policy shaping out
Bye,
enrico.
PS: rate if useful
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-09-2018 03:00 PM
Hi E,
How are you?
Please could you point me to any document/video that can give me a qucik intro to voip on a basic level?
Thank you.
