cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
39323
Views
21
Helpful
10
Replies

Duplex and speed commands missing, ISR 4331

darth_ravenell
Level 1
Level 1

Help! I think I'm going crazy! I was trying to configure int Gi0/0/0 on our ISR 4331 router running Version 16.6.2. I go to conf t, enter int Gi0/0/0, I add in the description, configure the IP address, I enter no negotiation auto, I enter speed 100 and I get "% Invalid input detected at '^' marker".

 

I'm like "OK", so I tried duplex full and I got "% Invalid input detected at '^' marker" again. So, I enter ? and low and behold speed and duplex are not showing as available commands. 

 

Because of time constraints I set negotiation auto and of course the interface goes up, up but is Half duplex. Now, I'm panicking. I hit ? again and I see speed and duplex now being available commands. I try to set the speed and duplex and of course it says these cannot be set while negotiation auto is set.

 

So, finally, I set no negotiation auto and hit ? again. Viola, there they are! I set speed 100 and duplex full and my interface goes to duplex full. 

 

I tried to duplicate this issue on Gi0/0/2 to prove I'm not crazy and of course it doesn't happen. This is not the first time this has happened to me. 

 

In conclusion, I'm either going crazy or this is a fluke thing that happens with the 4331's. Anyone had this happen before? Does anyone know if this is a known bug or something?

1 Accepted Solution

Accepted Solutions

OK - that is somewhat consistent with my findings that the interface has to be up before setting the speed and duplex parameters.  Not good for me as I am configuring devices for shipping, although I guess I could connect the interface to a switch port to simulate the up condition.  The forcing OAM active seems to get around that but I am not completely sure about what other ramifications that might have.  The link seems to go up and down normally so I am going to continue to use it until it bites me. (A similar result could be had by setting no keepalives but when doing that, the link looks "up" whether it is or not.)  Anyway thanks for providing the info from TAC.

View solution in original post

10 Replies 10

Hello,

 

odd indeed. Is this a GLC-T or SFP-GE-T ?

It's the RJ-45 port for Ge0/0/0.

Hello,

 

try and shut/no shut the port, then check if this still occurs...

Leo Laohoo
Hall of Fame
Hall of Fame

Try setting the interface to point to the copper port by using the command "media rj" and then set the speed/duplex?

I had a similar problem when attempting to set speed and duplex on G0/0/2 with a GLC-TE sfp module  installed.  With the earlier module (GLC-T which is end of sale), simply turning off negotiation "no negotiation auto" would allow the speed and duplex commands to be used, but not so with the new module.  I achieved some success trying different things and in one case shipped the router across country only to have it not come up (we are using G0/0/2 for MPLS WAN connection and our carrier insists that the link be coded to 100/FULL).  I was later able to get that branch to work but only after the router was connected.  After reading about a similar issue on another thread, I found the following sequence always resulted in success:

shut

no negotiation auto

ethernet oam mode active

no shut

speed 100

duplex full

 

All of these steps may or may not be necessary, but as I use an automated process to configure branch routers at least I know that it works reliably.  The oam command and the duplex command do not show in the configuration and the show interface reveals:

  Full Duplex, 100Mbps, link type is force-up, media type is T

 

In retrospect, I surmise (perhaps incorrectly) that the link needs to be up before the speed and duplex commands work: either by being connected or by forcing OAM active.

Thanks for that. I've never seen this command before.

Thanks for this tip. TAC didn't mention this command. Thanks for sharing your experience in this area!

darth_ravenell
Level 1
Level 1

Thanks for the suggestions. Just a quick update on what has occured since I posted this discussion. I opened a TAC case and worked with an Engineer. This was challenging because the issue was already rectified and didn't have the means to reproduce the issue.

Long story short, at first TAC provided information saying it's not recommended to set negotation to "no negotiation auto". Instead, they recomend setting "negotiation forced".
Well, this command was not an available command on the 4331 I was working on which was running Version 16.6.2.

TAC came back saying since the command was not available, to still NOT set "no negotiation auto". To leave set to auto and configure speed 100 and duplex full.

This didn't work. The router said speed and duplex could not be set with "negotiation auto" configured.

Finally, after the engineer spent time in their lab trying to reproduce the issue on their equipment, their feed back was to, in the future, first bring the interface up with "negotiation auto" turned on. Then set "no negotiation auto" and finally set the speed to your setting.

So, inconclusion, it seems ISR 4331's are finicy when it comes to sharing a RJ-45 port with a SFP port. That the order of operations for bringing up your interface when needing to hard speed and duplex, is important to avoid configuration issues.

OK - that is somewhat consistent with my findings that the interface has to be up before setting the speed and duplex parameters.  Not good for me as I am configuring devices for shipping, although I guess I could connect the interface to a switch port to simulate the up condition.  The forcing OAM active seems to get around that but I am not completely sure about what other ramifications that might have.  The link seems to go up and down normally so I am going to continue to use it until it bites me. (A similar result could be had by setting no keepalives but when doing that, the link looks "up" whether it is or not.)  Anyway thanks for providing the info from TAC.

In my experience if the optics aren't in the SFP port then you can't touch speed or duplex because it doesn't recognize the command. It's odd, but that's the case. I've seen this in ASR's, ISR's and IOS-XE switches.
Review Cisco Networking for a $25 gift card