cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1066
Views
0
Helpful
3
Replies

Dynamic NAT Overload exercise understanding the problem.

Hi all,

 

I'm doing a practice with packet tracer to configure a Dynamic NAT overload (or PAT). 

In this practice, I have to create a Dynamic NAT overload with the following information:

 

IP public address 65.0.0.15

and the router_principal  

Gig0/0 30.0.0.1/8
Gig0/ 216.0.0.1/24

Screenshot_packet_tracer.png

 

The router_principal has this running_config

Router_Principal#sh running-config
Building configuration...
Current configuration : 888 bytes
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router_Principal
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524247V-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 30.0.0.1 255.0.0.0
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 216.0.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat pool dhcp_publicas 65.0.0.15 65.0.0.15 netmask 255.0.0.0
ip nat inside source list 10 interface GigabitEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.0.0 0.0.0.255
!
!

 

The private network is 192.168.0.0/24

 

The soho_router 

 

Router_SOHO#sh running-config
Building configuration...
Current configuration : 679 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router_SOHO
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524BLRG-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 30.0.0.2 255.0.0.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

I can ping to and from any due to default ip route in both routers.

 

But at the time to write

sh ip nat translation and s ip nat statistics

, seems that nat has not been created.

Router_Principal#sh ip nat translations
Router_Principal#
Router_Principal#sh ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: GigabitEthernet0/0
Inside Interfaces: GigabitEthernet0/1
Hits: 0 Misses: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
access-list 10 pool dhcp_publicas refCount 0
pool dhcp_publicas: netmask 255.0.0.0
start 65.0.0.15 end 65.0.0.15
type generic, total addresses 1 , allocated 0 (0%), misses 0
Router_Principal#

I don't know what I am doing bad, I watched youtube videos to understand but with no positive results.

I attached packet tracer file in case someone can help me to solve and explain why exists this problem !!!

 

Thank you in advance

2 Accepted Solutions

Accepted Solutions

Jon Marshall
Hall of Fame
Hall of Fame

 

You are not using the pool you have created in your NAT statement. 

 

Jon

View solution in original post

Hello,

 

your configuration looks mixed up:

 

interface GigabitEthernet0/1
ip address 216.0.0.1 255.255.255.0
--> ip nat inside
duplex auto
speed auto




--> ip nat inside source list 10 interface GigabitEthernet0/1 overload


What instructions are you following ? Post the zipped project (.pkt) file together with the written instructions you are following...

 

 

View solution in original post

3 Replies 3

Jon Marshall
Hall of Fame
Hall of Fame

 

You are not using the pool you have created in your NAT statement. 

 

Jon

Hello,

 

your configuration looks mixed up:

 

interface GigabitEthernet0/1
ip address 216.0.0.1 255.255.255.0
--> ip nat inside
duplex auto
speed auto




--> ip nat inside source list 10 interface GigabitEthernet0/1 overload


What instructions are you following ? Post the zipped project (.pkt) file together with the written instructions you are following...

 

 

Hi Georg,

 

Sorry for the delay to answer, I haven't received any email about my question from cisco community.

 

Thank you for your reply and help. At least PAT is working, I have took a lot of videos and read pdfs to see the issue, and I couldn't  make work. There's no ping between networks. Despite I configured both routers with a default route 

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

, strange but it is enough.

 

This is the configuration from Router_SOHO

 

!
hostname Router_SOHO
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524BLRG-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 30.0.0.2 255.0.0.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool dhcp_publicas 65.0.0.15 65.0.0.15 netmask 255.0.0.0
ip nat inside source list 10 pool dhcp_publicas overload
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 
!
ip flow-export version 9
!
access-list 10 permit 192.168.0.0 0.0.0.255
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

Configuration Router_Principal

 

Router_Principal#sh running-config 
Building configuration...

Current configuration : 876 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router_Principal
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524247V-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 30.0.0.1 255.0.0.0
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 216.0.0.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool dhcp_publicas 65.0.0.15 65.0.0.15 netmask 255.0.0.0
ip nat inside source list 10 pool dhcp_publicas overload
ip classless
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 
!
ip flow-export version 9
!
access-list 10 permit 216.0.0.0 0.0.0.255
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end