11-02-2021 12:10 PM
I am having issue with eBgp configuration and will appreciate your feedback and guidance. BGP is active, but i am not learning route or advertising prefixes. the upstream ISP are not learning prefixes from my end. i have advertised my network, yet still having this issue.
R1#sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 35000
BGP table version is 7, main routing table version 7
3 network entries using 744 bytes of memory
3 path entries using 360 bytes of memory
2/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1624 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.129 4 38000 0 0 1 0 0 never Idle
20.20.20.128 4 31000 247 261 7 0 0 01:55:34 1
102.100.100.2 4 320000 0 0 1 0 0 never Idle
R1#sh ip bgp
BGP table version is 7, local router ID is 1.1.1.1
Network Next Hop Metric LocPrf Weight Path
r> 0.0.0.0 20.20.20.128 0 0 31000 i
*> 102.100.100.2/29 0.0.0.0 0 32768 i
*> 102.100.100.2/28 0.0.0.0 0 32768 i
Solved! Go to Solution.
11-02-2021 03:14 PM
Hi @ossniper ,
You have configured
network 102.100.100.8 mask 255.255.255.248
network 102.100.100.0 mask 255.255.254.0
But for these prefixes to be advertised to the peer, they have to be present in the routing table. You can add static routes to null0 as follow:
ip route 102.100.100.8 255.255.255.248 null0
ip route 102.100.100.0 255.255.254.0 null0
Regards,
11-02-2021 09:19 PM
Hello @ossniper ,
for the inbound direction you are receving an eBGP route for default route 0.0.0.0/0
but you also have a static route to the neighbor
>> S* 0.0.0.0/0 [1/0] via 20.20.20.128
as a result of this the received default route is classified as r = RIB failure that just means that another more trusted routing source is providing a prefix that is installed in IP routing table, but there is nothing wrong on the received eBGP prefix.
r> 0.0.0.0 20.20.20.128 0 0 31000 i
The prefix is best ">" but it is "r" RIB failure for the presence of the static route.
Try the following
no ip route 0.0.0.0 0.0.0.0 20.20.20.128
ip route 0.0.0.0 0.0.0.0 20.20.20.18 220
! here the final 220 is the AD and this makes this static route a floating static route that when compared with AD = 20 of
! eBGP route will not be selected for installation in the IP routing table.
The results should be:
the "r" flag disappears and the default route will be:
B [20/0] 0.0.0.0/0 via 20.20.20.18
For the prefixes you would like to advertise upstream, be aware that now BGP has no auto-summary enabled by default and as explained by @Harold Ritter you need an exact match of the prefix to be present in IP routing table by any means connected, static routes or dynamically learned routes to have a match and to start to advertise to the upstream eBGP peer.
post
show ip route 102.100.100.0
if the output is empty apply the suggestions provided by Harold.
if this is a NAT pool you can use a loopback interface to represent the pool giving it an IP address taken from the pool with the correct subnet mask.
Hope to help
Giuseppe
11-02-2021 12:27 PM
Hello
TBH not enough information on how you are trying to achieve ebgp peering and advertising your prefixes - i can see you have 3 peers and only one is established - post the output of the following:
sh run | sec router bgp
sh ip int brief
sh ip route
sh ip cef <neighbour> samecable
sh ip bgp
11-02-2021 02:19 PM
Thanks for you response..
Upstream ISP = 20.20.20.128/31.
I don't know i'm missing and not learning bgp route.
R1#sh run | sec router bgp
router bgp 35000
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 20.20.20.128 remote-as 31000
neighbor 20.20.20.128 update-source Loopback0
!
address-family ipv4
network 102.100.100.8 mask 255.255.255.248
network 102.100.100.0 mask 255.255.254.0
neighbor 20.20.20.128 activate
exit-address-family
NETACCESS-EDGER1#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 41.200.200.130 YES NVRAM up up
GigabitEthernet0/0/1 197.190.190.49 YES NVRAM up up
GigabitEthernet0/0/2 unassigned YES NVRAM up up
GigabitEthernet0/0/2.3 10.3.0.1 YES NVRAM up up
GigabitEthernet0/0/2.4 10.4.0.1 YES NVRAM up up
GigabitEthernet0/0/2.5 192.168.5.1 YES NVRAM up up
GigabitEthernet0/0/2.6 10.5.0.1 YES NVRAM up up
GigabitEthernet0/0/2.7 192.168.7.1 YES NVRAM up up
GigabitEthernet0/0/2.9 10.8.0.1 YES NVRAM up up
Gi0/0/2.10 10.9.0.1 YES NVRAM up up
GigabitEthernet0/0/4 20.20.20.128 YES NVRAM up up
GigabitEthernet0/1/2 102.100.100.1 YES manual up up
R1#sh ip bgp
BGP table version is 11, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
r> 0.0.0.0 20.20.20.128 0 0 31000 i
*> 102.100.100.2/29 0.0.0.0 0 32768 i
*> 102.100.100.2/28 0.0.0.0 0 32768 i
R1#sh ip cef gi0/0/4
0.0.0.0/0
nexthop 20.20.20.128 GigabitEthernet0/0/4
20.20.20.128/31
attached to GigabitEthernet0/0/4
20.20.20.128/32
attached to GigabitEthernet0/0/4
NETACCESS-EDGER1#sh ip route
Gateway of last resort is 20.20.20.128 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 20.20.20.128
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 12 subnets, 3 masks
C 10.3.0.0/16 is directly connected, GigabitEthernet0/0/2.3
L 10.3.0.1/32 is directly connected, GigabitEthernet0/0/2.3
C 10.4.0.0/16 is directly connected, GigabitEthernet0/0/2.4
L 10.4.0.1/32 is directly connected, GigabitEthernet0/0/2.4
11-02-2021 03:05 PM
Hello,
what IP address is your ISP peering with, what is the IP address of the R1 interface ? Post the full running config of your R1 router...and if this is a lab and you don't use a 'real' ISP, post the full running config of the NETACCESS-EDGER1 router as well...
11-02-2021 03:14 PM
Hi @ossniper ,
You have configured
network 102.100.100.8 mask 255.255.255.248
network 102.100.100.0 mask 255.255.254.0
But for these prefixes to be advertised to the peer, they have to be present in the routing table. You can add static routes to null0 as follow:
ip route 102.100.100.8 255.255.255.248 null0
ip route 102.100.100.0 255.255.254.0 null0
Regards,
11-02-2021 09:19 PM
Hello @ossniper ,
for the inbound direction you are receving an eBGP route for default route 0.0.0.0/0
but you also have a static route to the neighbor
>> S* 0.0.0.0/0 [1/0] via 20.20.20.128
as a result of this the received default route is classified as r = RIB failure that just means that another more trusted routing source is providing a prefix that is installed in IP routing table, but there is nothing wrong on the received eBGP prefix.
r> 0.0.0.0 20.20.20.128 0 0 31000 i
The prefix is best ">" but it is "r" RIB failure for the presence of the static route.
Try the following
no ip route 0.0.0.0 0.0.0.0 20.20.20.128
ip route 0.0.0.0 0.0.0.0 20.20.20.18 220
! here the final 220 is the AD and this makes this static route a floating static route that when compared with AD = 20 of
! eBGP route will not be selected for installation in the IP routing table.
The results should be:
the "r" flag disappears and the default route will be:
B [20/0] 0.0.0.0/0 via 20.20.20.18
For the prefixes you would like to advertise upstream, be aware that now BGP has no auto-summary enabled by default and as explained by @Harold Ritter you need an exact match of the prefix to be present in IP routing table by any means connected, static routes or dynamically learned routes to have a match and to start to advertise to the upstream eBGP peer.
post
show ip route 102.100.100.0
if the output is empty apply the suggestions provided by Harold.
if this is a NAT pool you can use a loopback interface to represent the pool giving it an IP address taken from the pool with the correct subnet mask.
Hope to help
Giuseppe
11-03-2021 01:19 PM
Hello
@ossniper wrote:
R1#sh run | sec router bgp
router bgp 35000
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 20.20.20.128 remote-as 31000
neighbor 20.20.20.128 update-source Loopback0
NETACCESS-EDGER1#sh ip routeGateway of last resort is 20.20.20.128 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 20.20.20.128
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 12 subnets, 3 masks
C 10.3.0.0/16 is directly connected, GigabitEthernet0/0/2.3
L 10.3.0.1/32 is directly connected, GigabitEthernet0/0/2.3
C 10.4.0.0/16 is directly connected, GigabitEthernet0/0/2.4
L 10.4.0.1/32 is directly connected, GigabitEthernet0/0/2.4
Just like to add for referance-
Bgp performs two checks for peering, (ttl and connectivity) now if you try to peer with a ebgp neighbour that isnt directly connected like above (unless you are not showing all the routing table) the connectivity check needs to be disabled using the "neighbour xxxx disable-connected-check" or the ttl value is raised, However the bgp rtr won’t even consider peering to any neighbour who only path to it is via a default route.
11-02-2021 02:52 PM
caution: u have update-source Loopback0 , with this way, ISP must know how to reach your loopback 0.
from line 10.10.10.129 4 38000 0 0 1 0 0 never Idle ,
never and idle are not good, this is because u missing 2 statements neighbor x.x.x.x remote y and neighbor x.x.x.x active
check what you advertise with show ip bgp neighbor x.x.x.x advertised-routes
Regards, ML
**Please Rate All Helpful Responses **
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide