cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1553
Views
0
Helpful
2
Replies
nohara
Beginner

EIGRP Advertise VLANs

I have an issue regaridng EIGRP and VLANs. I have two layer 3 switches connected together via a /30 subnet. Both of these switches have the same SVI (VLAN 99) for management and are showing up/up. From Switch1 I am unable to ping the VLAN 99 interface on Switch2 and vice versa. As you can see below the eigrp topology shows 10.1.99.0 connected via vlan99. How can I approach this?

Switch1:

interface FastEthernet0/1
description <--To Switch2-->
no switchport
ip address 10.8.1.5 255.255.255.252

interface Vlan99
description <--Management-->
ip address 10.1.99.1 255.255.255.0

router eigrp 1
network 10.1.99.0 0.0.0.255
network 10.8.1.4 0.0.0.3

Switch1#show ip eigrp top
EIGRP-IPv4 Topology Table for AS(1)/ID(10.8.1.5)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.8.1.4/30, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 10.1.99.0/24, 1 successors, FD is 2816
via Connected, Vlan99

Switch2:

interface GigabitEthernet1/0/1
description <--To Switch1-->
no switchport
ip address 10.8.1.6 255.255.255.252

interface Vlan99
description <--Management-->
ip address 10.1.99.10 255.255.255.0

router eigrp 1
network 10.1.99.0 0.0.0.255
network 10.8.1.4 0.0.0.3
eigrp stub connected summary

Switch2#show ip eigrp top
EIGRP-IPv4 Topology Table for AS(1)/ID(10.8.1.6)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.8.1.4/30, 1 successors, FD is 28160
via Connected, GigabitEthernet1/0/1
P 10.1.99.0/24, 1 successors, FD is 2816
via Connected, Vlan99

2 REPLIES 2
Jon Marshall
Hall of Fame Guru

You cannot separate the same vlan/IP subnet by a L3 link. If you look at routing tables each switch sees vlan 99 as local because it is.

If you want to use the same vlan/IP subnet on all switches for management your links need to be trunks.

Jon

mikeleebrla
Beginner

Your issue is that you have the VLAN 99 on opposite sides of a routed network. In addition to that the IP scheme on both "inside networks" (vlans 99) overlap eachother. They are both on the 10.1.99.X/24 network.  Either router will never route packets destined for the 10.1.99.X/24 network across your 10.8.1.5 255.255.255.252 network b/c both routers already see the 10.1.99.X/24 network as directly connected (b/c it is directly connected to both routers). 

You have two ways to 'correct' this.

1.  configure the link between the two switches/routers as a trunk so traffic between them will be switched and not routed (probably the best solution)

2. change your IP scheme so you don't have overlapping networks behind your routers/switches.

**note that I'm using router/switch interchangeably b/c you have routing enabled on your switches, thus they are essentially routers for the purposes of your issue.

** note2,,, in your current setup even though you have vlan 99 on both switches, they do not 'know' about one another since they are behind routed networks.  Meaning vlan 99 on one switch has nothing to do with vlan 99 on the other switch.