cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
520
Views
0
Helpful
1
Replies
Beginner

EIGRP Distribute List on Nexus with Route-maps

HI, I was wondering if anyone has  done this successfully, I'm trying to create a route-map for an EIGRP  Distribute list on a N7K, the goal is to not advertise a 10.0.0.0/8 and  172.31.30.20/32 networks out a link to a remote site while permitting  all other traffic to the internet (default). I configured the  ACL/route-maps below and applied them outbound on the N7K interface but  no subnets at all are being received on the remote site router, any help  is appreciated.

ip access-list DENY_10.0.0.0

  10 permit ip any 10.244.244.20/30 <<--WAN interface network

   20 deny ip any 10.0.0.0/8

   25 deny ip any 172.31.30.20/32

   30 permit ip any any

route-map BLOCK_10.0.0.0 permit 10

  match ip address DENY_10.0.0.0

interface Ethernet1/3

ip distribute-list eigrp 1 route-map BLOCK_10.0.0.0 out

1 REPLY 1
Beginner

Re: EIGRP Distribute List on Nexus with Route-maps

Hi!

In case if you are still not able to get the solution, you can use try using a prefix-list as follows:

ip prefix-list DENY10172 seq 5 permit 10.244.244.20/30

ip prefix-list DENY10172 seq 10 deny 10.0.0.0/8

ip prefix-list DENY10172 seq 15 deny 172.31.30.20/32

ip prefix-list DENY10172 seq 20 permit 0.0.0.0/0 le 32

interface Ethernet1/3

ip distribute-list eigrp 1 prefix-list DENY10172 out

Or you can call prefix-list into a route-map and then call route-map in distribute list as you like.

Let me know if this works, Thanks,

Nandan Mathure

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards