cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
815
Views
0
Helpful
3
Replies

EIGRP distribute-list out with route-map match route-type local doesn't work

saba
Level 1
Level 1

This is done on gns3 dynamips.

[[R1]] --(e1/0)------- (L2 Switch1)------(e1/0)-- [[R6]]

 

What I'm trying to do is to tag on the R6 generated routes on the way to R1. Between the two routers, EIGRP is running. So I thought I could use distribute-list out command on R6 as follows:

 

R6#sh run | se route-map
 distribute-list route-map R6->R1 out Ethernet1/0
route-map R6->R1 permit 100
 match route-type local
 set tag 60
route-map R6->R1 permit 200

 

But when I try to check the tag, it just isn't there.

R1#sh ip route 10.10.16.0
Routing entry for 10.10.16.0/29
  Known via "eigrp 1003", distance 90, metric 409600, type internal
  Redistributing via eigrp 1003, ospf 1
  Advertised by ospf 1 subnets route-map E->O
  Last update from 166.15.13.2 on Ethernet1/0, 00:49:57 ago
  Routing Descriptor Blocks:
  * 166.15.13.2, from 166.15.13.2, 00:49:57 ago, via Ethernet1/0
      Route metric is 409600, traffic share count is 1
      Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

 

R6 Config:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
enable password 2018
!
no aaa new-model
memory-size iomem 5
!
ip cef
no ip domain lookup
ip domain name HANA.com
!
key chain Hana-Hyun
 key 21474836
   key-string oNe-BaNk
!
username Master privilege 15 password 0 dk1dl2xl3dnlf
username HaNaAgent privilege 5 password 0 1532gkskhana
username R4 password 0 g3kd51mssk9
!
ip ssh version 2
!
interface Loopback0
 ip address 10.10.16.6 255.255.255.248
!
interface Loopback1
 ip address 192.168.160.2 255.255.255.224 secondary
 ip address 192.168.160.1 255.255.255.224
 ip nat inside
 ip virtual-reassembly
!
interface Loopback2
 ip address 192.168.160.33 255.255.255.224
 ip nat inside
 ip virtual-reassembly
!
interface Loopback3
 ip address 192.168.160.65 255.255.255.248
!
interface Loopback4
 ip address 192.168.160.73 255.255.255.248
!
interface Multilink1
 ip address 166.15.13.5 255.255.255.252
 no peer neighbor-route
 ppp encrypt mppe 40 required
 ppp authentication ms-chap
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 604 ppp Virtual-Template1
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay interface-dlci 614 ppp Virtual-Template2
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 166.15.13.2 255.255.255.252
 ip authentication mode eigrp 1003 md5
 ip authentication key-chain eigrp 1003 Hana-Hyun
 full-duplex
!

interface Ethernet1/1
 ip address 166.15.13.14 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
interface Virtual-Template1
 no ip address
 ppp multilink
 ppp multilink group 1
!
interface Virtual-Template2
 no ip address
 ppp multilink
 ppp multilink group 1
!
router eigrp 1003
 passive-interface default
 no passive-interface Ethernet1/0
 no passive-interface Multilink1
 network 10.10.16.6 0.0.0.0
 network 166.15.13.2 0.0.0.0
 network 166.15.13.5 0.0.0.0
 network 192.168.160.0 0.0.0.63
 network 192.168.160.64 0.0.0.15
 distribute-list route-map R6->R1 out Ethernet1/0
 no auto-summary
!
ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 166.15.13.13
!
ip nat inside source list IP-NAT-Private interface Ethernet1/1 overload
!
ip access-list standard IP-NAT-Private
 permit 192.168.160.0 0.0.0.63
!
menu Staff title ^C
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
                              MeNu Staff
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

^C
menu Staff text 1. Routing Table Information
menu Staff command 1. sh ip route
menu Staff text 2. Interface Information
menu Staff command 2. sh ip int br
menu Staff text 3. Protocol Display
menu Staff command 3. sh ip protocol
menu Staff text 4. Running-config Display
menu Staff command 4. sh run
menu Staff text 5. Menu-Exit
menu Staff command 5. exit
!
route-map R6->R1 permit 100
 match route-type local
 set tag 60
!
route-map R6->R1 permit 200
!
control-plane
!
!
banner motd ^C
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
$                                                                  $
$                        - W A R N I N G -                         $
$                                                                  $
$   A notice that any unathorized use of the system is unlawful    $
$      and may be subject to civil and/or criminal penalties.      $
$                                                                  $
$      Any of your attempt to connect to the system is logged!!    $
$                                                                  $
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
^C
privilege exec level 5 show running-config
privilege exec level 5 show
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login local
 transport input ssh
line vty 5 10
 login local
 autocommand  menu Staff
 transport input telnet
!
ntp authentication-key 4294 md5 070B2A1D4A054B1D1B410F02082C 7
ntp authenticate
ntp trusted-key 4294
ntp server 10.10.15.5 key 4294
!
end

 

R1 Config:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable password 2018
!
no aaa new-model
memory-size iomem 5
!
ip cef
no ip domain lookup
ip domain name HANA.com
!

key chain Hana-Hyun
 key 21474836
   key-string oNe-BaNk
!
username Master privilege 15 password 0 dk1dl2xl3dnlf
username Busan2 password 0 KK55347ap2
username HaNaAgent privilege 5 password 0 1532gkskhana
!
ip ssh version 2
!
interface Loopback0
 ip address 10.10.11.1 255.255.255.248
 ip ospf network point-to-point
!
interface Loopback1
 ip address 192.168.48.1 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback2
 ip address 192.168.48.33 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback3
 ip address 192.168.64.1 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback4
 ip address 192.168.64.33 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback5
 ip address 192.168.80.97 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback6
 ip address 192.168.80.193 255.255.255.224
 ip ospf network point-to-point
!
interface Loopback7
 ip address 200.200.17.34 255.255.255.240
!
interface Loopback8
 ip address 192.168.80.225 255.255.255.224
 ip ospf network point-to-point
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/0.13 multipoint
 ip address 200.200.17.5 255.255.255.252
 ip access-group ACCESS-POLICY in
 ip ospf authentication message-digest
 ip ospf message-digest-key 53 md5 sj79aqj2dn0js
 frame-relay map ip 200.200.17.6 103 broadcast
!
interface Serial0/1
 ip address 200.200.17.13 255.255.255.252
 ip access-group ACCESS-POLICY in
 encapsulation ppp
 ip ospf authentication message-digest
 ip ospf message-digest-key 53 md5 sj79aqj2dn0js
 shutdown
 serial restart-delay 0
 ppp authentication chap
!
interface Serial0/2
 no ip address
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!

interface Ethernet1/0
 ip address 166.15.13.1 255.255.255.252
 ip access-group ACCESS-POLICY in
 ip authentication mode eigrp 1003 md5
 ip authentication key-chain eigrp 1003 Hana-Hyun
 ip summary-address eigrp 1003 200.200.17.0 255.255.255.240 5
 ip summary-address eigrp 1003 192.168.144.64 255.255.255.240 5
 ip summary-address eigrp 1003 192.168.144.0 255.255.255.192 5
 ip summary-address eigrp 1003 192.168.112.64 255.255.255.240 5
 ip summary-address eigrp 1003 192.168.112.0 255.255.255.192 5
 ip summary-address eigrp 1003 192.168.96.64 255.255.255.240 5
 ip summary-address eigrp 1003 192.168.96.0 255.255.255.192 5
 ip summary-address eigrp 1003 192.168.80.0 255.255.255.0 5
 ip summary-address eigrp 1003 192.168.64.0 255.255.255.192 5
 ip summary-address eigrp 1003 192.168.48.128 255.255.255.240 5
 ip summary-address eigrp 1003 192.168.48.0 255.255.255.128 5
 ip summary-address eigrp 1003 192.168.32.0 255.255.255.192 5
 full-duplex
!
interface Ethernet1/1
 no ip address
 full-duplex
!
interface Ethernet1/1.15
 encapsulation dot1Q 150
 ip address 200.200.17.18 255.255.255.252
 ip nat outside
 ip virtual-reassembly
!
interface Ethernet1/1.17
 encapsulation dot1Q 107
 ip address 192.168.32.1 255.255.255.240
 ip access-group ACCESS-POLICY in
 ip nat inside
 ip virtual-reassembly
 ip ospf message-digest-key 53 md5 sj79aqj2dn0js
!
interface Ethernet1/1.18
 encapsulation dot1Q 108
 ip address 192.168.32.17 255.255.255.240
 ip access-group ACCESS-POLICY in
 ip nat inside
 ip virtual-reassembly
 ip ospf message-digest-key 53 md5 sj79aqj2dn0js
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1003
 redistribute ospf 1 metric 1544 2000 255 1 1500 route-map O->E
 passive-interface default
 no passive-interface Ethernet1/0
 network 166.15.13.1 0.0.0.0
 distribute-list route-map SUM-CTRL-E out
 no auto-summary
!
router ospf 1
 router-id 10.10.11.1
 log-adjacency-changes
 area 0 authentication message-digest
 area 0 range 192.168.32.0 255.255.255.192
 area 0 range 192.168.48.0 255.255.255.128
 area 0 range 192.168.48.128 255.255.255.240
 area 0 range 192.168.64.0 255.255.255.192
 area 0 range 192.168.80.0 255.255.255.0
 area 192 range 192.168.96.0 255.255.255.192
 area 192 range 192.168.96.64 255.255.255.240
 area 192 range 192.168.112.0 255.255.255.192
 area 192 range 192.168.112.64 255.255.255.240
 area 192 range 192.168.144.0 255.255.255.192
 area 192 range 192.168.144.64 255.255.255.240
 area 192 range 200.200.17.0 255.255.255.240
 summary-address 192.168.128.0 255.255.255.192
 summary-address 192.168.128.64 255.255.255.240
 summary-address 192.168.160.0 255.255.255.192
 summary-address 192.168.160.64 255.255.255.240
 summary-address 166.15.13.0 255.255.255.248
 redistribute eigrp 1003 subnets route-map E->O
 passive-interface default
 no passive-interface Serial0/0.13
 no passive-interface Serial0/1
 no passive-interface Ethernet1/1.17
 no passive-interface Ethernet1/1.18
 network 10.10.11.1 0.0.0.0 area 0
 network 192.168.32.1 0.0.0.0 area 0
 network 192.168.32.17 0.0.0.0 area 0
 network 192.168.48.0 0.0.0.63 area 0
 network 192.168.64.0 0.0.0.63 area 0
 network 192.168.80.96 0.0.0.31 area 0
 network 192.168.80.192 0.0.0.31 area 0
 network 192.168.80.224 0.0.0.7 area 0
 network 200.200.17.5 0.0.0.0 area 192
 network 200.200.17.13 0.0.0.0 area 192
 neighbor 200.200.17.6
!
ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Ethernet1/1.15 200.200.17.17
!
ip nat inside source list NAT-GRP interface Ethernet1/1.15 overload
ip nat inside source static 192.168.48.74 200.200.17.34
ip nat inside source static 192.168.48.76 200.200.17.35
ip nat inside source static 192.168.48.82 200.200.17.36 route-map COMM reversible
ip nat inside source static 192.168.48.106 200.200.17.42
ip nat inside source static 192.168.48.107 200.200.17.43
ip nat inside source static tcp 192.168.48.138 3092 200.200.17.50 15663 extendable
!
!
ip access-list standard NAT-GRP
 permit 192.168.48.0 0.0.0.63
 permit 192.168.64.0 0.0.16.255
!
ip access-list extended ACCESS-POLICY
 permit ip 192.168.96.2 0.0.16.33 host 192.168.80.226 time-range CONF-TIME
 permit ip 192.168.128.2 0.0.16.33 host 192.168.80.226 time-range CONF-TIME
 permit ip 192.168.160.2 0.0.0.33 host 192.168.80.226 time-range CONF-TIME
 deny   ip any host 192.168.80.226
 permit ip any any
ip access-list extended ATM
 permit ip 192.168.48.82 0.0.0.1 149.190.10.2 0.0.0.5
!
menu Staff title ^C
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
                              MeNu Staff
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
^C
menu Staff text 1. Routing Table Information
menu Staff command 1. sh ip route
menu Staff text 2. Interface Information

menu Staff command 2. sh ip int br
menu Staff text 3. Protocol Display
menu Staff command 3. sh ip protocol
menu Staff text 4. Running-config Display
menu Staff command 4. sh run
menu Staff text 5. Menu-Exit
menu Staff command 5. exit
!
route-map SUM-CTRL-E permit 10
 match route-type internal local
 set tag 129
!
route-map SUM-CTRL-E permit 20
!
route-map E->O deny 100
 match interface Null0
 match route-type internal
!
route-map E->O permit 200
 match route-type internal
!
route-map O->E deny 100
 match interface Null0
 match route-type internal
!
route-map O->E permit 200
 match route-type internal
!
route-map COMM permit 100
 match ip address ATM
!
control-plane
!
banner motd ^C
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
$                                                                  $
$                        - W A R N I N G -                         $
$                                                                  $
$   A notice that any unathorized use of the system is unlawful    $
$      and may be subject to civil and/or criminal penalties.      $
$                                                                  $
$      Any of your attempt to connect to the system is logged!!    $
$                                                                  $
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
^C
privilege exec level 5 show running-config
privilege exec level 5 show
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login local
 transport input ssh
line vty 5 10
 login local
 autocommand  menu Staff
 transport input telnet
!
ntp authentication-key 4294 md5 045F00570B2D1E56054A01191E0D 7
ntp authenticate
ntp trusted-key 4294
ntp server 10.10.15.5 key 4294
time-range Conf-time
 periodic weekdays 8:30 to 10:00
!
!
event manager applet C-CLOSE
 event timer cron name _EEMinternalname0 cron-entry "00 10 * * *"
 action 1 cli command "enable"
 action 2 cli command "conf t"
 action 3 cli command "router ospf 1"
 action 4 cli command "no network 192.168.80.224 0.0.0.7 area 0"
 action 5 syslog msg "=====Conference Call Room CLOSED====="
event manager applet C-OPEN
 event timer cron name _EEMinternalname1 cron-entry "30 8 * * *"
 action 1 cli command "enable"
 action 2 cli command "conf t"
 action 3 cli command "router ospf 1"
 action 4 cli command "network 192.168.80.224 0.0.0.7 area 0"
 action 5 syslog msg "=====Conference Call Room OPEN====="
event manager applet SBuUP1
 event syslog pattern "%OSPF-5-ADJCHG: Process 1, Nbr 10.10.13.1 on Serial0/0.13 from FULL to DOWN, Neighbor Down: Interface down or detached"
 action 1.1 syslog msg "START EEM UP"
 action 1.2 cli command "enable"
 action 1.3 cli command "conf t"
 action 1.4 cli command "int s0/1"
 action 1.5 cli command "no shut"
 action 1.6 syslog msg "============= UP============="
event manager applet SBuUP2
 event syslog pattern "%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1/0, changed state to down"
 action 2.1 syslog msg "START EEM UP222222222222222222"
 action 2.2 cli command "enable"
 action 2.3 cli command "conf t"
 action 2.4 cli command "int s0/1"
 action 2.5 cli command "no shut"
 action 2.6 syslog msg "============= UP222============="
!
end

3 Replies 3

Peter Paluch
Cisco Employee
Cisco Employee

Hi Saba,

A couple of suggestions:

  1. Try pulling the output of show ip eigrp topology 10.10.16.0 255.255.255.248 detail on R1 and check if the tag is there. There's a long way from the EIGRP topology table to the routing table :) Or even better, since this is GNS, just capture the traffic between R6 and R1 and check if R6 advertises this network with a non-zero tag.
  2. If R6 is truly not advertising this network with a tag, I suspect the match route-type to be not doing what we expect it to do. Can you try removing it, keeping just the set tag in the route-map, and check again? Obviously, all the routes advertised from R6 should then become tagged.

Looking forward to hearing from you!

Best regards,
Peter

Thank you for the suggestion.
After looking into eigrp topology and trying out removing match route-type, I came to the same conclusion as yours. The "match route-type local" doesn't seem to work as it should whereas "match route-type internal" works fine. So, the workaround may be to set up tags in other eigrp routers so that I can filter them out.

Hello,

If I may ask, what exactly do you want to accomplish? Perhaps if you described what is your overall goal, we could come up with an alternative solution.

Best regards,
Peter

Review Cisco Networking for a $25 gift card