cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1904
Views
25
Helpful
18
Replies

EIGRP PBR on NX7K

zekebashi
Level 4
Level 4

Hello,

I'm trying to create a PBR to redistribute static routes into EIGRP on a NX7K. Cisco's document below states that the route-map policy needs to be implemented at the Interface level.

 

My question is, do I need to apply this policy on every interface that I have configured for EIGRP or can I just implement this route-map under the EIGRP instance?

 


https://www.cisco.com/c/en/us/products/collateral/switches/nexus-7000-series-switches/white-paper-c11-733892.html

 

 

Thanks in advance.

Best, ~sk

1 Accepted Solution

Accepted Solutions

Hello,

 

you don't need to define a next hop. You match on the static route destination (192.168.1.0/24 in your case):

 

ip prefix-list PL_ALLOW seq 10 permit 192.168.1.0/24
!
route-map RM_STATIC_EIGRP permit 10
match ip address prefix-list PL_ALLOW
!
router eigrp 1
redistribute static route-map RM_STATIC_EIGRP

View solution in original post

18 Replies 18

Hello

Not so sure what it is your trying to archive, "policy route to a redistributed static?"

Can you elaborate please?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I've 4 static route statements that I am trying to redistribute into an eigrp instance on a NX7K. On the NX-OS, redistributing routes requires the creation on route-maps. So, here's the config I came up with;

ip prefix-list 100
   permit 192.168.9.228/30

!

ip prefix-list 200
  permit 192.168.102.228/30

!
ip prefix-list 300
   permit 192.168.1.0/24

!
ip prefix-list 400
   permit 10.10.0.0/16

----
route-map STATIC_TO_EIGRP permit 10
match ip address prefix-list 200
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 15
match ip address prefix-list 300
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 20
match ip address prefix-list 400
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 25
match ip address prefix-list 100
set ip next-hop 10.1.9.254

!

router eigrp calenterprise
autonomous-system 1116
passive-interface default
address-family ipv4 unicast
redistribute static route-map STATIC_TO_EIGRP

 

 

Will this approach work?

 

Best, ~zK

Hello,

 

don't confuse PBR, and redistribution using route maps. PBR needs to be applied to interfaces, route redistribution using route maps under the (EIGRP in your case) routing protocol instance.

That's how I understood it. Thanks for the clarification!!

 

Here's my config. I hope I didn't miss anything.

 

ip prefix-list 100
   permit 192.168.9.228/30

!

ip prefix-list 200
  permit 192.168.102.228/30

!
ip prefix-list 300
   permit 192.168.1.0/24

!
ip prefix-list 400
   permit 10.10.0.0/16

----
route-map STATIC_TO_EIGRP permit 10
match ip address prefix-list 200
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 15
match ip address prefix-list 300
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 20
match ip address prefix-list 400
set ip next-hop 10.1.9.254

!
route-map STATIC_TO_EIGRP permit 25
match ip address prefix-list 100
set ip next-hop 10.1.9.254

!

router eigrp calenterprise
autonomous-system 1116
passive-interface default
address-family ipv4 unicast
redistribute static route-map STATIC_TO_EIGRP

Hello,

 

that does not look right. What are you trying to accomplish ? Redistribute static routes into EIGRP ?

 

Drop all the 'set' conditions, as these are for policy routing.

 

ip prefix-list 100
permit 192.168.9.228/30

!

ip prefix-list 200
permit 192.168.102.228/30

!
ip prefix-list 300
permit 192.168.1.0/24

!
ip prefix-list 400
permit 10.10.0.0/16

----
route-map STATIC_TO_EIGRP permit 10
match ip address prefix-list 200

!
route-map STATIC_TO_EIGRP permit 15
match ip address prefix-list 300

!
route-map STATIC_TO_EIGRP permit 20
match ip address prefix-list 400

!
route-map STATIC_TO_EIGRP permit 25
match ip address prefix-list 100

!

router eigrp calstrs
autonomous-system 1116
passive-interface default
address-family ipv4 unicast
redistribute static route-map STATIC_TO_EIGRP

I agree with @Georg Pauwen that the original poster is confusing the use of route maps to control redistribution of routes with the use of route maps in Policy Based Routing. Using route maps in PBR is intended to provide alternate routing for certain traffic by specifying a different next hop from what would be found in the IP routing table. Clearly what the original poster wants to do is to control redistribution of static routes into EIGRP. So at a minimum the original poster needs to remove the set statements from the route map.

 

I would also suggest that while the suggested approach of a route map with 4 stanzas will work it is more complex than is needed. Instead of 4 prefix lists each specifying a single address it would work with a single prefix list which has 4 entries, and therefore only a single stanza in the route map.

HTH

Rick

Thanks for the input. I was wondering if you could give me an example on how you would configure a static route distribution into eigrp using a route-map. Here's an example of the static route:

 

ip route 192.168.1.0 255.255.255.0 10.1.9.254

 

Thanks in advance.

 

Best, ~zK

Hello,

I am trying to redistribute static routes into eigrp on NX7K switch. 

Here's one of the static route statement that I need to redistribute: 

 

ip route 192.168.1.0 255.255.255.0  10.1.9.254

 

If I don't use the "set" statement under the route-map, how/where in your approach would you set the next-hop for the static route?

 

Thanks in advance.

 

Best~sK

 

 

Hello,

 

here is what the config would look like:

 

access-list 10 permit 192.168.1.0 0.0.0.255
!
route-map RM_STATIC_EIGRP permit 10
match ip address 10
!
router eigrp 1
redistribute static route-map RM_STATIC_EIGRP

Thanks for the reply.

I'm afraid that the access-list statement you defined in your config won't work on the NX-OS because on the NX-OS a destination parameter is required and that's the reason why I chose to use the prefix-lists.

Also, I seem to have a difficult time understanding where in your config a next-hop is defined for the source subnet 192.168.1.0 255.255.255.0. The static route is as follows :

192.168.1.0 255.255.255.0 10.1.9.254. 

The next-hop needs to be defined, doesn't it? 

I was hoping that you would clarify that for me so I could understand it better.

Thanks in advance.
~zK

Hello,

 

you don't need to define a next hop. You match on the static route destination (192.168.1.0/24 in your case):

 

ip prefix-list PL_ALLOW seq 10 permit 192.168.1.0/24
!
route-map RM_STATIC_EIGRP permit 10
match ip address prefix-list PL_ALLOW
!
router eigrp 1
redistribute static route-map RM_STATIC_EIGRP

 

 

I see. So, in essence the "redistribute static route-map RM_STATIC_EIGRP" statement will call the static route being "ip route 192.168.1.0 255.255.255.0 10.1.9.254" and filter the source address based on the prefix-list which is PL_ALLOW and the next-hop is already defined in the static route. 

 

I hope I got it right. 

 

 

Hello,

 

you filter the destination address (192.168.1.0/24 is the destination). 

Correct. The dest network/subnet is 192.168.1.0/24.

 

Thanks for your help on this.

 

Best, ~zK

Review Cisco Networking for a $25 gift card