cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

3153
Views
0
Helpful
2
Replies
Highlighted
Beginner

eigrp stub, connected route not redistributed !

Hello,

I have a strange problem happening in my topology I can't reproduce in labs :

Some directly connected route are not redistributed to eigrp, wheras it's configured to.

I have 3 locations with  2 stacked switchs c3750E 12.2(53)SE2 (UNIVERSALK9) ipbase

Theses 3 stacks are full mesh, interconnected by 2 independant networks : vlan64 and vlan65

I don't know the technlogy used for these interconnection, cause it's a link layer 2 subscribed to a provider.

Vlan 65 is down, cause the link is not operational now.

The main objective for that, is to be able to join each location with a redundant link. For us, EIGRP was the best choice...

here is a schema, much more explicit :

topo.png

For workaround, we have put static route for each FW-SW interco (underlined by ** in the conf), If we don't do that, each FW-SW interco are not recognized by neighbor switchs, and not part of the routing tab.

here is the conf :

SW1#sh run | begin router

router eigrp 100

variance 2

network 192.168.64.0

network 192.168.65.0

redistribute static

redistribute connected

passive-interface default

no passive-interface Vlan64

no passive-interface Vlan65

eigrp stub connected static

!

ip default-gateway 192.168.62.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.62.1

ip route 10.10.0.0 255.255.0.0 192.168.62.1

ip route 10.200.211.0 255.255.255.0 192.168.62.1

ip route 10.200.212.0 255.255.255.0 192.168.62.1

ip route 92.103.128.80 255.255.255.240 192.168.62.1

ip route 192.168.0.0 255.255.255.0 192.168.62.1

ip route 192.168.31.0 255.255.255.248 192.168.62.1

ip route 192.168.32.0 255.255.255.248 192.168.62.1

ip route 192.168.33.0 255.255.255.248 192.168.62.1

ip route 192.168.34.0 255.255.255.248 192.168.62.1

ip route 192.168.41.0 255.255.255.0 192.168.62.1

ip route 192.168.42.0 255.255.255.0 192.168.62.1

ip route 192.168.52.0 255.255.255.0 192.168.62.1

ip route 192.168.54.0 255.255.255.0 192.168.62.1

ip route 192.168.55.0 255.255.255.0 192.168.62.1

**ip route 192.168.60.0 255.255.255.224 192.168.64.3**

ip route 192.168.81.0 255.255.255.0 192.168.62.1

ip route 192.168.140.0 255.255.255.0 192.168.62.1

ip route 192.168.246.0 255.255.255.0 192.168.62.1

!

SW_1#sh run | begin Vlan62

interface Vlan62

ip address 192.168.62.2 255.255.255.224

!

interface Vlan64

description INTERCO_200

bandwidth 200000

ip address 192.168.64.2 255.255.255.224

!

interface Vlan65

bandwidth 100000

ip address 192.168.65.2 255.255.255.224

shutdown

!

and for interfaces :

!

interface GigabitEthernet1/0/48

description VL_L2LB

switchport trunk encapsulation dot1q

switchport trunk native vlan 64

switchport trunk allowed vlan 64

switchport mode trunk

shutdown

!

interface GigabitEthernet1/1/1

description VL_L2LB

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 65

switchport mode trunk

!

====SW2=====

SW2#sh run | begin router

router eigrp 100

variance 2

network 192.168.64.0

network 192.168.65.0

redistribute connected

redistribute static

passive-interface default

no passive-interface Vlan64

no passive-interface Vlan65

eigrp stub connected static

!

ip default-gateway 192.168.60.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.60.1

ip route 192.168.22.0 255.255.255.0 192.168.60.1

ip route 192.168.50.0 255.255.255.0 192.168.60.1

ip route 192.168.57.0 255.255.255.0 192.168.60.1

**ip route 192.168.62.0 255.255.255.224 192.168.64.2**

ip route 192.168.80.0 255.255.255.0 192.168.60.1

!

SW2#sh run | begin Vlan60

interface Vlan60

ip address 192.168.60.2 255.255.255.224

!

interface Vlan64

description VL_INTER_CIV

bandwidth 200000

ip address 192.168.64.3 255.255.255.224

!

interface Vlan65

bandwidth 100000

ip address 192.168.65.3 255.255.255.224

!

and for interfaces :

!

interface GigabitEthernet1/0/48

description VL_L2LA

switchport trunk encapsulation dot1q

switchport trunk native vlan 64

switchport trunk allowed vlan 64

switchport mode trunk

duplex full

!

interface GigabitEthernet2/0/48

description L2LB

switchport trunk encapsulation dot1q

switchport trunk native vlan 65

switchport trunk allowed vlan 65,200

switchport mode trunk

!

=====SW 3=====

SW3#sh run | begin router

router eigrp 100

variance 2

network 192.168.64.0

network 192.168.65.0

redistribute connected

redistribute static

passive-interface default

no passive-interface Vlan64

no passive-interface Vlan65

eigrp stub connected static

!

ip default-gateway 192.168.62.2

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.62.2

ip route 192.168.6.0 255.255.255.0 192.168.61.1

ip route 192.168.20.0 255.255.255.0 192.168.61.1

ip route 192.168.56.0 255.255.255.0 192.168.61.1

**ip route 192.168.62.0 255.255.255.224 192.168.64.2**

ip route 192.168.148.0 255.255.255.0 192.168.61.1

ip route 212.27.38.253 255.255.255.255 192.168.61.1

!

SW3#sh run | begin Vlan24

!

interface Vlan24

description VL_USER

ip address 192.168.24.1 255.255.252.0

ip helper-address 192.168.51.10

!

interface Vlan61

description VL_INTERCO

ip address 192.168.61.2 255.255.255.248

!

interface Vlan64

description INTERCO_200

bandwidth 200000

ip address 192.168.64.1 255.255.255.224

!

interface Vlan65

description INTERCO_100

bandwidth 100000

ip address 192.168.65.1 255.255.255.224

shutdown

and for interfaces :

!

interface GigabitEthernet1/1/1

description L2L IBM

switchport trunk encapsulation dot1q

switchport trunk native vlan 64

switchport trunk allowed vlan 64

switchport mode trunk

!

interface GigabitEthernet2/0/48

description L2LB

switchport trunk encapsulation dot1q

switchport trunk native vlan 65

switchport trunk allowed vlan 65

switchport mode trunk

!

here is some show :

SW2#sh ip eigrp nei

EIGRP-IPv4 Neighbors for AS(100)

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   192.168.64.2            Vl64              11 4d20h      22   200  0  571

1   192.168.64.1            Vl64              13 4d20h      13   200  0  969

SW2#sh ip route 192.168.62.0 255.255.255.224

Routing entry for 192.168.62.0/27

  Known via "static", distance 1, metric 0

  Redistributing via eigrp 100

  Advertised by eigrp 100

  Routing Descriptor Blocks:

  * 192.168.64.2

      Route metric is 0, traffic share count is 1

SW2#sh ip eigrp top 192.168.62.0/27

EIGRP-IPv4 Topology Entry for AS(100)/ID(192.168.65.3) for 192.168.62.0/27

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 13056

  Descriptor Blocks:

  192.168.64.2, from Rstatic, Send flag is 0x0

      Composite metric is (13056/0), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 10 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 0

        Originating router is 192.168.65.3

      External data:

        AS number of route is 0

        External protocol is Static, external metric is 0

        Administrator tag is 0 (0x00000000)

  192.168.64.1 (Vlan64), from 192.168.64.1, Send flag is 0x0

      Composite metric is (13312/13056), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 1

        Originating router is 192.168.80.1

      External data:

        AS number of route is 0

        External protocol is Static, external metric is 0

        Administrator tag is 0 (0x00000000)

that's quite normal, as route is put static, but if route is not put static, we have something like :

EIGRP-IPv4 Topology Entry for AS(100)/ID(192.168.64.3)

%Entry 192.168.62.0/27 not in topology table

and If I'm not wrong, there should be an output of the redistributed connected route, before the redistributed static route by 64.1, cause connected route as a lower metric than static ?!

here is the concerned route on SW1, all seems to be ok :

SW1#sh ip route 192.168.62.0

Routing entry for 192.168.62.0/27, 1 known subnets

  Attached (1 connections)

  Redistributing via eigrp 100

C       192.168.62.0 is directly connected, Vlan62

but topology from this switch should not be that ! (ie redistribute connected route should be in first place ?!, here it is entirely missing !)

SW1#sh ip eigrp top 192.168.62.0/27

EIGRP-IPv4 Topology Entry for AS(100)/ID(192.168.65.2) for 192.168.62.0/27

  State is Passive, Query origin flag is 1, 0 Successor(s), FD is 4294967295

  Descriptor Blocks:

  192.168.64.1 (Vlan64), from 192.168.64.1, Send flag is 0x0

      Composite metric is (13312/13056), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 1

        Originating router is 192.168.80.1

      External data:

        AS number of route is 0

        External protocol is Static, external metric is 0

        Administrator tag is 0 (0x00000000)

  192.168.64.3 (Vlan64), from 192.168.64.3, Send flag is 0x0

      Composite metric is (13312/13056), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 1

        Originating router is 192.168.65.3

      External data:

        AS number of route is 0

        External protocol is Static, external metric is 0

        Administrator tag is 0 (0x00000000)

And now, with a network connected /29, on the other switch, it's working !

SW2#sh ip route 192.168.61.0 255.255.255.248

Routing entry for 192.168.61.0/29

  Known via "eigrp 100", distance 170, metric 13312, type external

  Redistributing via eigrp 100

  Last update from 192.168.64.1 on Vlan64, 4d20h ago

  Routing Descriptor Blocks:

  * 192.168.64.1, from 192.168.64.1, 4d20h ago, via Vlan64

      Route metric is 13312, traffic share count is 1

      Total delay is 20 microseconds, minimum bandwidth is 200000 Kbit

      Reliability 255/255, minimum MTU 9000 bytes

      Loading 1/255, Hops 1

SW2#sh ip eigrp top 192.168.61.0/29

EIGRP-IPv4 Topology Entry for AS(100)/ID(192.168.65.3) for 192.168.61.0/29

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 13312

  Descriptor Blocks:

  192.168.64.1 (Vlan64), from 192.168.64.1, Send flag is 0x0

      Composite metric is (13312/2816), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 1

        Originating router is 192.168.80.1

      External data:

        AS number of route is 0

        External protocol is Connected, external metric is 0

        Administrator tag is 0 (0x00000000)

same as for another directly connected network in the same neighbor :

SW2#sh ip eigrp top 192.168.24.0/22

EIGRP-IPv4 Topology Entry for AS(100)/ID(192.168.65.3) for 192.168.24.0/22

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 13312

  Descriptor Blocks:

  192.168.64.1 (Vlan64), from 192.168.64.1, Send flag is 0x0

      Composite metric is (13312/2816), route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 20 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 9000

        Hop count is 1

        Originating router is 192.168.80.1

      External data:

        AS number of route is 0

        External protocol is Connected, external metric is 0

        Administrator tag is 0 (0x00000000)

few other questions :

- why redistributed connected route are not advertised correctly on eigrp on some neighbors ?

- should be connected route, mentionned with "network X.X.X.X" command to be internal, is it good ??

- is it a best practice to enforce metric by specifying it with "redistribute static metric 100000 100 255 1 1500" ?

- I think "default metric" is not useful here cause we don't redistribute another routing protocol into eigrp, am I right ?

Thanks for your investigations !

Everyone's tags (4)
2 REPLIES 2
Advisor

eigrp stub, connected route not redistributed !

Hi,

1) all is perfectly normal on sw1 and sw3 you'll see your connected routes from sw2 redistributed into EIGRP appear as D EX  but I think you have to set a metric for static routes , do they appear in the routing table of other switches as D EX ?

2)yes you can also do it this way as in IPv4 redistribution there is a include-connected default behaviour

3-4) you can specify seed metric both ways but first way will overide second way and I think you can't redistribute static into EIGRP without a seed metric

Regards.

Alain.

Don't forget to rate helpful posts.
Beginner

eigrp stub, connected route not redistributed !

Hi alain,

Thanks for your fast reply,

I don't have to specify metric for static route, as all static route are well distributed over EIGRP (see below)

SW1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.62.1 to network 0.0.0.0

     192.168.62.0/27 is subnetted, 1 subnets

C       192.168.62.0 is directly connected, Vlan62

D EX 192.168.148.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

     192.168.31.0/29 is subnetted, 1 subnets

S       192.168.31.0 [1/0] via 192.168.62.1

     192.168.61.0/29 is subnetted, 1 subnets

D EX    192.168.61.0 [170/13312] via 192.168.64.1, 5d01h, Vlan64

D EX 192.168.15.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

     192.168.60.0/27 is subnetted, 1 subnets

S       192.168.60.0 [1/0] via 192.168.64.3

S    192.168.42.0/24 [1/0] via 192.168.62.1

S    192.168.246.0/24 [1/0] via 192.168.62.1

D EX 192.168.57.0/24 [170/13312] via 192.168.64.3, 5d01h, Vlan64

D EX 192.168.56.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

S    192.168.41.0/24 [1/0] via 192.168.62.1

S    192.168.140.0/24 [1/0] via 192.168.62.1

     192.168.64.0/27 is subnetted, 1 subnets

C       192.168.64.0 is directly connected, Vlan64

S    192.168.81.0/24 [1/0] via 192.168.62.1

S    192.168.55.0/24 [1/0] via 192.168.62.1

D EX 192.168.80.0/24 [170/13312] via 192.168.64.3, 5d01h, Vlan64

     192.168.65.0/27 is subnetted, 1 subnets

D       192.168.65.0 [90/26112] via 192.168.64.3, 5d01h, Vlan64

     92.0.0.0/28 is subnetted, 1 subnets

S       92.103.128.80 [1/0] via 192.168.62.1

S    192.168.54.0/24 [1/0] via 192.168.62.1

D EX 192.168.20.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

S       10.10.0.0/16 [1/0] via 192.168.62.1

S       10.200.211.0/24 [1/0] via 192.168.62.1

S       10.200.212.0/24 [1/0] via 192.168.62.1

D EX 192.168.6.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

D EX 192.168.53.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

D EX 192.168.22.0/24 [170/13312] via 192.168.64.3, 5d01h, Vlan64

S    192.168.52.0/24 [1/0] via 192.168.62.1

     192.168.34.0/29 is subnetted, 1 subnets

S       192.168.34.0 [1/0] via 192.168.62.1

D EX 192.168.51.0/24 [170/13312] via 192.168.64.1, 5d01h, Vlan64

S    192.168.0.0/24 [1/0] via 192.168.62.1

     212.27.38.0/32 is subnetted, 1 subnets

D EX    212.27.38.253 [170/13312] via 192.168.64.1, 5d01h, Vlan64

D EX 192.168.50.0/24 [170/13312] via 192.168.64.3, 5d01h, Vlan64

     192.168.32.0/29 is subnetted, 1 subnets

S       192.168.32.0 [1/0] via 192.168.62.1

     192.168.33.0/29 is subnetted, 1 subnets

S       192.168.33.0 [1/0] via 192.168.62.1

S*   0.0.0.0/0 [1/0] via 192.168.62.1

D EX 192.168.24.0/22 [170/13312] via 192.168.64.1, 5d01h, Vlan64

As you can see, all static route are "D EX", but route to .60.0 is "S" (normal, cause i put it as static for workaround). route to .61 is good : "D EX".

If I delete my static route to .60.0 from SW1 and SW3, there will be no route to this network, (it should be, through EIGRP with SW2 redistribute connected).

Same happening for network 60.0 and 62.0 from every neighbor switch !

I test it in my lab, putting an additional static route to already defined "D EX" eigrp route.

I see all 3 route : 1 static and 2 other connected route !

comparing with my production topology, connected route are well recognized.

SW1_test#sh ip eigrp top 192.168.60.0/27

IP-EIGRP (AS 100): Topology entry for 192.168.60.0/27

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 15360

  Routing Descriptor Blocks:

  192.168.64.3, from Rstatic, Send flag is 0x0

      Composite metric is (15360/0), Route is External

      Vector metric:

        Minimum bandwidth is 200000 Kbit

        Total delay is 100 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 0

      External data:

        Originating router is 192.168.65.2 (this system)

        AS number of route is 0

        External protocol is Static, external metric is 0

        Administrator tag is 0 (0x00000000)

  192.168.64.3 (Vlan64), from 192.168.64.3, Send flag is 0x0

      Composite metric is (30720/28160), Route is External

      Vector metric:

        Minimum bandwidth is 100000 Kbit

        Total delay is 200 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 192.168.65.3

        AS number of route is 0

        External protocol is Connected, external metric is 0

        Administrator tag is 0 (0x00000000)

  192.168.65.3 (Vlan65), from 192.168.65.3, Send flag is 0x0

      Composite metric is (30720/28160), Route is External

      Vector metric:

        Minimum bandwidth is 100000 Kbit

        Total delay is 200 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 192.168.65.3

        AS number of route is 0

        External protocol is Connected, external metric is 0

        Administrator tag is 0 (0x00000000)

I emulate 2600 series (2600 Software (C2691-ADVIPSERVICESK9-M), Version 12.4(17)) with 16FE-SW module in GNS3

Here is some log event, I removed all concerned route after putting static route

SW2#sh ip eigrp event

---all after static route inserted---

94   14:11:15.269 Metric set: 192.168.62.0/27 4294967295

95   14:11:15.269 Redist rt event: Route Up

96   14:11:15.269 Redist rt change: 192.168.62.0/27 Rstatic

97   14:09:56.335 Metric set: 192.168.60.0/27 4294967295

98   14:09:56.335 Poison squashed: 192.168.60.0/27 metric chg

99   14:09:56.335 Route installing: 192.168.60.0/27 192.168.64.2

100  14:09:56.335 Find FS: 192.168.60.0/27 4294967295

101  14:09:56.335 Rcv update met/succmet: 13312 13056

102  14:09:56.335 Rcv update dest/nh: 192.168.60.0/27 192.168.64.2

103  14:09:56.335 Metric set: 192.168.60.0/27 4294967295

104  14:06:01.565 Change queue emptied, entries: 17

The switch put the biggest metric he can (integer limit) : 4294967295, amazing !

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here