cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16039
Views
0
Helpful
5
Replies
chuang123
Beginner

frame-relay Error: This command applies only to DCE interfaces

hi all,

I am setting up my ccnp home lab.

I have 4*1841 with wic-2t(smart serial) installed, and 1*2610xm with nm-8a/s intalled.

I want to use my 2610xm as frame relay switch.

but when I tried to set the clock rate on the serial interface, it pop up a error.  "

This command applies only to DCE interfaces" but I did input command frame-relay switching and frame-relay intf-type dce

I search the forum, and found it might be the physical cable issue?  I bought DB60 to ss cable, it fit perfectly on both end. but just couldn't set one end with clock rate

http://www.ebay.de/itm/290728419705?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

can anyone help? thanks!!

hostname FRSW

!

!

ip subnet-zero

!

!

!

frame-relay switching

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0

ip address 10.59.1.1 255.255.255.0

encapsulation frame-relay

no fair-queue

frame-relay intf-type dce

frame-relay route 102 interface Serial1/2 201

frame-relay route 103 interface Serial1/3 301

!

interface Serial1/1

no ip address

encapsulation frame-relay

frame-relay intf-type dce

!

interface Serial1/2

no ip address

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 301 interface Serial1/1 103

!

interface Serial1/3

no ip address

shutdown

!

interface Serial1/4

no ip address

shutdown

!

interface Serial1/5

no ip address

shutdown

!

FRSW#conf t

FRSW(config-if)#clock rate 64000

%Error: This command applies only to DCE interfaces

1 ACCEPTED SOLUTION

Accepted Solutions
Peter Paluch
Hall of Fame Cisco Employee

Hello,

Of course you can configure your lab even with the cables you currently have.

I try to set my 1841 as DCE with clock rate(but it show me another message as below)

R1(config-if)#frame-relay intf-type dce

Must enable frame-relay switching to configure DCE/NNI

Hmmm, no, this is not what you want to configure.

Look, your cables are DCE at their SS end, right? So configure your 1841 with the clock rate 128000 command but do not use the frame-relay intf-type command on your 1841. On the 2610XM, configure frame-relay switching in the global configuration mode, and on the individual interface, use the frame-relay intf-type dce command. Do not configure any clock rate on the 2610XM because the clocking is already provided by your 1841.

Once again, as I indicated earlier: it does not matter who is the physical DTE/DCE. Just make sure that the FR switch is configured as FR DCE.

Best regards,

Peter

View solution in original post

5 REPLIES 5
Peter Paluch
Hall of Fame Cisco Employee

Hello,

This is normal. There is a difference between physical layer DCE and Frame Relay DCE concept.

The physical layer DCE always depends on, and only on, the type of cable that is attached to the serial interface. A DCE cable requires that the interface provides a clocking signal that is configured using the clock rate command. Two routers connected back-to-back with a serial cable will have one DCE and one DTE interface on this link. On the DTE end, the clock rate command is ignored and actually refused just like you saw. This is correct.

The Frame Relay DCE has absolutely nothing to do with physical DCE cable. In Frame Relay, the DCE functionality refers to the operation of the LMI protocol. In LMI, one side of a Frame Relay interconnection asks about virtual circuits, their DLCIs and their status, and the other side responds. This is distinguished by the Frame Relay DTE/DCE role. A DTE interface sends LMI Status Enquiry messages and the DCE responds with LMI Status messages. If you did not configure one side of your Frame Relay link as FR DCE then the port would act as a FR DTE. There would be two FR DTE interfaces on the link, both sending LMI Status Enquiries but no one responding. These interfaces would never go up.

Feel welcome to ask further!

Best regards,

Peter

hi Peter,

I just recheck my cable... sadly, I seems bought wrong cable. on DB60 end as DTE, SS end as DCE..

I bought 10 of these cables, is anyway I can still setup my lab? I try to set my 1841 as DCE with clock rate(but it show me another message as below)

R1(config-if)#frame-relay intf-type dce

Must enable frame-relay switching to configure DCE/NNI

but my 1841 is not a frame-relay switch... should I still input this command "frame-relay switching" on my 1841?

Peter Paluch
Hall of Fame Cisco Employee

Hello,

Of course you can configure your lab even with the cables you currently have.

I try to set my 1841 as DCE with clock rate(but it show me another message as below)

R1(config-if)#frame-relay intf-type dce

Must enable frame-relay switching to configure DCE/NNI

Hmmm, no, this is not what you want to configure.

Look, your cables are DCE at their SS end, right? So configure your 1841 with the clock rate 128000 command but do not use the frame-relay intf-type command on your 1841. On the 2610XM, configure frame-relay switching in the global configuration mode, and on the individual interface, use the frame-relay intf-type dce command. Do not configure any clock rate on the 2610XM because the clocking is already provided by your 1841.

Once again, as I indicated earlier: it does not matter who is the physical DTE/DCE. Just make sure that the FR switch is configured as FR DCE.

Best regards,

Peter

View solution in original post

THANK YOU PETER!!! it works!!

R1#ping 10.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

!!!!!

so exciting to see above result now I can continue my frame-relay lab.. thank you again, I spent half day on troubleshoot this issue.

Peter Paluch
Hall of Fame Cisco Employee

Hello,

I am glad to know it is working! Good luck in your studies - and whenever you come across something you would like to ask, please feel welcome to post your questions on these forums again.

Take care.

Best regards,

Peter