06-25-2015 04:27 PM - edited 03-05-2019 01:45 AM
Hi All,
I configured route summarization eigrp. When pinging the R2-destination from R1-source(two hops away) it appears I have some sort of routing loop because I drop packets. I have attached my topology. R1, R3, R2. R3 is in the middle with two interfaces one connected to R1 and the other to R2 so, I summarized in both interfaces. I appreciate your help in advance!
R1
int serial1/1
ip summary address 10.1.0.0 255.255.252.0
R3
int serial 1/1
ip summary address 10.2.0.0 255.255.252.0
!
int serial 1/0
ip summary address 10.2.0.0 255.255.252.0
R2
int s1/1
ip summary address 10.2.0.0 255.255.252.0
06-26-2015 07:18 AM
Just a quick thing why are you summarizing twice same subnet on R3 , do it on only 1 of the interfaces i would chose s1/0 for summarization as the upstream router will be the 1 that receives the summarized route
06-26-2015 10:24 AM
Thanks for your response Mark! Yeah, I wasnt too sure if i need to put the summarized route on both interfaces or not but i figured I should because I wanted both routers to get the advertised summary route.
I have eigrp over serial connection if that helps. So I know this cant be a split-horizon issue..
Any other ideas?
06-26-2015 12:48 PM
If you remove one of those summary from r3 do you still get drops ?
If this is a lab can you post the configs ill take a look
Are you sure about spilt horizon I thought it was just on by default for frame relay serial links have you tried it ? You can check With Show interface that would have been the next thing to check
06-26-2015 12:59 PM
Hi Mark, I am have point to point serial links with eigrp running. I dont have a lab i am just trying to get these three routers up and running optimal over p to p serial links over eigrp. since I was reading about summarized routes I thought to practice but came accross these packet losses I didnt like between r1 and r2
R1#sho run | s eigrp
ip summary-address eigrp 33 10.1.0.0 255.255.252.0 5
router eigrp 33
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
network 10.1.3.0 0.0.0.255
network 192.168.1.0
no auto-summary
R1#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.1.3.0/24 is directly connected, Loopback2
D 10.3.0.0/22 [90/2809856] via 192.168.1.2, 04:40:37, Serial1/1
D 10.2.1.0/24 [90/2297856] via 192.168.1.2, 02:46:40, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback1
D 10.2.2.0/24 [90/2297856] via 192.168.1.2, 02:46:40, Serial1/1
C 10.1.1.0/24 is directly connected, Loopback0
D 10.2.3.0/24 [90/2297856] via 192.168.1.2, 02:46:40, Serial1/1
D 10.1.0.0/22 is a summary, 04:42:39, Null0
C 192.168.1.0/24 is directly connected, Serial1/1
D 192.168.2.0/24 [90/2681856] via 192.168.1.2, 07:13:29, Serial1/1
R1#
R1#
R3#sho run | s eigrp
ip summary-address eigrp 33 10.2.0.0 255.255.252.0 5
router eigrp 33
network 10.2.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 10.2.3.0 0.0.0.255
network 192.168.1.0
network 192.168.2.0
no auto-summary
R3#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.2.0.0/22 is a summary, 02:49:22, Null0
D 10.3.0.0/22 [90/2297856] via 192.168.2.2, 04:44:12, Serial1/0
C 10.2.1.0/24 is directly connected, Loopback0
C 10.2.2.0/24 is directly connected, Loopback1
C 10.2.3.0/24 is directly connected, Loopback2
D 10.1.0.0/22 [90/2297856] via 192.168.1.1, 04:46:16, Serial1/1
C 192.168.1.0/24 is directly connected, Serial1/1
C 192.168.2.0/24 is directly connected, Serial1/0
R3#
R2#sho run | s eigrp
ip summary-address eigrp 33 10.3.0.0 255.255.252.0 5
router eigrp 33
network 10.3.1.0 0.0.0.255
network 10.3.2.0 0.0.0.255
network 10.3.3.0 0.0.0.255
network 192.168.2.0
no auto-summary
R2#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.3.1.0/24 is directly connected, Loopback0
D 10.2.0.0/22 [90/2297856] via 192.168.2.1, 02:47:51, Serial1/1
D 10.3.0.0/22 is a summary, 04:41:18, Null0
C 10.3.3.0/24 is directly connected, Loopback2
C 10.3.2.0/24 is directly connected, Loopback1
D 10.1.0.0/22 [90/2809856] via 192.168.2.1, 04:43:20, Serial1/1
D 192.168.1.0/24 [90/2681856] via 192.168.2.1, 07:14:07, Serial1/1
C 192.168.2.0/24 is directly connected, Serial1/1
R2#
06-29-2015 02:58 AM
Hi
i threw your config into a quick lab , strange enough as below mine works fine , what i notice is im receiving only the summary routes from R3 on r1 and r2 while you also receive the /24 addresses on r1 from r3 even though there's a summary on the interface that is if you still have the 2 summary's configured on r3 , im not dropping any traffic as below between r1 and r2 , are the 2 summary routes still there
r1#ping 10.3.2.1 re 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.3.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 28/70/104 ms
r1#ping 10.3.3.1 re 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 20/68/112 ms
r1#sh ip route | b Gate
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.2.0.0/22 [90/2297856] via 192.168.1.2, 00:04:41, Serial1/1
C 10.1.3.0/24 is directly connected, Loopback3
D 10.3.0.0/22 [90/2809856] via 192.168.1.2, 00:02:50, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback2
C 10.1.1.0/24 is directly connected, Loopback1
D 10.1.0.0/22 is a summary, 00:09:43, Null0
C 192.168.1.0/24 is directly connected, Serial1/1
D 192.168.2.0/24 [90/2681856] via 192.168.1.2, 00:16:18, Serial1/1
r1##
r2#sh ip route | b Gatew
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.3.1.0/24 is directly connected, Loopback1
D 10.2.0.0/22 [90/2297856] via 192.168.2.1, 00:03:39, Serial1/1
D 10.3.0.0/22 is a summary, 00:01:54, Null0
C 10.3.3.0/24 is directly connected, Loopback3
C 10.3.2.0/24 is directly connected, Loopback2
D 10.1.0.0/22 [90/2809856] via 192.168.2.1, 00:08:46, Serial1/1
D 192.168.1.0/24 [90/2681856] via 192.168.2.1, 00:14:29, Serial1/1
C 192.168.2.0/24 is directly connected, Serial1/1
r2#ping 10.1.2.1 re 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 12/57/108 ms
r2#ping 10.1.3.1 re 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 12/61/120 ms
r2#
r3#sh ip route | b Gat
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.2.0.0/22 is a summary, 00:13:40, Null0
D 10.3.0.0/22 [90/2297856] via 192.168.2.2, 00:11:49, Serial1/1
C 10.2.1.0/24 is directly connected, Loopback1
C 10.2.2.0/24 is directly connected, Loopback2
C 10.2.3.0/24 is directly connected, Loopback3
D 10.1.0.0/22 [90/2297856] via 192.168.1.1, 00:18:41, Serial1/0
C 192.168.1.0/24 is directly connected, Serial1/0
C 192.168.2.0/24 is directly connected, Serial1/1
r3#
06-30-2015 04:55 PM
Hi Mark, Thanks for the follow up. Yeah, this one is bugging me.. so where it loses packets is from R1 to R2 and vice versa. the middle router R3 i can both routers just fine. Any idea why I could be losing packets from R1 to R2? R3 pinging out of both interfaces is 100 percent successful.
07-01-2015 01:08 AM
If you remove the summary routes does it stop the drops to rule that out as i was not able to replicate the problem with the config you provided using summary routes so it may be something else?
Is there anything else set under the interfaces for the interfaces involved
07-01-2015 11:27 AM
I just removed the summary routes and that worked. pings 100 percent accross all routers with no packet loss.
Before removing the summary routes here is the configurations with summary routes:
R1
interface Serial1/1
ip address 192.168.2.2 255.255.255.0
ip summary-address eigrp 33 10.1.0.0 255.255.252.0 5
serial restart-delay 0
R3
interface Serial1/0
ip address 192.168.2.1 255.255.255.0
ip summary-address eigrp 33 10.2.0.0 255.255.252.0 5
serial restart-delay 0
no fair-queue
!
interface Serial1/1
ip address 192.168.1.2 255.255.255.0
serial restart-delay 0
R2
interface Serial1/1
ip address 192.168.2.2 255.255.255.0
ip summary-address eigrp 33 10.3.0.0 255.255.252.0 5
serial restart-delay 0
07-01-2015 02:04 PM
acutally I noticed just now that the packets drop even with no summary. So the issue indeed is not with the summary route.
07-01-2015 02:43 PM
Do I need to put a clock rate somewhere?
07-02-2015 12:26 AM
ok so thats confirmed then at least as i got no drops in my lab same config which is good to rule out the summarization , yes clocking is required in real world equipment not in labs usually , clocking is set on the dce side , i think from memory you can check which is dce if already connected from doing a show controllers sx/x/x it should tell your interface is dte or dce , it depends on the cable connection
Are you seeing drops under the serial interfaces incrementing when pinging , crcs,frame errors ?
07-02-2015 10:11 AM
No I dont see any counters incrementing.
Success rate is 60 percent (3/5), round-trip min/avg/max = 24/565/1528 ms
R1#sho int serial 1/1
Serial1/1 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.1.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:00, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5520 packets input, 359046 bytes, 0 no buffer
Received 1889 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
5483 packets output, 356804 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
2 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up
R3#sho int serial 1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.2.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:02, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
44229 packets input, 2881229 bytes, 0 no buffer
Received 17120 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
44868 packets output, 2923804 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 output buffer failures, 0 output buffers swapped out
5 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up
R3#sho int serial 1/1
Serial1/1 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
44700 packets input, 2904868 bytes, 0 no buffer
Received 17210 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
45052 packets output, 2932794 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
R2#sho int serial 1/1
Serial1/1 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.2.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:03, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5591 packets input, 363560 bytes, 0 no buffer
Received 1914 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
5521 packets output, 359082 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
2 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up
R3#sho int serial 1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 192.168.2.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:02, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
44333 packets input, 2888380 bytes, 0 no buffer
Received 17153 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
44974 packets output, 2931028 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 output buffer failures, 0 output buffers swapped out
5 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide