04-18-2017 01:36 PM - edited 03-05-2019 08:22 AM
Hi All,
My workplace has made the decision to move from the 3750 platform to the ASR platform (they have purchased an ASR 920). I have never worked with the ASR routers so I'm a bit lost. We have a few buildings that interconnect with fiber through the 3750, which will be replaced with an ASR 920.
What is the best way to replicate the same vlan and vlan-interface behavior that we currently have set up on our 3750? I have read up a bit on the 920's and it says a lot about using service instances and BDI's, but I'm not sure how to do it properly. I have a bit of a lab setup so I am lucky enough to be able to play with the device a bit before we deploy it. Here's the currently configuration on our 3750 that is at the core of our other switches that I'm wanting to translate onto the ASR 920:
vlan 10
name Workstations
vlan 20
name Printers
vlan 30
name KVM
interface GigabitEthernet1/0/1
description Link to Building 1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30
switchport mode trunk
interface GigabitEthernet1/0/2
description Link to Building 2
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30
switchport mode trunk
interface GigabitEthernet1/0/3
description Link to Building 3
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30
switchport mode trunk
interface Vlan10
ip address 192.168.10.1 255.255.255.0
interface Vlan20
ip address 192.168.20.1 255.255.255.0
interface Vlan30
ip address 192.168.30.1 255.255.255.0
Any help would be appreciated.
Thanks,
JB
04-20-2017 12:52 AM
You are using a flat vlan structure across all your buildings. I'm not sure the ASR920 was the best choice.
Yes, you will need to use bridge domains.
05-10-2017 03:47 AM
long time has passed since I used asr9xx, yet it supposed to be like that.
interface GigabitEthernet1/0/1
description Link to Building 1
service-instance 10 ethernet
encapsulation dot1q untagged
bridge-domain 10
service-instance 20 ethernet
encapsulation dot1q vlan 20
bridge-domain 20
service-instance 30 ethernet
encapsulation dot1q vlan 30
bridge-domain 30
int vlan (can be BVI, not really sure) 10
ip addr
int vlan 20
ip addr
int vlan 30
ip add
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide