cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
707
Views
0
Helpful
4
Replies
Highlighted
Beginner

GRE NAT configuration not working

I have a router with the following configuration and i am not seeing any NAT Translation can you please let me know where is the mistake.

The inside interface is Gigabit Ethernet 2. 

I am natting  107.154.50.39 to 10.0.1.142

interface Tunnel0

ip address 192.168.247.29 255.255.255.252

ip nat outside

tunnel source 10.0.0.252

tunnel destination 107.154.40.168

!

!

interface GigabitEthernet2

ip address dhcp

ip nat inside

negotiation auto

!         

ip nat pool LAN-NAT 107.154.50.39 107.154.50.39 prefix-length 24

ip nat inside source route-map GRE-NAT pool LAN-NAT

route-map GRE-NAT permit 10

match ip address office22

ip access-list extended office22

permit ip host 10.0.1.142 any

4 REPLIES 4
Highlighted
Advisor

If you are NATing 107.154.50

If you are NATing 107.154.50.39 to 10.0.1.142 you should replace the NAT config with:

ip nat inside source static 10.0.1.142 107.154.50.39

Highlighted
Beginner

Philip

Philip

I had tested this statement before I was able to see NAT translations coming in but when traffic came from instance back to Internet it was not NAtting.

That is the reason I tried this different config it was not doing any translations 

I think this is something to do with tunnel interface NAT

regards 

anuj 

Highlighted
Beginner

Hi, Can the outside

Hi, Can the outside interfaces ping each other?

Do you have an ip route to reach the other side of the GRE tunnel or a router protocol?

Highlighted
Advisor

The NAT configuration I have

The NAT configuration I have given is correct, so it is some other issue - such as a lack of understanding of how your environment works.

Where does this tunnel go to?  Is your Internet actually delivered over this tunnel?  Do you have a default route pointing to  192.168.247.30?

Perhaps try posting your whole config.