cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1823
Views
0
Helpful
2
Replies
laviel
Cisco Employee

GRE tunnel as OSPF neighbor

Hi all,

I have a setup in which I've got two routers (router A and router B) connected indirectly through several other routers and between these two routers theres a functioning GRE tunnel whose IP address on each side is based on the loopback address (10.11.21.5 and 10.11.21.6 respectively). In addition there's an MPLS-TE tunnel headed from router B to router A, also based on these loopback addresses.

Point-to-Point OSPF is running between each of the routers and its adjacent core routers (see diagram below). All OSPF neighbors are up correctly, but the thing is that there's an OSPF adjacency over the GRE tunnel as well and I'm not sure how to get rid of it. Here's the diagram:

OSPF_GRE_diagram.jpg

Here is the output of show ip ospf neighbor from both routers:

Router A:

RouterA1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.11.21.6        0   FULL/  -        00:00:32    10.11.21.6      Tunnel501

10.11.21.4        0   FULL/  -        00:00:39    10.11.11.45     GigabitEthernet2/4

10.11.21.4        0   FULL/  -        00:00:39    10.11.11.41     GigabitEthernet2/3

10.11.21.3        0   FULL/  -        00:00:31    10.11.11.29     GigabitEthernet5/1/1

10.10.21.2        0   FULL/  -        00:00:38    10.11.11.25     GigabitEthernet5/1/0

RouterA#

Router B:

RouterB#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.11.21.5        0   FULL/  -        00:00:39    10.11.21.5      Tunnel501

10.11.21.3        0   FULL/  -        00:00:34    10.11.11.37     GigabitEthernet6/0/1

10.11.21.1        0   FULL/  -        00:00:38    10.11.11.33     GigabitEthernet6/0/0

RouterB#

Here are the GRE tunnel configurations, plus the loopback configurations on the two routers:

Router A:

interface Tunnel501

description ### GRE Tunnel to NPE-7609-RAN1 ###

ip unnumbered Loopback0

no ip route-cache

keepalive 60 5

tunnel source 10.11.11.26

tunnel destination 10.11.11.34

tunnel key 30

tunnel checksum

end

interface Loopback0

ip address 10.11.21.5 255.255.255.255

end

Router B:

interface Tunnel501

description ### GRE Tunnel to NPE-7606-RAN1 ###

ip unnumbered Loopback0

no ip route-cache

keepalive 60 5

tunnel source 10.11.11.34

tunnel destination 10.11.11.26

tunnel key 30

tunnel checksum

end

interface Loopback0

ip address 10.11.21.6 255.255.255.255

end

Here's the show run | s router ospf section from both routers:

Router A:

RouterA#show run | s router ospf

router ospf 65200

router-id 10.11.21.5

network 10.11.11.24 0.0.0.3 area 0

network 10.11.11.28 0.0.0.3 area 0

network 10.11.11.40 0.0.0.3 area 0

network 10.11.11.44 0.0.0.3 area 0

network 10.11.21.5 0.0.0.0 area 0

bfd all-interfaces

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

Router B:

RouterB#show run | s router ospf

router ospf 65200

router-id 10.11.21.6

network 10.11.11.32 0.0.0.3 area 0

network 10.11.11.36 0.0.0.3 area 0

network 10.11.21.6 0.0.0.0 area 0

bfd all-interfaces

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

If there are any other missing details, pleaes let me know.

Thanks in advance,

Lior

1 ACCEPTED SOLUTION

Accepted Solutions
Peter Paluch
Hall of Fame Cisco Employee

Hello Lior,

Your issue is caused by the fact that your Tunnel interfaces are configured as IP Unnumbered interfaces, using the IP address from the loopbacks, and you have added the loopback addresses into OSPF. As a result, OSPF runs on all interfaces that share the IP addresses of the loobacks - in your case, the tunnels. This is the general behavior of IP Unnumbered - as soon as you add the "master" interface to a routing protocol, it will run on all interfaces that share the IP address of the "master" interface.

There are two ways of getting rid of the OSPF adjacency through the GRE tunnels - either configure the tunnels with their own unique IP address that is not added to OSPF, or declare them as passive interfaces in the OSPF configuration.

Best regards,

Peter

View solution in original post

2 REPLIES 2
Peter Paluch
Hall of Fame Cisco Employee

Hello Lior,

Your issue is caused by the fact that your Tunnel interfaces are configured as IP Unnumbered interfaces, using the IP address from the loopbacks, and you have added the loopback addresses into OSPF. As a result, OSPF runs on all interfaces that share the IP addresses of the loobacks - in your case, the tunnels. This is the general behavior of IP Unnumbered - as soon as you add the "master" interface to a routing protocol, it will run on all interfaces that share the IP address of the "master" interface.

There are two ways of getting rid of the OSPF adjacency through the GRE tunnels - either configure the tunnels with their own unique IP address that is not added to OSPF, or declare them as passive interfaces in the OSPF configuration.

Best regards,

Peter

View solution in original post

Hi Peter,

Thanks a lot for your answer, I'll give the passive interface a try

Regards,

Lior