cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1037
Views
0
Helpful
3
Replies

Help to create frame-relay multilink PPP

Steph1963
Beginner
Beginner

Hi,

I would like to know if it is possible to build  a frame-relay multiplink PPP on more than one interface. In other words, could we aggregate two serial port and build a single bundle of frame-relay multilink PPP and keep the same map-class frame-relay SHAPE_384K using the following configuration.

I would also like to understand why the following configuration creates virtual-Template and Virtual-access interfaces:

show ip int brief

Virtual-Access1            177.1.101.1     YES TFTP   up                    up

Virtual-Template1          177.1.101.1     YES TFTP   down                  down

Thanks for your help

Stephane

Configuration

class-map match-all VOICE

match ip dscp ef

class-map match-all SIGNALING

match ip dscp cs3

!

policy-map CBWFQ

class VOICE

    priority 48

class SIGNALING

    bandwidth 8

class class-default

    fair-queue

!

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay traffic-shaping

!

interface Serial1/0.1 point-to-point

frame-relay interface-dlci 112 ppp Virtual-Template1

  class SHAPE_384K

!

interface Virtual-Template1

bandwidth 384

ip unnumbered Loopback0

ppp multilink

ppp multilink interleave

ppp multilink fragment delay 13

service-policy output CBWFQ

!

map-class frame-relay SHAPE_384K

frame-relay cir 384000

frame-relay bc 3840

frame-relay be 0

frame-relay mincir 384000

1 Accepted Solution

Accepted Solutions

Hey Steph,

virtual-templates, act like template configurations which u can call for different interfaces, to my understanding the virtual access is the resemblance of the bind between the template and a physical interface, i believe because a template is never directly in action it is down, but where it is in effect with a physical interface, the binding (virtual access) comes up up.

here in ur original post i saw that you want to do a multilink on Frame Relay VC's, it is called PPP over Frame Relay, so its DLCI membership in a multilink interface is configured with utilizing virtual templates through the below command:

interface serial1/0/0/1:0

  frame-relay interface-dlci 100 ppp virtual-template 1

in the other config u shared above, those interfaces are originally using PPP encapsulation, it is different from PPPoFR which u deal with virtual circuits and per DLCI.

HTH

plz Rate helpful posts.


Soroush.

Hope it Helps!

Soroush.

View solution in original post

3 Replies 3

smehrnia
Rising star
Rising star

Hi,

virtual access is a cloned interface, which is created automatically along with the virtual template. as the name of the Virtual-Template implies it is a template used for creating virtual interfaces, whenever u use the template and bind it to an interface n it starts working it creates this virtual access instance.

keep in mind that to make a multilink bundle u need to be able to configure the other end of the connection as MPPP too.

U have to create ur physical FR interfaces, assign class-maps n bind a virtual template to the SVC's u link to be in the bundle:

interface virtual-template X

  no ip address

  ppp multilink

  ppp multilink group 1

and then create the multilink interface and assign ur desired setting to it:

interface multilink X

ip address x.x.x.x

bandwidth xxx

ppp multilink

ppp multilink group 1  .... (same group number)

ppp multilink fragment delay 13

service-policy output CBWFQ

Hope it Helps,

Soroush.

Hope it Helps!

Soroush.

Hi Soroush,

Thanks a lot for your reply, a virtual-access is a cloned interface from the virtual-template make sense to me. Can we say that the virtual-access interface can be up or down while virtual-template is always down. What could be the reason for this?

I would like to understand if I can use the following configuration in the case where I want to assing a second interface to the sampe multilink PPP bundle.

interface Serial1/1.1 point-to-point

frame-relay interface-dlci 112 ppp Virtual-Template1

  class SHAPE_384K

I think I am confused about the utilization of a virtual Template. I am not sure when a Virtual Template is required or not. In your configuration example, you are using a virtual template.

interface virtual-template X

  no ip address

  ppp multilink

  ppp multilink group 1

interface multilink X

  ip address x.x.x.x

  bandwidth xxx

  ppp multilink

  ppp multilink group 1  .... (same group number)

  ppp multilink fragment delay 13

  service-policy output CBWFQ

I would assume that the interace configuration would be the following but I am not sure

interface serial1/0/0/1:0

  frame-relay inerface-dlci 100 ppp virtual-template 1

But I have also seen configuration example like the following one with no virtual-template. Why in this case, no virtual-template is require.

interface Multilink1

ip unnumbered Loopback0

ppp multilink

ppp multilink group 1

!

interface Serial1/4

bandwidth 2000

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial1/5

bandwidth 4000

encapsulation ppp

ppp multilink

ppp multilink group 1

serial restart-delay 0

Thanks for all your help

Stephane

Hey Steph,

virtual-templates, act like template configurations which u can call for different interfaces, to my understanding the virtual access is the resemblance of the bind between the template and a physical interface, i believe because a template is never directly in action it is down, but where it is in effect with a physical interface, the binding (virtual access) comes up up.

here in ur original post i saw that you want to do a multilink on Frame Relay VC's, it is called PPP over Frame Relay, so its DLCI membership in a multilink interface is configured with utilizing virtual templates through the below command:

interface serial1/0/0/1:0

  frame-relay interface-dlci 100 ppp virtual-template 1

in the other config u shared above, those interfaces are originally using PPP encapsulation, it is different from PPPoFR which u deal with virtual circuits and per DLCI.

HTH

plz Rate helpful posts.


Soroush.

Hope it Helps!

Soroush.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers