10-24-2015 09:02 PM - edited 03-05-2019 02:35 AM
Assuming I did everything else right...what might I be missing?
R2 and R3 have been configured with physical IPv4 addresses/Loopbacks and each also has an IPv6 Loopback simulating an internal network.
I even configured the Tunnels on each Router with their own IPv6 address.
All three Routers are running OSPF and while only R2 and R3 are running OSPFv3...with all their IPv6 addresses, including the tunnels, being incorporated into the Routing.
R2 and R3 still don't know about each other.
Obviously R1 has no IPv6 information but in all the demonstrations, I never saw the MIDDLE router having to be configured with anything that R2 and R3 do.
What should I do?
Solved! Go to Solution.
10-25-2015 04:14 PM
I implemented your scenario in a simulator. Please try this config and give me the result. Please see the result of ping attached. Redistribute is not needed. I put it just in case.
R1
hostname R1
ipv6 unicast-routing
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Loopback101
ipv6 address 2001:101:101:1::1/64
ipv6 ospf 111 area 0
!
interface Tunnel1
ipv6 address 2001:404:404:4::4/64
ipv6 ospf 111 area 0
tunnel source 1.1.1.1
tunnel destination 2.2.2.2
!
!
interface Serial1/0
ip address 192.40.0.28 255.255.255.0
encapsulation ppp
router ospf 3
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.40.0.0 0.0.0.255 area 0
ipv6 router ospf 111
redistribute connected
log-adjacency-changes
***********
R0
!
interface Serial0
ip address 192.40.0.27 255.255.255.0
encapsulation ppp
!
interface Serial1
ip address 23.0.2.5 255.255.255.248
encapsulation ppp
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
********************************
R2
hostname R2
ipv6 unicast-routing
!
interface Loopback2
ip address 2.2.2.2 255.255.255.0
interface Loopback202
no ip address
ipv6 address 2001:202:202:2::2/64
ipv6 ospf 222 area 0
!
interface Tunnel1
no ip address
ipv6 address 2001:404:404:4::3/64
ipv6 ospf 222 area 0
tunnel source 2.2.2.2
tunnel destination 1.1.1.1
!
!
interface Serial0
ip address 23.0.2.6 255.255.255.248
encapsulation ppp
!
ipv6 router ospf 222
log-adjacency-changes
redistribute connected
10-25-2015 09:22 AM
I see two tunnels in your attachment. You need only one tunnel in this case.
Follow these steps.
1- Run OSPF on Router R0 and R1 and R2 and advertise IP address of your links and loopback1
2- Router R1 should ping both R2 link and loopback1.
3- Create a tunnel from R1 to R2 (only one Tunnel ) .
Configure the source and destination addresses. Source and destination addresses are 192.40.0.0 and 23.0.2.0
Configure an IPV6 address on Tunnel both sides.
4-You are able to ping the IPV6 address of R1 from R2 if your tunnel configuration is correct.
5- Configure OSPFv3 on R1 and R2 and advertise loopback 101 and 202.
Please share your config if you are not able to ping after the change.
Hope it helps,
Masoud
10-25-2015 09:48 AM
Hello
depends on what tunneliing IPv4 -IPv6 feature you are using
Can you post your confiig for these 3 rtrs please
res
paul
10-25-2015 02:44 PM
I still cannot ping from either side
here's my configurations...Router 0 omitted...he's good to go.
i can only specify a source INTERFACE here in packet tracer for some reason
R2
!
!
ipv6 unicast-routing
!
interface Loopback2
ip address 2.2.2.2 255.255.255.0
!
interface Loopback202
no ip address
ipv6 address 2001:202:202:2::2/64
!
interface Tunnel1
no ip address
mtu 1476
ipv6 address 2001:404:404:4::3/64
ipv6 ospf 222 area 0
tunnel source Serial0
tunnel destination 192.40.0.28
!
!
interface Serial0
ip address 23.0.2.6 255.255.255.248
!
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.0.2.0 0.0.0.7 area 0
R1
!
!
ipv6 unicast-routing
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
!
!
interface Loopback101
no ip address
ipv6 address 2001:101:101:1::1/64
!
interface Tunnel1
no ip address
mtu 1476
ipv6 address 2001:404:404:4::4/64
ipv6 ospf 111 area 0
tunnel source Serial0
tunnel destination 23.0.2.6
!
!
!
interface Serial0
ip address 192.40.0.28 255.255.255.0
!
!
!
!
router ospf 3
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.40.0.0 0.0.0.255 area 0
10-25-2015 02:44 PM
How about R0? Do you have OSPF on R0?
Can you ping 23.0.2.6 from R1?
can you ping 2.2.2.2 from R1?
Can you ping 2001:404:404:4::3 from R1?
10-25-2015 03:07 PM
hey Masoud
yes all IPv4 addresses are ping'able.
as far as OSPFv3 goes...i've tried configuring it on ONLY loop 101/202, then ONLY the Tunnel on BOTH sides, then BOTH
still nothing.
i even fixed my SOURCE/DESTINATION statements on both sides...still nothing.
R1...tunnel source Serial 0 tunnel destination 23.0.2.6
R2...tunnel source Serial 0 tunnel destination 192.40.0.28
10-25-2015 03:23 PM
everything looks good to me.
Share your final configurationin including R0, R1, R2 here so that I can test it on a simulator. and give the result back.
10-25-2015 05:31 PM
I finally got it to work.
I only used one Loopback each on R1 and R2.
I put IP4 and IP6 addresses on the same Loopback.
Plus, I added the tunnel mode ipv6ip statement.
One or both of those made it work.
10-25-2015 05:39 PM
Glad it worked. Check also my previous comment. I implemented you scenario in a simulator with your IPs. It worked. The result is attached to that comment. Please rate my comments if you are happy with.
Masoud
10-26-2015 03:52 PM
IPv6ip in unrelated, It may cause problem if MTU is not set properly.
I think your problem is OSPFV3. Please implement the configuration on my previous comment and share the result.
To check your tunnel: Ping the IP address of tunnel on the other side.
To check your routing table: show ipv6 route.
10-25-2015 04:14 PM
I implemented your scenario in a simulator. Please try this config and give me the result. Please see the result of ping attached. Redistribute is not needed. I put it just in case.
R1
hostname R1
ipv6 unicast-routing
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Loopback101
ipv6 address 2001:101:101:1::1/64
ipv6 ospf 111 area 0
!
interface Tunnel1
ipv6 address 2001:404:404:4::4/64
ipv6 ospf 111 area 0
tunnel source 1.1.1.1
tunnel destination 2.2.2.2
!
!
interface Serial1/0
ip address 192.40.0.28 255.255.255.0
encapsulation ppp
router ospf 3
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.40.0.0 0.0.0.255 area 0
ipv6 router ospf 111
redistribute connected
log-adjacency-changes
***********
R0
!
interface Serial0
ip address 192.40.0.27 255.255.255.0
encapsulation ppp
!
interface Serial1
ip address 23.0.2.5 255.255.255.248
encapsulation ppp
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
********************************
R2
hostname R2
ipv6 unicast-routing
!
interface Loopback2
ip address 2.2.2.2 255.255.255.0
interface Loopback202
no ip address
ipv6 address 2001:202:202:2::2/64
ipv6 ospf 222 area 0
!
interface Tunnel1
no ip address
ipv6 address 2001:404:404:4::3/64
ipv6 ospf 222 area 0
tunnel source 2.2.2.2
tunnel destination 1.1.1.1
!
!
interface Serial0
ip address 23.0.2.6 255.255.255.248
encapsulation ppp
!
ipv6 router ospf 222
log-adjacency-changes
redistribute connected
10-25-2015 03:00 PM
If you did not redistribute connected routes under ospfv3, add these commands
R1
interface Loopback101
ipv6 ospf 111 area 0
R2
interface Loopback202
ipv6 ospf 222 area 0
10-25-2015 10:28 AM
Hello,
Please check this sample configuration. I checked it. It works. Topology is attached.
*********************
R2
ipv6 unicast-routing
interface Loopback10
ip address 172.16.1.2 255.255.255.255
!
interface Loopback100
ipv6 address 2003::1:1/124
ipv6 enable
!
interface Tunnel0
ipv6 address 3FFE:B00:C18:1::2/127
ipv6 ospf 1 area 0
tunnel source 1.1.1.1
tunnel destination 2.2.2.1
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
duplex half
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 172.16.1.2 0.0.0.0 area 0
!
ipv6 router ospf 100
redistribute connected
***************************************************************
R1
hostname R1
interface Loopback10
ip address 172.16.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.0
duplex half
!
interface FastEthernet1/0
ip address 2.2.2.2 255.255.255.0
duplex half
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
**********************************************************************
R3
ipv6 unicast-routing
interface Loopback0
ip address 172.16.1.3 255.255.255.255
!
interface Loopback100
ipv6 address 2003::2:1/124
!
interface Tunnel0
ipv6 address 3FFE:B00:C18:1::3/127
ipv6 ospf 100 area 0
tunnel source 2.2.2.1
tunnel destination 1.1.1.1
!
interface FastEthernet0/0
ip address 2.2.2.1 255.255.255.0
duplex half
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 172.16.1.3 0.0.0.0 area 0
ipv6 router ospf 100
redistribute connected
Masoud
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide