cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
132
Views
1
Helpful
2
Replies

How do you rate-limit / police an mpls pseudowire configuration?

kevin.r719
Level 1
Level 1

so I'm migrating an l2tp tunnel to an eompls link i'd like to to attach the same rate-limiter ex:  (2 cisco 2900's)

class-map match-all L2TPV3-TRAFFIC
 match access-group 130

policy-map L2TP_PM_OUT
 class L2TPV3-TRAFFIC
  shape average 40000000
 class class-default
policy-map TUN_PM_OUT
 class class-default
  shape average 50000000
   service-policy L2TP_PM_OUT

access-list 130 permit 115 any any


int tunnel1
....
 service-policy output  TUN_PM_OUT

with l2tp i could select the traffic by protocol, but eompls is just mpls traffic?

the new config is pretty simple, however i'll have multiple pseudowires terminating on one device so i'd like to apply it at the tunnel level .

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 no lldp transmit
 no lldp receive
 no cdp enable
 xconnect 192.168.1.2 1 encapsulation mpls
2 Replies 2

I think you can do that under Pseudo class, which later add with xconnect command 
MHM

antisocial11224
Level 1
Level 1

@kevin.r719 wrote:

so I'm migrating an l2tp tunnel to an eompls link i'd like to to attach the same rate-limiter ex:  (2 cisco 2900's)

class-map match-all L2TPV3-TRAFFIC
 match access-group 130

policy-map L2TP_PM_OUT
 class L2TPV3-TRAFFIC
  shape average 40000000
 class class-default
policy-map TUN_PM_OUT
 class class-default
  shape average 50000000
   service-policy L2TP_PM_OUT

access-list 130 permit 115 any any


int tunnel1
....
 service-policy output  TUN_PM_OUT

with l2tp i could select the traffic by protocol, but eompls is just mpls traffic?

the new config is pretty simple, however i'll have multiple pseudowires terminating on one device so i'd like to apply it at the tunnel level .

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 no lldp transmit
 no lldp receive
 no cdp enable
 xconnect 192.168.1.2 1 encapsulation mpls

Here's how you can rate-limit MPLS pseudowires on your Cisco 2900s, similar to how you policed L2TP traffic:

1. Class-Map for MPLS Pseudowire Traffic:

First, define a class-map to identify the MPLS pseudowire traffic you want to rate-limit. You can achieve this in two ways:

  • DSCP Marking: If your MPLS packets are already marked with a specific Differentiated Services Code Point (DSCP), you can use a class-map that matches based on DSCP:
Cisco CLI
class-map MATCH-MPLS-PW
  match dscp ef  ! Replace "ef" with your actual DSCP marking
Review Cisco Networking for a $25 gift card