cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1428
Views
20
Helpful
14
Replies

How to bind 4 T1 links as 1 tunnel link for 4 times bandwidth on 4321

Rivera Pu
Level 1
Level 1

We have a ISR4321 with 4 T1 ports. Is there any command can binding 4 T1 ports as 1 tunnel port and with redundancy function. If one T1 link is down, we will still have 75% bandwidth.

(So far the link can only use se0/2/0:0, that's not what we want)

Here is current configuration template:

controller T1 0/2/0
threshold sd-ber 6
threshold sf-ber 3
framing esf
clock source internal
linecode b8zs
cablelength long 0db
channel-group 0 timeslots 1-24
description P0 Full T1 To Future
!
controller T1 0/2/1
threshold sd-ber 6
threshold sf-ber 3
framing esf
clock source internal
linecode b8zs
cablelength long 0db
channel-group 1 timeslots 1-24
description P1 Full T1 To Future
!
controller T1 0/2/2
threshold sd-ber 6
threshold sf-ber 3
framing esf
clock source internal
linecode b8zs
cablelength long 0db
channel-group 2 timeslots 1-24
description P2 Full T1 To Future
!
controller T1 0/2/3
threshold sd-ber 6
threshold sf-ber 3
framing esf
clock source internal
linecode b8zs
cablelength long 0db
channel-group 3 timeslots 1-24
description P3 Full T1 To Future




interface Tunnel2
ip address 10.11.19.2 255.255.255.0
ip mtu 1400
ip tcp adjust-mss 1360
ip ospf dead-interval 15
ip ospf hello-interval 5
ip ospf 1 area 0
ip ospf cost 10
tunnel source Serial0/2/0:0
tunnel destination 10.12.19.1

interface Serial0/2/0:0
ip address 10.12.19.2 255.255.255.0
encapsulation ppp
!
interface Serial0/2/1:1
description T1 Link To Future
no ip address
!
interface Serial0/2/2:2
description T1 Link To Future
no ip address
!
interface Serial0/2/3:3
description T1 Link To Future
no ip address


 

 

1 Accepted Solution

Accepted Solutions

"Is there ports binding function to instead of MLPPP?"

Sometimes there is, but I believe it would require extra (often external) hardware.  (E.g. T1s using ATM and IMA).

"Something like port-channel."

MLPP is something like port-channel, but also a bit different.  Both, though, bind together multiple physical ports into one logical port.

"I am a little confused about that T1 controller setting "group-channel", is that a kind of port-channel?"

When using a T1 (or E1, too, I recall), you can divvy up its bandwidth into channels, or not.  The former allows you use one or more 64Kbps (adjacent) channels to form a subinterface.  So, using channels, is somewhat, too, like a port-channel and/or MLPPP.

If you did have subinterfaces, it might be possible to bind them into a MLPPP interface too.

I recall (?) with a single T1 channels you could do things like have four routers, each with a T1 connection.  HQ router takes its 64 channels and might use 32 of them to one of the other routers, and 16 channels to the two other routers.  Since those other three routers are not using all their 64 channels, you also have the option to use the channels for connections between those routers too.

With T1s, though, you cannot aggregate, at L2, more than a single T1's bandwidth, without doing something like MLPPP, or using some kind of MUX.

At L3, you can do packet by packet, round-robin, on multi links, but packet delivery sequence (for a single flow) is not guaranteed.  MLPPP does guarantee this. 

"What about MLPP split flow's packets?"

Yes (unlike Etherchannel which does not.)

"Will this work with 4 times bandwidth(binding 4 T1)?"

Yes.

"If one T1 is down, will it reduce to 75% bandwidth?"

Yes.

"How about QoS? Can it run on this MLPPP?"

I believe you can configure and use QoS on a multilink interface.

View solution in original post

14 Replies 14

Joseph W. Doherty
Hall of Fame
Hall of Fame

Possibly if your router, and other side's router, support MLPPP.

E.g. https://www.cisco.com/c/en/us/td/docs/routers/access/4400/feature/guide/isr4451mlpp.html

Both sides are 4321, but how to apply this? Will MLPPP make 4 s0/?/0 ports as 1 group? 

How to solve tunnel source problem?

As I know that, Tunnel only accept one source:

tunnel source Serial0/2/0:0

 

If MLPPP is supported, you should be able to define a multilink interface (in concept, much like an Etherchannel port-channel interface), which I believe your tunnel interface can use.

BTW, if you create a multilink interface, do you still have a need for a tunnel interface?  I ask because your posting appears to have tunnel destination on the other side of the serial link.  If you're thinking you need to have a tunnel to use all your physical links, concurrently, that's not the case with MLPPP.  (Also, BTW, unlike Etherchannel, MLPP will split each flow's packets across the links.)

Is there ports binding function to instead of MLPPP? Something like port-channel. I am a little confused about that T1 controller setting "group-channel", is that a kind of port-channel?

What about MLPP split flow's packets? Will this work with 4 times bandwidth(binding 4 T1)? If one T1 is down, will it reduce to 75% bandwidth? How about QoS? Can it run on this MLPPP?

Thank you for the answers. I just had so many unknown stuff. 

"Is there ports binding function to instead of MLPPP?"

Sometimes there is, but I believe it would require extra (often external) hardware.  (E.g. T1s using ATM and IMA).

"Something like port-channel."

MLPP is something like port-channel, but also a bit different.  Both, though, bind together multiple physical ports into one logical port.

"I am a little confused about that T1 controller setting "group-channel", is that a kind of port-channel?"

When using a T1 (or E1, too, I recall), you can divvy up its bandwidth into channels, or not.  The former allows you use one or more 64Kbps (adjacent) channels to form a subinterface.  So, using channels, is somewhat, too, like a port-channel and/or MLPPP.

If you did have subinterfaces, it might be possible to bind them into a MLPPP interface too.

I recall (?) with a single T1 channels you could do things like have four routers, each with a T1 connection.  HQ router takes its 64 channels and might use 32 of them to one of the other routers, and 16 channels to the two other routers.  Since those other three routers are not using all their 64 channels, you also have the option to use the channels for connections between those routers too.

With T1s, though, you cannot aggregate, at L2, more than a single T1's bandwidth, without doing something like MLPPP, or using some kind of MUX.

At L3, you can do packet by packet, round-robin, on multi links, but packet delivery sequence (for a single flow) is not guaranteed.  MLPPP does guarantee this. 

"What about MLPP split flow's packets?"

Yes (unlike Etherchannel which does not.)

"Will this work with 4 times bandwidth(binding 4 T1)?"

Yes.

"If one T1 is down, will it reduce to 75% bandwidth?"

Yes.

"How about QoS? Can it run on this MLPPP?"

I believe you can configure and use QoS on a multilink interface.

Thank you very much for the details explain.

I will have a try on my end and let you know the result.

I agree that MLPPP would seem to be the solution for your requirements. It would take 4 T1 links and aggregate them to be treated as a single entity. And if one of the T1s fails then MLPPP redistributes what would have gone over that link and you have 75% of the bandwidth.

It is a good question whether you need a tunnel to achieve your goals. A standard GRE tunnel such as the one in your post provides a point to point link. MLPPP also provides a point to point link. Is there some other aspect of the tunnel that you want - perhaps encryption of the traffic going through the tunnel? If the tunnel was just an attempt to aggregate multiple links then MLPPP is the better solution.

HTH

Rick

config loopback, use it as source of your tunnel 
config MLPPP OR config static route with each PPP which make router have multi path to destination
and hence you get what you need
multi link serve same tunnel source 

". . . OR config static route with each PPP which make router have multi path to destination"

NB: when doing multi-path (usually equal cost) routing to a destination, either routing will round robin flows (which precludes any one flow from having more than one link's bandwidth) or round-robin packets (which often creates out-of-sequence packet delivery issues).

Hi , I got back from test. Thank you very much for the answer. It's working on MLPPP, the only question is I have no idea how to put crypto on this link?

When we had tunnel we can just use "tunnel protection ipsec profile"  but this is changed to multilink now.

 

 

It might be as simple as setting up your crypto tunnel to use the MLPPP interface rather than a physical interface.

Something like?

tunnel source multilink 1

 

Yes.

Review Cisco Networking for a $25 gift card