cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
292
Views
0
Helpful
1
Replies

How to connect a router to the Internet

newnetman
Level 1
Level 1

Hello all,

Can someone please take the pain to lead me into the step by step of how to connect a router to the internet.

I currently have an ADSL internet connection.

My routers are primarily 2611XM loaded with 256MB/32Flash, also have 2 CAT 3550s with EMI.

i want to use this to practice a lot on BGP, NTP, NAT (will see if my ISP can help with a static add)and any other protocols as my studies demands.

Thanking you all in advance,

Regards

1 Reply 1

Rick Morris
Level 6
Level 6

First, if you are going to run BGP you will need to check with your provider first. Since you have an ADSL my guess it they will not peer with you.

However, if you want to run basic static route that can be done.

You need to make sure you have the correct card in your router to accept the ADSL connection.

Info you will need from your ISP

IP address. You will need to know the IP they are assigning, request static so you don't have to change anything. You could use DHCP but if they offer static I would use that.

Basic config:

To get you connected, not specific to your type of connection or interfaces, this is just to be used as a guide.

interface Ethernet 0

description Connected to Local LAN

ip address x.x.x.x 255.255.255.x <---IP the ISP provides, unless you are going to run NAT, then you would configure with private IP.

no shutdown

!

interface Serial 0

ip unnumbered ethernet 0

no shut

!

ip route 0.0.0.0 0.0.0.0 serial 0

another config option

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.0 <---whatever IP you assign in the private range

!

interface Serial0

description Connected to ISP

ip address x.x.x.x 255.255.255.252 <--IP provided by ISP

!

ip route 0.0.0.0 0.0.0.0 Serial0

This should help get you started.

For NAT:

In global config:

ip access-list extended nat_inside

permit ip x.x.x.x 0.0.0.255 any

(this is the IP subnet you apply to the ethernet interface)

!

ip nat inside source list nat_inside interface Serial0 overload

!

apply this to the serial interface

!

ip nat outside

!

This should help get started with a basic NAT config.

Review Cisco Networking for a $25 gift card