cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
700
Views
0
Helpful
9
Replies

How to dynamically change the default gateway with IOS 15

collinsjl
Level 1
Level 1

How in IOS 15.0 would I do the the following as we would with older IOS?

ip sla 10
 icmp-echo 172.16.200.1
 timeout 1500
 frequency 5

ip sla schedule 10 life forever start-time now

ip route 0.0.0.0 0.0.0.0 172.16.200.1 track 1
ip route 0.0.0.0 0.0.0.0 172.168.201.1 2
track 1 rtr 10 reachability


Will the default-network command work and what would that config look like?

What are my options here?  Or should I say what the best way to get the default route to roll over when the primary connection fails?

Details:


IOS
WS-C2960XR-48FPS-I 15.0(2a)EX5           C2960X-UNIVERSALK9-M     

Config:
router eigrp 200
 network 4.4.4.4 0.0.0.0
 network 172.16.200.0 0.0.0.255
 network 10.4.0.0 0.0.0.255
 network 192.168.0.0 0.0.7.255
 eigrp stub connected summary

router eigrp 201
 network 4.4.4.4 0.0.0.0
 network 172.16.201.0 0.0.0.255
 network 10.4.0.0 0.0.0.255
 network 192.168.0.0 0.0.7.255
 eigrp stub connected summary


interface GigabitEthernet1/0/1
 description ISP_VLAN_PRI
 no switchport
 ip address 172.16.200.4 255.255.255.0

interface GigabitEthernet1/0/2
 description ISP_VLAN_SEC
 switchport access vlan 201
 switchport mode access

interface Vlan201
 ip address 172.16.201.4 255.255.255.0


Connected EIGRP switch is the core 3850 stack
EIGRP 200 next hop is 172.16.200.1
EIGRP 201 next hop is 172.16.201.1

All traffic from router 4.4.4.4 is to go through router 1.1.1.1 to get to the Internet.


1 Accepted Solution

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Collinsjl,

default network is reported as not working anymore in recent IOS images according to latest CCIE Written book version 5  vol I written by Peter Paluch.

I have a question for you. Why two different EIGRP processes announcing the same networks?

One EIGRP process should be enough in your scenario.

The process with the lower AS number wins the competition in providing a prefix to the IP routing table.

The scenario would be far simpler with a single EIGRP AS domain.

Second note:

why eigrp stub is in use here. The C3850 stack cannot be an EIGRP stub it needs to pass routes to the other device.

Ok I see you are providing the configuration of the C2960 that is a leaf and it can be a stub. No problem about this.

You can have the C3850 to inject a default static route in EIGRP domain (a single domain) and the C2960 to use happily the two links to go the internet and leave to the C3850 the choice of the ISP to be used.

Hope to help

Giuseppe

View solution in original post

9 Replies 9

Peter Paluch
Cisco Employee
Cisco Employee

Hello,

If IP SLA is supported on your 15.0 IOS then the configuration as you have posted should be accepted with just one exception: Instead of track 1 rtr 10, you would use track 1 ip sla 10 - and that's about it.

That being said, you are running two EIGRP processes that obviously learn and advertise some networks. Would it not be possible for your upstream EIGRP routers to advertise the default routes to you? In this way, if the particular EIGRP neighbor died, the default route through it would go away spontaneously.

Best regards,
Peter

IP SLA # does not work

ex

BON_2960XR_1(config)#ip sla ?
  key-chain           Use MD5 Authentication for IP SLAs Control Messages
  responder          Enable IP SLAs Responder

Pushing the default route from the core switch would be the way to go but how? 

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Collinsjl,

default network is reported as not working anymore in recent IOS images according to latest CCIE Written book version 5  vol I written by Peter Paluch.

I have a question for you. Why two different EIGRP processes announcing the same networks?

One EIGRP process should be enough in your scenario.

The process with the lower AS number wins the competition in providing a prefix to the IP routing table.

The scenario would be far simpler with a single EIGRP AS domain.

Second note:

why eigrp stub is in use here. The C3850 stack cannot be an EIGRP stub it needs to pass routes to the other device.

Ok I see you are providing the configuration of the C2960 that is a leaf and it can be a stub. No problem about this.

You can have the C3850 to inject a default static route in EIGRP domain (a single domain) and the C2960 to use happily the two links to go the internet and leave to the C3850 the choice of the ISP to be used.

Hope to help

Giuseppe

Moved comments for clairity

Moved comments for clairity

I see you caught on to the fact that they have 2960XRs at the distant ends.

I used 2 EIGRP processes because of Spanning-tree.

The real overview is that there are 5 locations total and the 3850 is the only site that has Internet connectivity.  So all five sites need to talk to each other and the main site.  We have the 2 connections to each site for fail-over not for redundancy/load balancing.  The ISP has an MPLS mesh that they are using to connect all the sites and handing me an L2 connection and I have to use L3.  They do not want to see all of our MACs just the ones for the links.

So how would I configure the 3850 to send the default route to the 2960s?  It needs to send the next hop default route and not the default route it has to the Internet connected ISP.

The 3850  --- The 3850 is IP Base so EIGRP Stub only supported.

WS-C3850-48P 03.03.05SE cat3k_caa-universalk9

interface GigabitEthernet1/0/19
description ISP_VLAN_PRI
no switchport
ip address 172.16.200.1 255.255.255.0
end


interface GigabitEthernet2/0/19
description ISP_VLAN_SEC
no switchport
ip address 172.16.201.1 255.255.255.0
end

router eigrp 200
network 1.1.1.1 0.0.0.0
network 172.16.200.0 0.0.0.255
eigrp stub connected summary

router eigrp 201
network 1.1.1.1 0.0.0.0
network 172.16.201.0 0.0.0.255
eigrp stub connected summary

ip route 0.0.0.0 0.0.0.0 192.168.1.2 --Firewall

Update:

I have added the following command to the interfaces on the 3850

interface GigabitEthernet1/0/19
description ISP_VLAN_PRI
no switchport
ip address 172.16.200.1 255.255.255.0
ip summary-address eigrp 200 0.0.0.0 0.0.0.0

interface GigabitEthernet2/0/19
description ISP_VLAN_SEC
no switchport
ip address 172.16.201.1 255.255.255.0
ip summary-address eigrp 201 0.0.0.0 0.0.0.0

In the EIGRP topology I see

EIGRP-IPv4 Topology Table for AS(200)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 4.4.4.4/32, 1 successors, FD is 130816
via 172.16.200.4 (130816/128256), GigabitEthernet1/0/19
P 5.5.5.5/32, 1 successors, FD is 130816
via 172.16.200.5 (130816/128256), GigabitEthernet1/0/19
P 0.0.0.0/0, 1 successors, FD is 2816
via Summary (2816/0), Null0
P 2.2.2.2/32, 1 successors, FD is 130816
via 172.16.200.2 (130816/128256), GigabitEthernet1/0/19
P 172.16.200.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet1/0/19
P 3.3.3.3/32, 1 successors, FD is 130816
via 172.16.200.3 (130816/128256), GigabitEthernet1/0/19
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0

EIGRP-IPv4 Topology Table for AS(201)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 4.4.4.4/32, 0 successors, FD is Inaccessible
via 172.16.201.4 (130816/128256), GigabitEthernet2/0/19
P 0.0.0.0/0, 1 successors, FD is 2816
via Summary (2816/0), Null0
P 172.16.201.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet2/0/19
P 2.2.2.2/32, 0 successors, FD is Inaccessible
via 172.16.201.2 (130816/128256), GigabitEthernet2/0/19
P 3.3.3.3/32, 0 successors, FD is Inaccessible
via 172.16.201.3 (130816/128256), GigabitEthernet2/0/19
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0

On the distant end I see in the topology

EIGRP-IPv4 Topology Table for AS(200)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 4.4.4.4/32, 1 successors, FD is 128256
via Connected, Loopback0
P 0.0.0.0/0, 0 successors, FD is Inaccessible
via 172.16.200.1 (3072/2816), GigabitEthernet1/0/1
P 2.2.2.2/32, 1 successors, FD is 130816
via 172.16.200.2 (130816/128256), GigabitEthernet1/0/1
P 172.16.200.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet1/0/1
P 3.3.3.3/32, 1 successors, FD is 130816
via 172.16.200.3 (130816/128256), GigabitEthernet1/0/1

EIGRP-IPv4 Topology Table for AS(201)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 4.4.4.4/32, 1 successors, FD is 128256
via Connected, Loopback0
P 0.0.0.0/0, 0 successors, FD is Inaccessible
via 172.16.201.1 (3072/2816), GigabitEthernet1/0/2
P 172.16.201.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet1/0/2
P 3.3.3.3/32, 0 successors, FD is Inaccessible
via 172.16.201.3 (130816/128256), GigabitEthernet1/0/2

This is a production systems and running EIGRP 100 for that right now and I did not include that in the output.  That is where the static default route is right now so that's why you don't see the defaults routes I am trying to push as being used(Inaccessible).   I will be moving the production networks over after I ensure I can get the Default Gateway to propagate.

This to me looks like it will work but I am concerned about the NULL value in the 3850.   

Does anyone see a reason why this will not work?

Hello Collinsjl,

>> The 3850  --- The 3850 is IP Base so EIGRP Stub only supported.

No,this is the root cause of your issue the C3850 should be able to run a complete version of EIGRP so that it can inject a default route in the EIGRP domain(s).

This is the reason why the FD of injected default routes is inaccessible as seen from the C2960.

On the other hand the C2960 as you showed does not support full IP SLA.

At this point, you should go to your manager and make him to accept to buy the upgrade license for the C3850, because the central device in an EIGRP domain(s) cannot be a stub.

Explain him this way : EIGRP stub makes impossible for the central device to advertise prefixes to the other devices.

EIGRP stub feature is good for leaf devices that have no other device downstream of them.

You are in a dead lock now. The error has been done in provisioning the network the central EIGRP switch C3850 needs a different license.

Hope to help

Giuseppe

Thanks for the response.

  Bottom line is I don't have upgrading the license as part of the solution for these people.  So I must make it work with what I have.  Which is not a real bad start off point.  5 routers/switches in essentially a full mesh with one having access to the Internet I do have any down stream devices that needs to be propagated to the mesh that every router/switch cannot see directly via a neighbor.  The only issue is the dynamic default route that the units will need when eigrp 200 primary is lost and eigrp 201 secondary comes up.  I think with the solution I provided above it will work.   

  So I rehashed it.  If I have 2 equal cost links coming into each location then why not use them all the time.  I configured a L3 port channel at all sites assigned an IP address to each port channel for EIGRP 200.  With one EIGRP instance I can just static the default route at each site that has to go to the 3850 to get to any unknown routes.  I was thinking that a port channel would not work because they are normally point to point and these are point to multi-point.  So just use channel-goup mode on.  Looks like it is going to work.  I guess it will load balance across the links.

So the new config -- do you see any issues here?  Are there any caveats I should be looking for when using the port channels the way I am?

The 3850 config:


interface Port-channel20
no switchport
ip address 172.16.200.1 255.255.255.0

interface GigabitEthernet1/0/19
description ISP_VLAN_PRI
no switchport
no ip address
channel-group 20 mode on

interface GigabitEthernet2/0/19
description ISP_VLAN_SEC
no switchport
no ip address
channel-group 20 mode on

router eigrp 200
network 1.1.1.1 0.0.0.0
network 10.1.0.0 0.0.0.255
network 172.16.200.0 0.0.0.255
network 192.168.0.0 0.0.7.255
eigrp stub connected summary

ip route 0.0.0.0 0.0.0.0 192.168.1.2 (Firewall to Internet)

**** This environemnt is production so EIGRP 100 is up but
will be replaced by EIGRP 200 and the statics below will
be deleted and ten used from EIGRP 200*****

EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.58)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.4.0.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.5.0.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.1.0.0/24, 1 successors, FD is 2816
via Connected, Vlan10
P 192.168.0.0/21, 1 successors, FD is 2816
via Connected, Vlan1
P 10.4.96.0/24, 1 successors, FD is 3072
via 10.1.0.2 (3072/2816), Vlan10
P 192.168.30.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 192.168.40.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.2.0.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 0.0.0.0/0, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.254.254.0/25, 1 successors, FD is 2816
via Connected, Vlan254
P 192.168.50.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.3.0.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)
P 10.100.1.0/24, 1 successors, FD is 3072
via 10.1.0.2 (3072/2816), Vlan10
P 192.168.20.0/24, 1 successors, FD is 2816
via Rstatic (2816/0)

EIGRP-IPv4 Topology Table for AS(200)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.4.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.4 (3072/2816), Port-channel20
P 10.5.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.5 (3072/2816), Port-channel20
P 4.4.4.4/32, 1 successors, FD is 129536
via 172.16.200.4 (129536/128256), Port-channel20
P 10.1.0.0/24, 1 successors, FD is 2816
via Connected, Vlan10
P 192.168.0.0/21, 1 successors, FD is 2816
via Connected, Vlan1
P 192.168.30.0/24, 0 successors, FD is Inaccessible
via 172.16.200.3 (3072/2816), Port-channel20
P 5.5.5.5/32, 1 successors, FD is 129536
via 172.16.200.5 (129536/128256), Port-channel20
P 192.168.40.0/24, 0 successors, FD is Inaccessible
via 172.16.200.4 (3072/2816), Port-channel20
P 10.2.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.2 (3072/2816), Port-channel20
P 0.0.0.0/0, 1 successors, FD is 2816
via Summary (2816/0), Null0
P 2.2.2.2/32, 1 successors, FD is 129536
via 172.16.200.2 (129536/128256), Port-channel20
P 192.168.50.0/24, 0 successors, FD is Inaccessible
via 172.16.200.5 (3072/2816), Port-channel20
P 10.3.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.3 (3072/2816), Port-channel20
P 172.16.200.0/24, 1 successors, FD is 1536
via Connected, Port-channel20
P 3.3.3.3/32, 1 successors, FD is 129536
via 172.16.200.3 (129536/128256), Port-channel20
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.20.0/24, 0 successors, FD is Inaccessible
via 172.16.200.2 (3072/2816), Port-channel20

sh ip route:

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.1.2
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/129536] via 172.16.200.2, 00:25:07, Port-channel20
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/129536] via 172.16.200.3, 00:25:07, Port-channel20
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/129536] via 172.16.200.4, 00:24:05, Port-channel20
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/129536] via 172.16.200.5, 00:25:07, Port-channel20
10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
C 10.1.0.0/24 is directly connected, Vlan10
L 10.1.0.1/32 is directly connected, Vlan10
S 10.2.0.0/24 [1/0] via 10.254.254.2
S 10.3.0.0/24 [1/0] via 10.254.254.3
S 10.4.0.0/24 [1/0] via 10.254.254.4
D 10.4.96.0/24 [90/3072] via 10.1.0.2, 01:55:54, Vlan10
S 10.5.0.0/24 [1/0] via 10.254.254.5
D 10.100.1.0/24 [90/3072] via 10.1.0.2, 01:55:54, Vlan10
C 10.254.254.0/25 is directly connected, Vlan254
L 10.254.254.1/32 is directly connected, Vlan254

172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C 172.16.0.0/30 is directly connected, Vlan254
L 172.16.0.1/32 is directly connected, Vlan254
C 172.16.200.0/24 is directly connected, Port-channel20
L 172.16.200.1/32 is directly connected, Port-channel20
C 192.168.0.0/21 is directly connected, Vlan1
192.168.1.0/32 is subnetted, 1 subnets
L 192.168.1.1 is directly connected, Vlan1
S 192.168.20.0/24 [1/0] via 10.254.254.2
S 192.168.30.0/24 [1/0] via 10.254.254.3
S 192.168.40.0/24 [1/0] via 10.254.254.4
S 192.168.50.0/24 [1/0] via 10.254.254.5

In one of the 2960XRs (Other 3 site are similar)


interface Port-channel20
no switchport
ip address 172.16.200.3 255.255.255.0

interface GigabitEthernet1/0/1
no switchport
no ip address
channel-group 20 mode on

interface GigabitEthernet1/0/2
no switchport
no ip address
channel-group 20 mode on

router eigrp 200
network 3.3.3.3 0.0.0.0
network 10.3.0.0 0.0.0.255
network 172.16.200.0 0.0.0.255
network 192.168.30.0
eigrp stub connected summary

I will add the default route to the 3850 at cutover

ip route 0.0.0.0 0.0.0.0 172.16.200.1

****Like I said EIGRP 100 is going away and being replaced by 200****

EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.30.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.4.0.0/24, 1 successors, FD is 3072
via 10.254.254.4 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254
P 10.5.0.0/24, 1 successors, FD is 3072
via 10.254.254.5 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254
P 10.1.0.0/24, 1 successors, FD is 3072
via 10.254.254.1 (3072/2816), Vlan254
P 192.168.0.0/21, 1 successors, FD is 3072
via 10.254.254.1 (3072/2816), Vlan254
P 192.168.30.0/24, 1 successors, FD is 2816
via Connected, Vlan1
P 192.168.40.0/24, 1 successors, FD is 3072
via 10.254.254.4 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254
P 10.2.0.0/24, 1 successors, FD is 3072
via 10.254.254.2 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254
P 0.0.0.0/0, 0 successors, FD is Inaccessible
via 10.254.254.1 (3072/2816), Vlan254
P 10.254.254.0/25, 1 successors, FD is 2816
via Connected, Vlan254
P 192.168.50.0/24, 1 successors, FD is 3072
via 10.254.254.5 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254
P 10.3.0.0/24, 1 successors, FD is 2816
via Connected, Vlan10
P 192.168.20.0/24, 1 successors, FD is 3072
via 10.254.254.2 (3072/2816), Vlan254
via 10.254.254.1 (3072/2816), Vlan254

EIGRP-IPv4 Topology Table for AS(200)/ID(3.3.3.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.4.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.4 (3072/2816), Port-channel20
P 4.4.4.4/32, 1 successors, FD is 129536
via 172.16.200.4 (129536/128256), Port-channel20
P 10.1.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.1 (3072/2816), Port-channel20
P 192.168.0.0/21, 0 successors, FD is Inaccessible
via 172.16.200.1 (3072/2816), Port-channel20
P 192.168.30.0/24, 1 successors, FD is 2816
via Connected, Vlan1
P 192.168.40.0/24, 0 successors, FD is Inaccessible
via 172.16.200.4 (3072/2816), Port-channel20
P 10.2.0.0/24, 0 successors, FD is Inaccessible
via 172.16.200.2 (3072/2816), Port-channel20
P 2.2.2.2/32, 1 successors, FD is 129536
via 172.16.200.2 (129536/128256), Port-channel20
P 10.3.0.0/24, 1 successors, FD is 2816
via Connected, Vlan10
P 172.16.200.0/24, 1 successors, FD is 1536
via Connected, Port-channel20
P 3.3.3.3/32, 1 successors, FD is 128256
via Connected, Loopback0
P 1.1.1.1/32, 1 successors, FD is 129536
via 172.16.200.1 (129536/128256), Port-channel20
P 192.168.20.0/24, 0 successors, FD is Inaccessible
via 172.16.200.2 (3072/2816), Port-channel20

sh ip route:

Gateway of last resort is 10.254.254.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 10.254.254.1
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/129536] via 172.16.200.1, 00:33:04, Port-channel20
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/129536] via 172.16.200.2, 01:48:24, Port-channel20
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/129536] via 172.16.200.4, 01:42:14, Port-channel20
10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
D 10.1.0.0/24 [90/3072] via 10.254.254.1, 01:49:32, Vlan254
D 10.2.0.0/24 [90/3072] via 10.254.254.2, 01:49:32, Vlan254
C 10.3.0.0/24 is directly connected, Vlan10
L 10.3.0.1/32 is directly connected, Vlan10
D 10.4.0.0/24 [90/3072] via 10.254.254.4, 01:49:32, Vlan254
D 10.5.0.0/24 [90/3072] via 10.254.254.5, 01:49:32, Vlan254
C 10.254.254.0/25 is directly connected, Vlan254
L 10.254.254.3/32 is directly connected, Vlan254
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Port-channel20
L 172.16.200.3/32 is directly connected, Port-channel20
D 192.168.0.0/21 [90/3072] via 10.254.254.1, 01:49:32, Vlan254
D 192.168.20.0/24 [90/3072] via 10.254.254.2, 01:49:32, Vlan254
192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.30.0/24 is directly connected, Vlan1
L 192.168.30.1/32 is directly connected, Vlan1
D 192.168.40.0/24 [90/3072] via 10.254.254.4, 01:49:32, Vlan254
D 192.168.50.0/24 [90/3072] via 10.254.254.5, 01:49:32, Vlan254

Well... that did not work.  Something is timing out and I cant ping the loopback addresses anymore.

How would I have just one instance of EIGRP?  Guess I can fall back to interface vlans and have both ports on the same VLAN.  Then I am at L3 riding on L2 with multi links.  Have no idea what will happen across the ISP MPLS VPN and what mac tables will look like or if spanning tree will be an issue.  I dont think they pass spanning tree data but with both  links on the same vlan and no port channel sounds like a massive loop topology.

Any help would be appreciated. Cutting them over Monday night. 

Update:

Just ended up going back to assigning 2 interfaces with different sub-nets on them and using a single eigrp instance.

Tested and all was well after I killed the messages about the mismatch sub-net.  OMG it would not stop and thats why I thought that would not work earlier.

no eigrp log-neighbor-warnings

Tested all and it seems to be working fine.  With one instance I can statically assign the default route and still use the configuration I am in with EIGRP Stub only all over the place.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card