cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
415
Views
15
Helpful
8
Replies
KhimeraZ
Beginner

How to make two Vlans communicate each other

Screenshot 2022-05-24 154517.jpg

Im new to Vlans and static routing. I got assignment that have scenario like this :

There's two building 1 is "Teknologi Maklumat" and 2 is "Matematik" 

and each building have 3 vlan. I know how to make vlan for each subgroups. But i dont know how to make these subgroup can communicate each other. 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Flavio Miranda
Advisor

Hi

  Find attached a working file.  I fix the problem and you can test from PC1 in Sistem rangkaian to PC2 in Analisis

Step you are missing.

 

AS you have only two routers, you can use static route between them:

In Router0:

ip route 0.0.0.0 0.0.0.0 50.0.0.2

In Router1:

ip route 0.0.0.0 0.0.0.0 50.0.0.1

 

This way, anything that is not directly connected to the router, they send to next router.

 

For PC you also make a mistake. On "Teknologi Maklumat" side, you add the IP address 40.0.0.1 on Router0 interface, but you configured IP 10.0.0.0/8 on PCs.

 PCs must have the same network as Router internal interfaces.

 

Lastly, PC must have a gateway if they need to communicate with a different network. This way, all PC on Teknologi Maklumat must have Gateway as 40.0.0.1

View solution in original post

8 REPLIES 8
Georg Pauwen
VIP Master

Hello,

 

right now, in your current configuration, all devices in each building are in the same Vlan. Each separate Vlan requires an individual subnet. The Vlans then need to be routed on the routers, using what is called a router-on-a-stick topology.

 

Can you post the full instructions you are following ? The instructions should include information on which IP addressing scheme and which Vlans are supposed to be used...

Unfortunately there's no instruction or IP addressing scheme. All I got just a table with Building name and subgroups name in it. 

Hello,

 

which version of Packet Tracer are you using ?

version 8.1.1 i think..

 

Hello,

 

since you are learning this stuff, I added a few things to your network. Try and understand what it is all for.

 

- added Vlan subinterfaces to both routers

- configured trunk ports for the links between the switches, and the links between the switches and the routers

- added DHCP pools to the routers for each Vlan

- added a management Vlan for the switches

- configured the switches for VTP in order to synchronize the Vlan databases

- configured the access ports with the 'spanning-tree portfast' command in order for DHCP to work

- added EIGRP as a routing protocol

Flavio Miranda
Advisor

Hi

  Find attached a working file.  I fix the problem and you can test from PC1 in Sistem rangkaian to PC2 in Analisis

Step you are missing.

 

AS you have only two routers, you can use static route between them:

In Router0:

ip route 0.0.0.0 0.0.0.0 50.0.0.2

In Router1:

ip route 0.0.0.0 0.0.0.0 50.0.0.1

 

This way, anything that is not directly connected to the router, they send to next router.

 

For PC you also make a mistake. On "Teknologi Maklumat" side, you add the IP address 40.0.0.1 on Router0 interface, but you configured IP 10.0.0.0/8 on PCs.

 PCs must have the same network as Router internal interfaces.

 

Lastly, PC must have a gateway if they need to communicate with a different network. This way, all PC on Teknologi Maklumat must have Gateway as 40.0.0.1

right now im using L3 switch to make vlan communicating each other, but now i want to make my pc 1 to communicate to pc 6 which is pc 6 at the other building. www.jpg

On this case, you did very well on the Router´s subinterfaces. But, you can´t put IP address on the physical interface.

 

Example on Router 0

!

interface FastEthernet0/1  > No IP address here

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 10

ip address 10.0.0.1 255.0.0.0

!

interface FastEthernet0/1.2

encapsulation dot1Q 20

ip address 20.0.0.3 255.0.0.0

!

interface FastEthernet0/1.3

encapsulation dot1Q 30

ip address 30.0.0.5 255.0.0.0

!

 

You need to add static routing, just like the previous exercise:

Router 0

ip route 0.0.0.0 0.0.0.0 80.0.0.2

Router1

ip route 0.0.0.0 0.0.0.0 80.0.0.1

 

Another mistake is that you did not configure the Interface between Switch L3 and Router as a Trunk. It must be trunk.

And you can not use the same IP address on Router Subinterfaces and Switch L3 Interface vlans. They must be different.

You can not repeat the IP address on your network, ever!!

 

You can test my file pinguing PC  10.0.0.200 (left) to  60.0.0.70 (right).

PS:  The PC´s gateway is the Router´s Subinterfaces.

 

Any doubt, let me know.