06-01-2005 11:02 AM - edited 03-03-2019 09:43 AM
how do I open a port for remote desktop connection and forward my e0 (outside ip) which is DHCP (not static) to my computer ip which is 192.168.1.101. I did something before with forwarding and the computer i forward to, there ended up being an ip conflict. Need to get my RDC working.
Thanks in advance!
06-02-2005 04:15 AM
Assuming that you use nat/pat and a dialer interface. If you do not have a dialer int replace the dialer0 with your outside interface:
ip nat inside source static tcp 192.168.1.101 3389 interface Dialer0 3389
06-02-2005 09:21 AM
No do i not believe I have a dialer interface. This is my current setup.
Router#show run
Building configuration...
Current configuration : 560 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
enable password
!
ip subnet-zero
!
!
!
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
half-duplex
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed auto
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
!
end
So how would I forward my outside dhcp cable to an inside ip with port 3389. I can't set it as static because the e0(dhcp outside ip) is always changing.
06-03-2005 02:08 AM
Couple the overload action to the physical interface and it will work fine.
So it will be
ip nat inside source static tcp
To be able to indentify your host you can couple your dynamic ip to an hostname, you can find more info about this on http://www.dyndns.org .
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide