cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

404
Views
10
Helpful
11
Replies
Highlighted
Beginner

HSRP Standby Router dropping traffic

Hi,

Can anyone help with issue below?

 

I have two sites:

Site A has an L3 Switch that is running BGP and OSPF. It has two routers: R1 is running BGP and R2 is running OSPF. Both routers are using HSRP, R1 being the active router.

Site B has an L2 switch, using router on a stick. It has also two routers: R1 is running BGP and R2 is running OSPF. Both routers are using HSRP, R1 being the active router.

WAN Routers are in between of the two sites

Sample scenario:

Site A R1 goes down, Site A R2 will become active router. Whenever traffic goes to the other site, Site B R2 is dropping the traffic.

Attached is a picture for the sample scenario

 

How can I fix the issue? Is Site B R2 dropping the traffic because it is the standby router? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star

Re: HSRP Standby Router dropping traffic

Thank you for providing all the requested information!

To simply answer your question, the issue is with your tracking conditions.

When you shutdown one of the interfaces on A_R1, its priority will fall down and A_R2 will take over as the Active router. However, B_R1 is still the Active router on SiteB, and there will be no complete path between the two sites.

One of the solutions is to modify your tracking condition. Instead of simply tracking only interfaces on the router, add additional conditions like a route to the other Site.

 

Here is an example of tracking for B_R1:-

 

track 1 list boolean or
object 2
object 3
track 2 interface Fa1/0 line-protocol
track 3 ip route 192.168.2.0 255.255.255.0 reachability

 

interface Fa2/0.4

 ...

 standby 1 track 1

 

 

HTH,

Meheretab

HTH,
Meheretab

View solution in original post

11 REPLIES 11
Highlighted
Rising star

Re: HSRP Standby Router dropping traffic

Please share your configuration (or part of your configuration related with BGP, OSPF, HSRP, tracking condition).

HTH,
Meheretab
HTH,
Meheretab
Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

Apologies for the mistake. The R1 of Site A & B runs OSPF while R2 of Site A & B runs BGP

Please see attached files for the device configuration, diagram and traceroute

Thank you

Highlighted
Rising star

Re: HSRP Standby Router dropping traffic

Thank you for sharing the config and scenarios. Please share the interface configuration for A_L3SW as well.

 

HTH,

Meheretab

HTH,
Meheretab
Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

Please see Interface Configuration of A_L3SW

!
interface FastEthernet1/0
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/13
switchport access vlan 3
duplex full
speed 100
!
interface FastEthernet1/14
switchport access vlan 3
duplex full
speed 100
!
interface Vlan2
ip address 10.10.10.254 255.255.255.0
!
interface Vlan3
ip address 192.168.2.254 255.255.255.0
!

Highlighted
Rising star

Re: HSRP Standby Router dropping traffic

Thank you for providing all the requested information!

To simply answer your question, the issue is with your tracking conditions.

When you shutdown one of the interfaces on A_R1, its priority will fall down and A_R2 will take over as the Active router. However, B_R1 is still the Active router on SiteB, and there will be no complete path between the two sites.

One of the solutions is to modify your tracking condition. Instead of simply tracking only interfaces on the router, add additional conditions like a route to the other Site.

 

Here is an example of tracking for B_R1:-

 

track 1 list boolean or
object 2
object 3
track 2 interface Fa1/0 line-protocol
track 3 ip route 192.168.2.0 255.255.255.0 reachability

 

interface Fa2/0.4

 ...

 standby 1 track 1

 

 

HTH,

Meheretab

HTH,
Meheretab

View solution in original post

Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

Just made some changes to your sample configuration for B_R1. See below:

 

track 1 list boolean and
 object 2
 object 3
track 2 interface Fa1/0 line-protocol
track 3 ip route 10.10.10.0 255.255.255.0 reachability

 

I used 10.10.10.0 cause if I used 192.168.2.0 then B_R1 will still able to reach A_R1 ip 192.168.2.201

 

Thank you for your solution and it fixed the issue. It was very helpful

Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

If you have GNs3 file please upload it here, we can have a look at it. 

 

Check the the Site B router's routing table if it has the route to reach the destination device at Site B. Try to ping from SiteB standby router to the destination device marking source as Site B's core facing interface. 

Please do not hesitate to click the STAR button if you are satisfied with my answer.
Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

Yes, when B_R2 is still the standby router it still has route to the destination device. It can also reach the destination device using its core facing interface as the source.

B_R2 just doesn't forward the traffic, is that a characteristic of a HSRP standby router?

Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

You are right, it will forward the traffic without any additional configuration

Please do not hesitate to click the STAR button if you are satisfied with my answer.
Highlighted
Beginner

Re: HSRP Standby Router dropping traffic

Hi,

 

There is no need of any configuration for it to work i performed a lab check the below link for the video

 

Please do not hesitate to click the STAR button if you are satisfied with my answer.
Highlighted
VIP Mentor

Re: HSRP Standby Router dropping traffic

Hello
Your topology shows the rtrs are directly connected however in the OP there is a main wan rtr in between the two site routers which i am assuming doesn’t have any first hop redundancy running



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future