cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1301
Views
0
Helpful
19
Replies

i need to access all routers from my local desktop

R Manjunatha
Level 3
Level 3

Hi,

I am running BGP, OSPF, and EIGRP routing protocol in EVE-NG and I need to access all my routers from my local desktop

what could be the route configuration? I can be able to ping from my desktop R120 and further I can't any other routes.

I have attached my topology. 

R120

interface Loopback1
ip address 172.120.10.1 255.255.255.0
!
interface Loopback2
ip address 172.120.20.1 255.255.255.0
!
interface Loopback3
ip address 172.120.30.1 255.255.255.0
!
interface Loopback4
ip address 172.120.40.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.120.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address dhcp
duplex auto
!
interface Ethernet0/2
no ip address
shutdown
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
!
router eigrp 100
network 10.10.120.0 0.0.0.255
network 172.120.10.0 0.0.0.255
network 172.120.20.0 0.0.0.255
network 172.120.30.0 0.0.0.255
network 172.120.40.0 0.0.0.255
network 192.168.1.0
network 192.168.50.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.50.1
ip ssh version 2

 

R85

interface Loopback1
ip address 192.85.10.1 255.255.255.0
!
interface Loopback2
ip address 192.85.20.1 255.255.255.0
!
interface Loopback3
ip address 192.85.30.1 255.255.255.0
!
interface Loopback4
ip address 192.85.40.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.85.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address 10.10.86.1 255.255.255.0
duplex auto
!
interface Ethernet0/2
ip address 10.10.10.1 255.255.255.0
duplex auto
!
interface Ethernet0/3
ip address 172.16.85.1 255.255.255.0
duplex auto
!
interface Ethernet1/0
ip address 10.10.120.1 255.255.255.0
duplex auto
!
interface Ethernet1/1
no ip address
shutdown
duplex auto
!
interface Ethernet1/2
no ip address
shutdown
duplex auto
!
interface Ethernet1/3
no ip address
shutdown
duplex auto
!
!
router eigrp 100
network 10.10.10.0 0.0.0.255
network 10.10.85.0 0.0.0.255
network 10.10.86.0 0.0.0.255
network 10.10.120.0 0.0.0.255
network 172.16.85.0 0.0.0.255
network 192.85.10.0
network 192.85.20.0
network 192.85.30.0
network 192.85.40.0

my desktop ipconfig

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2406:7400:63:a4e5:5c1c:aa1c:f59d:86e
Temporary IPv6 Address. . . . . . : 2406:7400:63:a4e5:30c6:4b8:c787:2872
Link-local IPv6 Address . . . . . : fe80::5c1c:aa1c:f59d:86e%20
IPv4 Address. . . . . . . . . . . : 192.168.0.108
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::61ca:999c:d76a:a891%3
IPv4 Address. . . . . . . . . . . : 192.168.70.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::b94e:4fbf:d4:36eb%13
IPv4 Address. . . . . . . . . . . : 192.168.50.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Bluetooth Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

C:\Windows\system32>route add 10.10.120.0 mask 255.255.255.0 192.168.50.192

19 Replies 19

I am not finding any route from R60 and R63 and also, it's not pining.

clarification - show IP route 8.8.8.8 - This is the DNS server IP and how is this route will install in the routers R60 and R63?

R60#show ip route 8.8.8.8
% Network not in table
R60#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

R63#show ip route 8.8.8.8
% Network not in table
R63#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.

R120#show ip nat tr
R120#show ip nat tr
R120#

Hi @R Manjunatha ,

clarification - show IP route 8.8.8.8 - This is the DNS server IP and how is this route will install in the routers R60 and R63?

If you want to ping the DNS from R60 and R63, they need to have a route to it. The route to 8.8.8.8 will be via the default route propagated via eigrp and then redistributed into bgp on R61.

Can you check that the default route propagated to R61? I suspect that the default route does not propagate to AS65002 because you are missing the following command under "router bgp 65002" on R61.

router bgp 65002

default-information originate

This will allow the default route redistribution from eigrp to bgp. You should then see the default route propagate to R60 and R63.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi,

Thank you for the clarification.

 

I configured the "default-information originate" and I am able to ping DNS from R63 and similarly I can't ping from R60 BGP routers AS65002. I can reach from R61 

R61

R61#sh run | se bgp
redistribute bgp 65002 metric 10000 10 255 255 1500
router bgp 65002
bgp log-neighbor-changes
bgp redistribute-internal
network 61.61.61.0 mask 255.255.255.0
network 172.16.85.0 mask 255.255.255.0
network 192.61.10.0
network 192.61.20.0
network 192.61.30.0
network 192.61.40.0
redistribute eigrp 100
neighbor 48.48.48.48 remote-as 65002
neighbor 48.48.48.48 update-source Loopback0
neighbor 48.48.48.48 next-hop-self
neighbor 52.52.52.52 remote-as 65002
neighbor 52.52.52.52 update-source Loopback0
neighbor 52.52.52.52 next-hop-self
neighbor 60.60.60.60 remote-as 65002
neighbor 60.60.60.60 update-source Loopback0
neighbor 60.60.60.60 next-hop-self
default-information originate
R61#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/9 ms

R63

R63#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 279/279/281 ms

Hi @R Manjunatha ,

I am glad to see that it works for some routers. The fact that it doesn't work from R60 is probably due to the fact that the only prefixes you advertise from R60 are in the 192.160/16 range. You need to add this range to the access-list you use for the NAT on R120.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi

I have given a 192. /8 range to access-list in R120

R120(config)#access-list 1 permit 192.0.0.0 0.255.255.255
R120(config)#do sh ip nat tra
Pro Inside global Inside local Outside local Outside global
icmp 192.168.50.192:7 10.10.48.2:7 8.8.8.8:7 8.8.8.8:7
udp 192.168.50.192:123 10.10.48.2:123 34.208.249.133:123 34.208.249.133:123

R60(config-router)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....

 

R120(config)#do sh ip route | se 192.60.10.0
D EX 192.60.10.0/24 [170/309760] via 10.10.120.1, 01:09:51, Ethernet0/0

Router R60 Configuration

interface Loopback0
ip address 60.60.60.60 255.255.255.0
!
interface Loopback1
ip address 192.60.10.1 255.255.255.0
!
interface Loopback2
ip address 192.60.20.2 255.255.255.0
!
interface Loopback3
ip address 192.60.30.3 255.255.255.0
!
interface Loopback4
ip address 192.60.40.4 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.48.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address 10.10.60.1 255.255.255.0
duplex auto
!
interface Ethernet0/2
ip address dhcp
shutdown
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
interface Ethernet1/0
no ip address
shutdown
duplex auto
!
interface Ethernet1/1
no ip address
shutdown
duplex auto
!
interface Ethernet1/2
no ip address
shutdown
duplex auto
!
interface Ethernet1/3
no ip address
shutdown
duplex auto
!
router ospf 1
router-id 60.60.0.60
network 10.10.48.0 0.0.0.255 area 0
network 10.10.60.0 0.0.0.255 area 0
network 60.60.60.0 0.0.0.255 area 0
!
router bgp 65002
bgp log-neighbor-changes
network 60.60.60.0 mask 255.255.255.0
network 192.60.10.0
network 192.60.20.0
network 192.60.30.0
network 192.60.40.0
neighbor 48.48.48.48 remote-as 65002
neighbor 48.48.48.48 update-source Loopback0
neighbor 52.52.52.52 remote-as 65002
neighbor 52.52.52.52 update-source Loopback0
neighbor 61.61.61.61 remote-as 65002
neighbor 61.61.61.61 update-source Loopback0
!

Review Cisco Networking for a $25 gift card