cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1460
Views
0
Helpful
13
Replies

IBGP routing issue

aprasad11
Level 1
Level 1

Hi Guys,

I have a issue with IBGP routing.  

The IBGP neighbors are up but i am not able to ping prefix advertised between R9 ad R10.

I am able to ping peering neighbors but not routes that are advertised through BGP

I may have missed out something? below is IBGP config, show output and ping.  

--------------------------------------------------------------------------------------------------------------

R10#show run | s router bgp
router bgp 34567
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
network 10.10.10.11 mask 255.255.255.255
neighbor 9.9.9.9 activate
exit-address-family

R10#show ip bgp
BGP table version is 3, local router ID is 123.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*>i 9.9.9.1/32 9.9.9.9 0 100 0 i
*> 10.10.10.11/32 0.0.0.0 0 32768 i

---------------------------------------------------------------------------------------------------------------

R9#show run | s router bgp
router bgp 34567
bgp log-neighbor-changes
network 9.9.9.1 mask 255.255.255.255
neighbor 10.10.10.10 remote-as 34567
neighbor 10.10.10.10 update-source Loopback200

R9#show ip bg
BGP table version is 7, local router ID is 123.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 9.9.9.1/32 0.0.0.0 0 32768 i
*>i 10.10.10.11/32 10.10.10.10 0 100 0 i

----------------------------------------------------------------------------------------------------------------

Ping result from R10

R10#ping 9.9.9.1 source 10.10.10.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.11
.....
Success rate is 0 percent (0/5)
R10#

2 Accepted Solutions

Accepted Solutions

You are not advertising 9.9.9.1 or 10.10.10.11 into EIGRP so when the ping gets to the intermediate switches they have no route to those IPs.

Jon

View solution in original post

Hi

Have simulated your configuration (just changing the ip addressing on the switches)

ROUTER 9

interface Loopback1
ip address 9.9.9.1 255.255.255.255
!
interface Loopback200
ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
ip address 10.95.0.9 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 9.9.9.9 0.0.0.0
network 10.95.0.9 0.0.0.0
no auto-summary
!
router bgp 34567
no synchronization
bgp log-neighbor-changes
network 9.9.9.1 mask 255.255.255.255
neighbor 10.10.10.10 remote-as 34567
neighbor 10.10.10.10 update-source Loopback200
no auto-summary

SWITCH 1

nothing special

Vlan 10

ip routing

interface FastEthernet0/1
switchport access vlan 10
switchport mode access

!
interface FastEthernet0/3
no switchport
ip address 1.1.1.1 255.255.255.0
duplex auto
!
interface Vlan10
ip address 10.95.0.5 255.255.255.0
!
!
router eigrp 1
network 0.0.0.0
!

!

SWITCH 2

nothing special

vlan 20

ip routing

interface FastEthernet0/1
switchport access vlan 20
switchport mode access

!
interface FastEthernet0/3
no switchport
ip address 1.1.1.2 255.255.255.0
duplex auto
!
interface Vlan20
ip address 10.106.0.6 255.255.255.0
!
!
router eigrp 1
network 0.0.0.0

ROUTER 10

interface Loopback1
ip address 10.10.10.11 255.255.255.255
!
interface Loopback200
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
ip address 10.106.0.10 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 10.10.10.10 0.0.0.0
network 10.106.0.10 0.0.0.0
no auto-summary
!
router bgp 34567
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
neighbor 9.9.9.9 activate
no auto-summary
no synchronization
network 10.10.10.11 mask 255.255.255.255
exit-address-family

##########################################

##########################################

Now please note the routing tables

R9#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.95.0.5, 00:13:34, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
C 9.9.9.9 is directly connected, Loopback200
C 9.9.9.1 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.10.10.10/32 [90/435456] via 10.95.0.5, 00:13:28, FastEthernet0/0
B 10.10.10.11/32 [200/0] via 10.10.10.10, 00:12:37
C 10.95.0.0/24 is directly connected, FastEthernet0/0
D 10.106.0.0/24 [90/307456] via 10.95.0.5, 00:13:35, FastEthernet0/0
R9#
R9#
R9#
R9#sh ip bgp
BGP table version is 3, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 9.9.9.1/32 0.0.0.0 0 32768 i
*>i10.10.10.11/32 10.10.10.10 0 100 0 i
R9#

R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:14:23, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:14:23, FastEthernet0/0
B 9.9.9.1 [200/0] via 9.9.9.9, 00:13:32
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:14:23, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#
R10#
R10#sh ip bg
R10#sh ip bgp
BGP table version is 3, local router ID is 10.10.10.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i9.9.9.1/32 9.9.9.9 0 100 0 i
*> 10.10.10.11/32 0.0.0.0 0 32768 i
R10#

Now if you advertise the prefixes into EIGRP As John mentioned previously, it will be known via EIGRP and ping will be enabled:

R10#sh ip bgp
BGP table version is 4, local router ID is 10.10.10.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
r>i9.9.9.1/32 9.9.9.9 0 100 0 i      <---(r) indicates there is best path through IGP in this case EIGRP
*> 10.10.10.11/32 0.0.0.0 0 32768 i
R10#
R10#
R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:31:14, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:31:14, FastEthernet0/0
D 9.9.9.1 [90/435456] via 10.106.0.6, 00:01:06, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:31:16, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#

Now if you want them known via BGP you should change the distance value lowest than 90 on both routers

Example:

ROUTER 10

router bgp 34567
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
neighbor 9.9.9.9 activate
distance bgp 20 89 20

R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:26:13, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:26:13, FastEthernet0/0
B 9.9.9.1 [89/0] via 9.9.9.9, 00:02:08
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:26:13, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#

R10#ping 9.9.9.1 source 10.10.10.11 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.11
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 4/10/20 ms
R10#




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

13 Replies 13

Hi 

It looks fine, could you please share: show ip bgp summary. I see you are using the loopback200 as update-source, what IGP are you using? Have you disabled the sync?

router bgp x
no sync

Thank you in advance. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

Below is output for show ip bgp summary. IGP that i am using is EIGRP and yes i have disabled syn.

R10(config-router)#do show ip bgp sum
BGP router identifier 123.10.10.10, local AS number 34567
BGP table version is 5, main routing table version 5
2 network entries using 280 bytes of memory
2 path entries using 160 bytes of memory
2/2 BGP path/bestpath attribute entries using 288 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 7/5 prefixes, 7/5 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
9.9.9.9 4 34567 5 5 5 0 0 00:00:27 1

-------------------------------------------------------------------------------------------------

R9(config-router)#do show ip bg sum
BGP router identifier 123.9.9.9, local AS number 34567
BGP table version is 3, main routing table version 3
2 network entries using 280 bytes of memory
2 path entries using 160 bytes of memory
2/2 BGP path/bestpath attribute entries using 288 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 5/3 prefixes, 6/4 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.10 4 34567 6 6 3 0 0 00:01:08 1

Thank you, please compare your configuration with mine. Also I have disabled auto-summary.

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

yes after disabling sync i have done a hard reset for bgp neighbours (clear ip bgp *)..

Still cannot ping 

R10#ping 9.9.9.1 source 10.10.10.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.11
.....
Success rate is 0 percent (0/5)

Is possible to share the entire config? I changed the ip 10.10.10.11 instead 10.10.10.1

Are your routers connected directly like my example?

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.11, timeout is 2 seconds:
Packet sent with a source address of 9.9.9.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
R9#

R10#ping 9.9.9.1 source 10.10.10.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R10#




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

Attached is full config for R9 and R10.

Please note that i transit over two other eigrp routers SW3 and SW4

Thank You for your help

Hi

Have simulated your configuration (just changing the ip addressing on the switches)

ROUTER 9

interface Loopback1
ip address 9.9.9.1 255.255.255.255
!
interface Loopback200
ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
ip address 10.95.0.9 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 9.9.9.9 0.0.0.0
network 10.95.0.9 0.0.0.0
no auto-summary
!
router bgp 34567
no synchronization
bgp log-neighbor-changes
network 9.9.9.1 mask 255.255.255.255
neighbor 10.10.10.10 remote-as 34567
neighbor 10.10.10.10 update-source Loopback200
no auto-summary

SWITCH 1

nothing special

Vlan 10

ip routing

interface FastEthernet0/1
switchport access vlan 10
switchport mode access

!
interface FastEthernet0/3
no switchport
ip address 1.1.1.1 255.255.255.0
duplex auto
!
interface Vlan10
ip address 10.95.0.5 255.255.255.0
!
!
router eigrp 1
network 0.0.0.0
!

!

SWITCH 2

nothing special

vlan 20

ip routing

interface FastEthernet0/1
switchport access vlan 20
switchport mode access

!
interface FastEthernet0/3
no switchport
ip address 1.1.1.2 255.255.255.0
duplex auto
!
interface Vlan20
ip address 10.106.0.6 255.255.255.0
!
!
router eigrp 1
network 0.0.0.0

ROUTER 10

interface Loopback1
ip address 10.10.10.11 255.255.255.255
!
interface Loopback200
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
ip address 10.106.0.10 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 10.10.10.10 0.0.0.0
network 10.106.0.10 0.0.0.0
no auto-summary
!
router bgp 34567
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
neighbor 9.9.9.9 activate
no auto-summary
no synchronization
network 10.10.10.11 mask 255.255.255.255
exit-address-family

##########################################

##########################################

Now please note the routing tables

R9#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.95.0.5, 00:13:34, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
C 9.9.9.9 is directly connected, Loopback200
C 9.9.9.1 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.10.10.10/32 [90/435456] via 10.95.0.5, 00:13:28, FastEthernet0/0
B 10.10.10.11/32 [200/0] via 10.10.10.10, 00:12:37
C 10.95.0.0/24 is directly connected, FastEthernet0/0
D 10.106.0.0/24 [90/307456] via 10.95.0.5, 00:13:35, FastEthernet0/0
R9#
R9#
R9#
R9#sh ip bgp
BGP table version is 3, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 9.9.9.1/32 0.0.0.0 0 32768 i
*>i10.10.10.11/32 10.10.10.10 0 100 0 i
R9#

R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:14:23, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:14:23, FastEthernet0/0
B 9.9.9.1 [200/0] via 9.9.9.9, 00:13:32
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:14:23, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#
R10#
R10#sh ip bg
R10#sh ip bgp
BGP table version is 3, local router ID is 10.10.10.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i9.9.9.1/32 9.9.9.9 0 100 0 i
*> 10.10.10.11/32 0.0.0.0 0 32768 i
R10#

Now if you advertise the prefixes into EIGRP As John mentioned previously, it will be known via EIGRP and ping will be enabled:

R10#sh ip bgp
BGP table version is 4, local router ID is 10.10.10.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
r>i9.9.9.1/32 9.9.9.9 0 100 0 i      <---(r) indicates there is best path through IGP in this case EIGRP
*> 10.10.10.11/32 0.0.0.0 0 32768 i
R10#
R10#
R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:31:14, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:31:14, FastEthernet0/0
D 9.9.9.1 [90/435456] via 10.106.0.6, 00:01:06, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:31:16, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#

Now if you want them known via BGP you should change the distance value lowest than 90 on both routers

Example:

ROUTER 10

router bgp 34567
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
neighbor 9.9.9.9 activate
distance bgp 20 89 20

R10#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/307200] via 10.106.0.6, 00:26:13, FastEthernet0/0
9.0.0.0/32 is subnetted, 2 subnets
D 9.9.9.9 [90/435456] via 10.106.0.6, 00:26:13, FastEthernet0/0
B 9.9.9.1 [89/0] via 9.9.9.9, 00:02:08
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.10.10/32 is directly connected, Loopback200
C 10.10.10.11/32 is directly connected, Loopback1
D 10.95.0.0/24 [90/307456] via 10.106.0.6, 00:26:13, FastEthernet0/0
C 10.106.0.0/24 is directly connected, FastEthernet0/0
R10#

R10#ping 9.9.9.1 source 10.10.10.11 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.11
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 4/10/20 ms
R10#




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks Julio and Jon.. both answers were correct.

Thanks

It was a pleasure

Have a great day

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi, this is my configuration, assuming R9 and R10 are connected directly, I have used EIGRP as my NLRI:

ROUTER 9

interface Loopback1
ip address 9.9.9.1 255.255.255.255
!
interface Loopback200
ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
ip address 10.109.0.9 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 9.9.9.9 0.0.0.0
network 10.109.0.9 0.0.0.0
no auto-summary
!
router bgp 34567
no synchronization
bgp log-neighbor-changes
network 9.9.9.1 mask 255.255.255.255
neighbor 10.10.10.10 remote-as 34567
neighbor 10.10.10.10 update-source Loopback200
no auto-summary

ROUTER 10

interface Loopback1
ip address 10.10.10.1 255.255.255.255
!
interface Loopback200
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
ip address 10.109.0.10 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 10.10.10.10 0.0.0.0
network 10.109.0.10 0.0.0.0
no auto-summary
!
router bgp 34567
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 9.9.9.9 remote-as 34567
neighbor 9.9.9.9 update-source Loopback200
!
address-family ipv4
neighbor 9.9.9.9 activate
no auto-summary
no synchronization
network 10.10.10.1 mask 255.255.255.255
exit-address-family

And it works:

R9#sh ip bgp
BGP table version is 3, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 9.9.9.1/32 0.0.0.0 0 32768 i
*>i10.10.10.1/32 10.10.10.10 0 100 0 i
R9#
R9#
R9#
R9#ping 10.10.10.1 source 9.9.9.1 repeat 10

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 9.9.9.1
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 8/10/16 ms
R9#

################

R10#sh ip bg
R10#sh ip bgp
BGP table version is 3, local router ID is 10.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i9.9.9.1/32 9.9.9.9 0 100 0 i
*> 10.10.10.1/32 0.0.0.0 0 32768 i
R10#
R10#
R10#
R10#ping 9.9.9.1 source 10.10.10.1 repeat 10

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 9.9.9.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.1
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 4/10/16 ms
R10#

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi Julio,

directly connected works fine with me too but i only get issues when i transit through the other two eigrp neighbours (SW3 and SW4).. probably i need to check the IGP?

Hi

Yes, I was checking your config and it looks good, Which models are SW3 and 4? just make the following test

configure the EIGRP on the switches:

conf t

no router eigrp 34567

router eigrp 34567
no auto-summary
network 0.0.0.0 255.255.255.255

on both switches.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

You are not advertising 9.9.9.1 or 10.10.10.11 into EIGRP so when the ping gets to the intermediate switches they have no route to those IPs.

Jon

Review Cisco Networking for a $25 gift card