implementing QOS for VOIP
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2005
12:38 PM
- last edited on
03-25-2019
03:11 PM
by
ciscomoderator
We have two 1760 routers connected via a T1. On the LAN side there are 3rd party VOIP gateways installed. What we need to achieve is to implement QOS to prioratise voice calls going through the T1 link.
I have put together the following config. Appreciate if some one can confirm that this solution will work.
!
hostname ABC
!*********
Class-map match-all voice-signaling
match access-group 103
class-map match-all voice-traffic
match access-group 102
policy-map VOICE-POLICY
class voice-traffic
priority 100
!-- queue is assigned to "voice-traffic" class with (based on ACL in
!-- class voice) with max bandwidth = 100 Kbps.
class voice-signaling
bandwidth 8
class class-default
fair-queue
!*********
!
logging buffered 32000 debugging
enable password CISCO
!
ip subnet-zero
ip domain name abc.com
ip name-server 172.16.11.73
ip name-server 192.168.88.3
!
!
interface FastEthernet0/0
ip address 192.168.88.1 255.255.255.0
speed auto
full-duplex
interface Serial0/0
ip unnumbered FastEthernet0/0
ip tcp header-compression iphc-format
service-policy output VOICE-POLICY
no ip route-cache
no fair-queue
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.88.6
ip route 192.168.91.0 255.255.255.0 192.168.91.1
ip route 192.168.91.0 255.255.255.0 Serial0/0
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
Thanks
Pat
- Labels:
-
Routing Protocols

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2005 01:01 PM
Hello Pat,
the config looks ok to me, you are matching TCP port 1720 for the H.323 signaling, and UDP ports 16384 thru 32767 for the voice payload, which is exactly what should be matched...
Regards,
GP
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-23-2005 04:44 AM
Hi GP
Thanks a lot for checking it out. I will be trying it out today. I will update the status.
Thanks
Pat
