cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2511
Views
5
Helpful
11
Replies

Inter-vlan Routing Question

rkeeran
Level 1
Level 1

Hello All

 

I am trying to set up inter-vlan routing without a router. I have a Catalyst 3560 that has 5 vlans. This switch Is connected to a ISP Modem. Intervlan routing is set up on the switch but I am stuck. I am unable to browse the internet from any of the vlans. I am able to ping 8.8.8.8 from the switch but not from the vlans. If there is a router present I can use NATing to fix this but trying to see if it is possible to do it without the need of a router.

Building configuration...

 

Current configuration : 4540 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname TLab-Edge

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

system mtu routing 1500

vtp domain TestLab

vtp mode transparent

ip subnet-zero

ip routing

ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.20.1 192.168.20.10

ip dhcp excluded-address 192.168.30.1 192.168.30.10

ip dhcp excluded-address 192.168.40.1 192.168.40.10

ip dhcp excluded-address 192.168.50.1 192.168.50.10

!

ip dhcp pool CCTV

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   dns-server 8.8.8.8 8.8.4.4

!

ip dhcp pool DATA

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

   dns-server 8.8.8.8 8.8.4.4

!

ip dhcp pool VOICE

   network 192.168.30.0 255.255.255.0

   default-router 192.168.30.1

   dns-server 8.8.8.8 8.8.4.4

!

ip dhcp pool TV-WIFI

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.1

   dns-server 8.8.8.8 8.8.4.4

!

ip dhcp pool POS_ATM

   network 192.168.50.0 255.255.255.0

   default-router 192.168.50.1

   dns-server 8.8.8.8 8.8.4.4

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10

name CCTV

!

vlan 20

name DATA

!

vlan 30

name VOICE

!

vlan 40

name TV-WIFI

!

vlan 50

name POS-ATM

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

!

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 40

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/17

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/20

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/21

spanning-tree portfast

!

interface GigabitEthernet0/22

spanning-tree portfast

!

interface GigabitEthernet0/23

spanning-tree portfast

!

interface GigabitEthernet0/24

no switchport

ip address dhcp

spanning-tree portfast

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface TenGigabitEthernet0/1

!

interface TenGigabitEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

!

interface Vlan30

ip address 192.168.30.1 255.255.255.0

!

interface Vlan40

ip address 192.168.40.1 255.255.255.0

!

interface Vlan50

ip address 192.168.50.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

ip http server

!

!

!

control-plane

!

!

line con 0

line vty 5 15

!

end
2 Accepted Solutions

Accepted Solutions

Hello,

 

the short answer is: you need the router. The switch does not do NAT. You are better off doing a "router-on-a-stick" setup. If you don;t know how to use subinterfaces on the router, post the router config as well, so we can help you with the details...

View solution in original post

11 Replies 11

Hello,

 

the short answer is: you need the router. The switch does not do NAT. You are better off doing a "router-on-a-stick" setup. If you don;t know how to use subinterfaces on the router, post the router config as well, so we can help you with the details...

Hi Georg

 

Thanks for the rapid response. I have a Cisco 2621xm and when I set up router on a stick, speeds are below 30 Mbps when I get connectivity. Is there a way to fine tune the performance of the network if router on a stick is set up?

Hello,

 

the 2621XM is end of sale as of 2007, so you obviously have an ancient device there. Not sure how much that can be tuned, post the running config of the 2621XM. But actually, to be honest I think the router will be the bottleneck no matter what.

Hi Georg

 

I have setup up Router on a stick on my set up at home. Please see configs attached

See attachment for performance of a 2621XM.

 

Hi Joseph

 

Thanks for the heads up. What can I expect from a Cisco 2811 router?

Hello,

 

the 2811 is end of sale as of 2011. It won't be a big improvement.

 

What is your budget ? You might be better of just buying, depending on what you are willing to spend, a Cisco ISR 1111 (around 700 dollars) or just a 'cheap' ISP modem (around 100 to 200 dollars).

Hi Georg

 

Its for a small office space. Service provider is potentially going install a Hub 2000/3000 modem. Client wants to reduce costs as much as possible. Trying to exhaust my options before going with the only option available.

See attachments.

Thanks Joseph!

 

I really appreciate it. I have a bit more to reconsider. Thanks

Hello

As stated by @Georg Pauwen you will need a router for the network translation and also quite a good scalable one to accommodate the amount of users you may have.

 

I would personally look into meraki soho rtrs, however review the following selector to provide you with some idea on what would be applicable. -here


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul