cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Bookmark
|
Subscribe
|
2846
Views
0
Helpful
6
Replies

interface bandwidth command

Mike Assel
Level 4
Level 4

I'm trying to track down a possible service provider misconfiguration on our MPLS connection (that or reveal my own ignorance   I'm trying to confirm the QoS configuration across our MPLS WAN.  My question is this:  What number is the percentage based on in the priority percent 25 and bandwidth percent 74 commands (see below for router config)?  I'm assuming it is the default bandwidth of the physical interface or the configured bandwidth using the bandwidth command on the interface.  Here is my concern.  The physical connection from the SP managed router in our office to the SP edge is 100Mbps.  However we are only paying for and are limited to 10 Mbps.  I have what I'm told is the full config of the SP router in our office and nowhere do I see anything in the config that tells this router that it is being limited to 10Mbps into the MPLS cloud.  So unless I'm missing something there seems to be a bandwidth misconfiguation that I think is causing some issues with QoS among other things. 

I'd appreciate it if somebody could confirm what I am thinking or tell me where I am incorrect. 

Here is a snippet of the config from our service provider mangaged router that is connected to our LAN:

class-map match-any af41

match ip dscp af41

class-map match-any ef

match ip dscp ef

!

!

policy-map 25_74

class ef

    priority percent 25

class af41

    bandwidth percent 74

class class-default

    fair-queue

  set ip dscp default

!

!

!

!

interface FastEthernet0/0

description => Metro Eth Internet Connection to service provider

ip address <details removed>

no ip redirects

speed 100

full-duplex

no cdp enable

max-reserved-bandwidth 100

service-policy output 25_74

!

interface FastEthernet0/1

description => Direct connection to LAN

ip address 192.168.1.251 255.255.255.0

no ip redirects

duplex auto

speed auto

no cdp enable

2 Accepted Solutions

Accepted Solutions

Edison Ortiz
Hall of Fame
Hall of Fame

You are correct. You should apply a H-QoS with a shaper to 10Mbps.

class-map match-any af41

match ip dscp af41

class-map match-any ef

match ip dscp ef

!

!

policy-map 25_74

class ef

    priority percent 25

class af41

    bandwidth percent 74

class class-default

    fair-queue

  set ip dscp default

!

policy-map 10Mbps

class class-default

  shape average 9500000

   service-policy  25_74

!

interface FastEthernet0/0

service-policy output 10Mbps

View solution in original post

when you use Hqos with a shaper in the parent policy you do not need the bandwidth command in the interface level

because the Qos Policy will reference the shaper value from the parent policy

see this document i wrote which dicuss the function

https://supportforums.cisco.com/docs/DOC-8373

good luck

if helpful Rate

View solution in original post

6 Replies 6

Edison Ortiz
Hall of Fame
Hall of Fame

You are correct. You should apply a H-QoS with a shaper to 10Mbps.

class-map match-any af41

match ip dscp af41

class-map match-any ef

match ip dscp ef

!

!

policy-map 25_74

class ef

    priority percent 25

class af41

    bandwidth percent 74

class class-default

    fair-queue

  set ip dscp default

!

policy-map 10Mbps

class class-default

  shape average 9500000

   service-policy  25_74

!

interface FastEthernet0/0

service-policy output 10Mbps

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

When shaping, on many routers you may need to account for L2 overhead.  For Ethernet, you might need to shape 5 to 15% less than nominal rate.

When shaping to support VoIP, you might need to decrease the Tc interval.

In this particular construct, leaving only 1% of bandwidth for class-default could be a little too severe (there are reasons why Cisco's default is 25%) although on most platforms supporting CBWFQ before HQF, class-default with FQ doesn't usually adhere to the remaining bandwidth.

If running across a MPLS cloud supporting multipoint, consideration should also be given to cloud egress QoS.

Mike Assel
Level 4
Level 4

Thanks! H-qos is hierarchical? Would a statement like this also be needed?

Interface fastethernet0/0

Bandwidth 10000

Sent from Cisco Technical Support iPhone App

when you use Hqos with a shaper in the parent policy you do not need the bandwidth command in the interface level

because the Qos Policy will reference the shaper value from the parent policy

see this document i wrote which dicuss the function

https://supportforums.cisco.com/docs/DOC-8373

good luck

if helpful Rate

Mike Assel
Level 4
Level 4

Thanks to the both of you for the responses.  I believe I have  a grasp on it now.  The ultimate issue is that I have no visibility into the router configs of the service provider, so I have no way to confirm if they have misconfigured something (other than asking them). 

Hi,

   Actually ISP would do Policing to not allow you to use bandwidth more than service contract. You can use tools for testing. You can just download multiple huge files from many sources and then use "show interface" to see "30 second input/output rate". It can be adjusted from 30s to 600s. It's a good idea to shape your traffic to not exceed 10Mbps and then send it to software queues if exceeded. Edison already provided a good solution for you.

HTH,

Toshi