cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

80349
Views
29
Helpful
15
Replies
Beginner

Interface Embedded-Service-Engine0/0??

Hi All,

Sure this is a simple one. New to the 1900 series routers, have a 1921 with IOS 15.1. Noticed that there is a standard interface labeled Embedded-Service-Engine0/0. Can anyone advise what the purpose of this is? Cannot seem to find any detail on it. See extract from default config below.

interface Embedded-Service-Engine0/0
no ip address
no ip route-cache
shutdown

Jason

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Interface Embedded-Service-Engine0/0??

15 REPLIES 15
Highlighted
Beginner

Re: Interface Embedded-Service-Engine0/0??

Beginner

Re: Interface Embedded-Service-Engine0/0??

Thanks Muammer, i'll take a look at this.

Cisco Employee

Interface Embedded-Service-Engine0/0??

Hello,

In 19xx does not do anything while:

Embedded Service Engine Overview

Cisco Integrated Services Routers Generation 2 (Cisco ISRs G2) have dual  core CPUs on the motherboard. The first core runs Cisco IOS software as  Cisco Integrated Services Routers (ISRs) do; the second core, or the Embedded Service Engine, is capable of running Linux-based applications.

The following Cisco ISR G2 platforms support the Embedded Service Engine:

Cisco 2911

Cisco 2921

Cisco 2951

Cisco 3925

Cisco 3945

Beginner

Re: Interface Embedded-Service-Engine0/0??

As I see this Embedded-Service-Engine0/0 doesn't show up in earlier (15.0) IOS versions. Does anyone know since when is this enabled by default?

Beginner

Re: Interface Embedded-Service-Engine0/0??

This was introduced in 15.0(1)M via this internal bug:

CSCso10637   

Add the embedded-service-engine 0/0 interface to IOS for OPPO

Internally found enhancement (Sev6) bug: R-Resolved

http://www.cisco.com/cgi-bin/Support/Bugtool/home.pl

Beginner

Interface Embedded-Service-Engine0/0??

can this port be used for telnet access to the device?

Hall of Fame Master

Interface Embedded-Service-Engine0/0??

Whether it could be used for telnet access would depend on what type of device you use in the Embedded Service Engine and what functionality it provided. But generally you would use the normal built in Ethernet or network module interfaces for telnet access.

HTH

Rick

If you found this post helpful, please let the community know by clicking the helpful button!
By doing so, and until end of January, you are helping Doctors Without Borders
Beginner

Interface Embedded-Service-Engine0/0??

sorry, didn't get it

I am asking if the Embedded Service Engine can function as a normal ethernet port that you can configure an IP address, and then access that IP address via a telnet?

Beginner

Interface Embedded-Service-Engine0/0??

Yes you can. We have a switches on completely separate networks which we need to manage from another network and we just patch a Ethernet cable into the management port, configure an IP and then we are able to use telnet, SSH, SNMP etc.

Enthusiast

Re: Interface Embedded-Service-Engine0/0??

Hi Richard,

 

I saw your reply on this post. I am replacing a Cisco 3550 SW with a Cisco 2911. I have configured two interfaces one facing the provider and one facing our LAN. do I need to configure Embadded-Service-Engine 0/0?

 

if I leave it alone, would my 2911 router will perform what is expected from it which just providing a connectivity to the provider and to my LAN?

 

Please advise as i am going to perform this task tonight.

 

Best Regards,

 

Masood

 

Beginner

Re: Interface Embedded-Service-Engine0/0??

Yes.  It will perform normally if you just use your Gig ports.  The ISE is for running Linux applications.  We use 2921 routers for OOB and telephony and we do not use the ISE at all and it works perfectly normal.  Hope this helps.

 

Our example config:

Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/0         10.x.x.x        YES NVRAM  up                    up 
Enthusiast

Re: Interface Embedded-Service-Engine0/0??

Thanks a alot. what a relief!

 

This is the first time I have configured an ISR router so I wasn't sure if I need to do any configuration on the embedded Service module or not.

as for normal configuration, i have done already and I will see tonight how it would work. I hope it goes well.

 

BTW: I added a vlan tagging ( vlan ID,encap dot1q,etc.)to my Gi interface but i am not sure if I had to do that since there is no switch involved. shoud I remove this vlan tagging?

 

the switch  am replacing was not configure by me an di ma not sure why they had configure vlans on a sw that s facing the Internet!? the didn't need it. because of that I added VLAN tagging with hesitations.

Best regards,

 

Masood

 

 

 

Beginner

Re: Interface Embedded-Service-Engine0/0??

You do not need vlan tagging on your router unless you are doing the following:

 

1. Configuring a metro-Ethernet circuit to your ISP which will require you to tag your traffic when leaving the router.

2. Configuring router on a stick, where your router will be the SVI and it tags the traffic to the corresponding L2 vlan on the switch.

Enthusiast

Re: Interface Embedded-Service-Engine0/0??

Thanks.



None of those conditions we have. If I had a L2 SW, I could have configure sub-interfaces and tag vlans which is not the case. Thanks again and Best Regards,



Masood


CreatePlease to create content
Content for Community-Ad
FusionCharts will render here