Internet Failover help
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-06-2012 10:01 AM - edited 03-04-2019 06:03 PM
Team,
I have a customer with 2 sites connected by a T-1 between 2 2800 series routers. The main site has a uc560 (So static routes only). Connected to the UC560 is an 871 router that is owned and managed by the cable company. The remote location also has an internet connection. I want to get them to fail over to each other in the event either one goes down. No problem if the internet connection is directly connected to the UC560 but its not....So if the internet is unreachable, the physical interface still stays up and the re-routing to the remote site doesn't happen. I have to physically shut down the interface or pull the ethernet cable to make the re-routing occur.
Is there a way we can check actual internet connectivity and if it's not there fail over to the remote site???
Conceptually...like a ping and if I don't see my default internetgateway it shuts the port down and lets re-routing occur?
Any other ways you guys think I can get this done? Suggestions always welcome
Thanks
Paul
- Labels:
-
Other Routing
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
11-09-2012 02:23 PM
Hey Paul,
If I assume your topology correctly it would be like following -
Main Site Remote Site
2811 -------------------- T1 ------------ 2811 --- Internet
| 10.10.20.2/24
|
192.168. |
1.0 | 10.10.20.1/24
LAN --- UC-560
| 150.x.x.1/24 eth0/0
|
| 150.x.x.2/24
871 Router
|
|
Internet
Using the route-map's we could acheive the failover on the Main Site :
ip sla 1
icmp-echo 4.2.2.2 source-ip 10.10.10.1
timeout 1000
threshold 2
frequency 3
track 10 ip sla 1 state
delay down 10
This track object will go down when the ping to 4.2.2.2 will not work from UC-560 port connected to 871
and I assume, you will have 2 static default routes for the Internet traffic on UC560 -
ip route 0.0.0.0 0.0.0.0 150.x.x.2 track 10 >>> this route will go down when the connectity to Internet over 871 is down.
ip route 0.0.0.0 0.0.0.0 10.10.20.2 20
For NAT -
int LAN
ip nat inside
int eth0/0
ip nat outside
ip access-list standard NEXT-HOP-871
permit host 150.x.x.2
ip access-list extended LAN-SUBNET
deny ip 192.168.1.0 0.0.0.255
permit ip 192.168.1.0 0.0.0.255 any
route-map PRIMARY permit 10
match ip add LAN-SUBNET
match ip next-hop NEXT-HOP-871
ip nat inside source route-map PRIMARY interface eth0/0
You may need to refer the following link -
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080133ddd.shtml
which conveys that when the packet comes on the inside interface (LAN) - routing is checked before NAT.
So when the primary link is up, the static route is UP (due to ip sla and track), packets get natted with the ip of eth0/0
and when the ip sla is down, so in turn the track object - then floating static route towards the 2811 is installed in routing table.
Thus the packets will be sent to the 2811 and 2811 should be configured in such a way so that it sends the traffic to Remote Site over T1.
Also you will need to configure the Remote site - to get that traffic natted if it is not destined to the local subnet.
- HTH
Rahul
