cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5823
Views
0
Helpful
7
Replies
Highlighted
Beginner

IP SLA Failover

I have purchased a new Cisco 1812 dual wan router and 2 internet connections as follows.

ISP1 (FE0) (WAN)     
Static IP: 58.27.132.106
Subnet: 255.255.255.252
Gateway: 58.27.132.105
DNS 10.16.6.11, 10.16.7.12

ISP2 (FE1) (WAN)
DHCP:*.*.
Subnet: 255.255.255.0
Gateway: 192.168.15.1
DNS 192.168.15.1,

LAN (FE2) (LAN)
IP:      10.10.10.1
Subnet:      255.255.255.0

I have 2 wan ports
FastEthernet0
FastEthernet1
8 Switch Ports FastEthernet2 / 9
1 Vlan = Vlan1

As per attached runnig-config i am able to run internet on both interfaces and it also switches between FE0 and FE1.
When FE0 interface (internet device Power) goes down it automatically switch within 10secs to FE1 interface and works fine. And vice versa it works fine.

But I am unable to achieve the desired Goal i.e. Internet WAN interface should switch on internet base not on network base

See if FE0 internet goes down (from ISP1) it should switch to FE1 (ISP2) as at the moment it’s not doing.
If interface FE0 network is connected and internet is down then it doesn’t switch to FE1 and I wanted to switch that way

Regards
Syed Talal Hassan

Everyone's tags (2)
7 REPLIES 7
Highlighted
Hall of Fame Guru

Re: IP SLA Failover

Syed

I'm not sure about this part of your config -

ip route 10.10.10.0 255.255.255.0 FastEthernet0 10 track 100
ip route 0.0.0.0 0.0.0.0 58.27.132.105
ip route 10.10.10.0 255.255.255.0 FastEthernet1 251

why is it 10.10.10.0/24 you are using on the IP SLA. For internet usage i would have thought your config would be -

ip route 0.0.0.0 0.0.0.0 58.27.132.105 track 100

ip route 0.0.0.0 0.0.0.0 fa0/1 250

Jon

Highlighted
Beginner

Re: IP SLA Failover

Hi John,

When we delete the previous one and add the following, internet stopped working even from both wans (internet)

previous deleted

ip route 10.10.10.0 255.255.255.0 FastEthernet0 10 track 100
ip route 10.10.10.0 255.255.255.0 FastEthernet1 251

entered these

ip route 0.0.0.0 0.0.0.0 58.27.132.105 track 100

ip route 0.0.0.0 0.0.0.0 fa0/1 250

Highlighted
Hall of Fame Guru

Re: IP SLA Failover

talalsyscon wrote:

Hi John,

When we delete the previous one and add the following, internet stopped working even from both wans (internet)

previous deleted

ip route 10.10.10.0 255.255.255.0 FastEthernet0 10 track 100
ip route 10.10.10.0 255.255.255.0 FastEthernet1 251

entered these

ip route 0.0.0.0 0.0.0.0 58.27.132.105 track 100

ip route 0.0.0.0 0.0.0.0 fa0/1 250

Sorry for that, but i can't understand how this would have happened. How does the route to 10.10.10.0 work for internet traffic ?

Jon

Highlighted
Beginner

Re: IP SLA Failover

Try the configuration here:

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html

Pay particular attention to this part:

Configuring Reliable Static Routing Backup Using Object Tracking: DHCP Example

The following example configures the Reliable Static Routing Backup Using Object Tracking feature using DHCP. The primary interface is an Ethernet interface, and the backup interface is a serial interface. This example applies to Cisco IOS Release 12.3(14)T and later releases.

!

ip dhcp-client default-router distance 25 

ip sla monitor 1

  type echo protocol ipIcmpEcho 172.16.23.7

  timeout 1000

  threshold 2

  frequency 3

ip sla monitor schedule 1 life forever start-time now 

track 123 rtr 1 reachability ( in IOS 12.4 and older use track 123 ip sla 1 reachability )

!

interface Ethernet0/0

  description primary-link

  ip dhcp client route track 123

  ip address dhcp

!

interface Serial2/0

  description backup-link

  ip address 10.2.2.2 255.0.0.0

!

ip local policy route-map MY-LOCAL-POLICY 

ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

!

access-list 101 permit icmp any host 172.16.23.7 echo 

route-map MY-LOCAL-POLICY permit 10

  match ip address 101

  set ip next-hop dynamic dhcp

Change the above config to match your setup. Instead of using the route map to allow icmp on the dynamic default route, use it to route icmp echo traffic to 4.2.2.2 matched by the access list towards the next hop 58.27.132.105.

Also don't use ip dhcp client route track in Fa1. You don't want to track the dynamic default route. Use "ip dhcp-client default-router distance 250" in global configuration mode. Let us know if that works out for you.

Alternatively, you can setup the two default routes without tracking and enable PfR using CCP since you have a ISR router with IOS 12.4. It's a much better way to use your WAN links. Or you can also use route-maps to send particular traffic towards one WAN link and another type of traffic towards the other one.

Rado

Highlighted
Beginner

Re: IP SLA Failover

You created redundant routes to your LAN. Those entries won't even pop in the routing table since your LAN is directly connected.

ip route 10.10.10.0 255.255.255.0 FastEthernet0 10 track 100
ip route 0.0.0.0 0.0.0.0 58.27.132.105
ip route 10.10.10.0 255.255.255.0 FastEthernet1 251

Read a bit about Optimized Edge Routing. It will help you with this.

Highlighted
Beginner

Re: IP SLA Failover

Dear All,

Find the attached Configuration after this the situation is as following

If both ISP are connected on FE0 and FE1 it auto switch between isp’s , I confirmed by visiting www.whatismyip.com and after 15 secs it goes to ISP 2 and comes back to ISP1. It is doing continuously. Attached is the result of ping.

Now if we unplug the cable of ISP1 from FE0 the internet works fine without any delay or switching. And continuous ping.

And if we plug back the cable of ISP1 FE0 and unplug the cable of ISP2 FE1 internet stopped working totally. No ping at all.

Please guide the error in my configuration.

Regards

Syed Talal Hassan

Highlighted
Beginner

Re: IP SLA Failover

Dear All,

Please find the attached config of IP SLA on Cisco 1812 which worked perfectly fine.

I hope in future this will help for upcoming people

Regards

Syed Talal Hassan.

CreatePlease to create content