08-04-2022 06:11 AM - last edited on 08-06-2022 10:10 PM by Translator
Hello All
I would like to extend the ip address range for the router, but not working like i though it would.
ip dhcp pool Pool
import all
network 192.168.35.0 255.255.254.0
default-router 192.168.35.1
domain-name gleamns
dns-server 8.8.8.8 4.4.4.4
lease 0 2
interface Vlan1
ip address 192.168.35.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly in
ip virtual-reassembly out
which gives me 512 host, but the ones that get the .34 range are not able to connect
Solved! Go to Solution.
08-06-2022 01:15 PM
access-list 101 is missing ?
08-04-2022 06:22 AM
sure not work the SVI which is GW 255.255.255.0 have mask different than host 255.255.254.0
only match the mask for both GW and host and it will work
08-04-2022 10:49 AM - last edited on 08-06-2022 10:12 PM by Translator
Hello,
make the changes marked in bold, when you are done, post the full running config again (sh run) so we can doublecheck...
ip dhcp pool center
import all
--> network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
--> no domain-name Domain1
--> dns-server 8.8.8.8
lease 0 2
interface GigabitEthernet4
description outside wan 2
ip address dhcp
--> ip nat outside
duplex auto
speed auto
interface GigabitEthernet5
description outside wan1
ip address dhcp
--> ip nat outside
duplex auto
speed auto
interface Vlan1
--> ip address 192.168.100.1 255.255.255.0
ip nat inside
--> no ip nat enable
no ip virtual-reassembly in
ip virtual-reassembly out
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source route-map ISP_1_RM interface GigabitEthernet4 overload
ip nat inside source route-map ISP_2_RM interface GigabitEthernet5 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
ip route 0.0.0.0 0.0.0.0 GigabitEthernet4 dhcp
!
route-map ISP_1_RM permit 10
match ip address 101
match interface GigabitEthernet4
!
route-map ISP_2_RM permit 10
match ip address 101
match interface GigabitEthernet5
!
access-list 23 permit any
--> access-list 101 permit ip 192.168.100.0 0.0.0.255 any
access-list 104 permit ip any any
access-list 104 deny ip any any
access-list 110 permit ip any any
08-04-2022 11:48 AM
@Georg Pauwen has answer your perfectly.
if not work then share final config and we will make double check.
08-05-2022 08:10 AM
ok thanks for all the help, I think it is working, I will have to take it out on site to make sure, the only thing i see is that the DHCP with it configured with the 255.255.255.0 it will not give out enough IP Addresses, if i could use the 255.255.254.0 that would give me 512 addresses, but how would you get the rest of it to work with that setting?
08-06-2022 01:17 AM
I am puzzled by the response from Georg which seems to address an environment different from what is described in the original post. Basically your issue is that there is a mismatch between your pool configuration which is a network /23 and your interface which is /24. It seems to me that if you change the mask on your vlan1 interface to 255.255.254.0 that it should work.
08-06-2022 09:31 AM
can you share you config
08-06-2022 10:03 AM - last edited on 08-06-2022 10:16 PM by Translator
ok here is what i have at this time, it will pull IP Addresses but will not browse the internet
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp pool center
import all
network 192.168.100.0 255.255.254.0
default-router 192.168.100.1
dns-server 8.8.8.8
lease 0 2
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
redundancy
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
description outside wan 2
ip address dhcp
ip nat outside
no ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet5
description outside wan1
ip address dhcp
ip nat outside
no ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.100.1 255.255.254.0
ip nat inside
ip nat enable
no ip virtual-reassembly in
ip virtual-reassembly out
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source route-map ISP_1_RM interface GigabitEthernet4 overload
ip nat inside source route-map ISP_2_RM interface GigabitEthernet5 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
ip route 0.0.0.0 0.0.0.0 GigabitEthernet4 dhcp
!
!
route-map ISP_1_RM permit 10
match ip address 101
match interface GigabitEthernet4
!
route-map ISP_2_RM permit 10
match ip address 101
match interface GigabitEthernet5
!
access-list 23 permit any
access-list 104 permit ip any any
access-list 104 deny ip any any
access-list 110 permit ip any any
08-06-2022 01:15 PM
access-list 101 is missing ?
08-06-2022 01:54 PM
Thank you, it seems to be working now. I hate access list sometimes.
I appreciate everyone's input.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide