08-01-2018 02:06 PM
Based on my understanding of IPv4 multicast, if I join a group on the receiver, RP will show a (*,G) tree.
When I configured via the following command
interface Loopback1
no ip address
ipv6 enable
ipv6 mld join-group FF0E::1
ipv6 mld join-group FF0E::2
ipv6 mld join-group FF0E::3
I expected to see a (*,G) tree on R5, which is configured as a RP, but I did not see it.
Anything have I missed ?
On R2
R2#show run | i int|ipv6
mmi polling-interval 60
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
ipv6 address 2002::2:2:2:2/128
interface Ethernet0/0
ipv6 address 2001:192:166:1::2/64
ipv6 enable
interface Ethernet0/1
ipv6 address 2001:172:16:24::2/64
ipv6 enable
interface Ethernet0/2
ipv6 address 2001:172:16:23::2/64
ipv6 enable
ipv6 pim rp-address 2005::5:5:5:5
R2#ping 2005::5:5:5:5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2005::5:5:5:5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
On R4
R4#show run | i int|ipv6
mmi polling-interval 60
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
ipv6 address 2004::4:4:4:4/128
interface Ethernet0/0
ipv6 address 2001:172:16:34::4/64
ipv6 enable
interface Ethernet0/1
ipv6 address 2001:172:16:24::4/64
ipv6 enable
interface Ethernet0/2
ipv6 address 2001:172:16:14::4/64
ipv6 enable
ipv6 pim rp-address 2005::5:5:5:5
R4#ping 2005::5:5:5:5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2005::5:5:5:5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/22 ms
On R5
RP#show run | i int|ipv6
mmi polling-interval 60
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
ipv6 address 2005::5:5:5:5/128
interface Ethernet0/3
ipv6 address 2001:172:16:54::5/64
ipv6 enable
ipv6 pim rp-address 2005::5:5:5:5
thanks !!
Solved! Go to Solution.
08-02-2018 05:43 PM
One thing I noticed is that your receiver is configred for IPv6 multicast-routing. I have seen it as causing issues in the past. The receiver should be just a host. Could you please do a "no ipv6 multicast-routing" on the receiver and see if you get better results.
Regards,
08-01-2018 02:22 PM
Hello,
hard to tell what you are missing without seeing the full configs of all routers in your topology, can you post those ?
08-01-2018 02:31 PM
On the receiver:
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback1
no ip address
ipv6 enable
ipv6 mld join-group FF0E::1
ipv6 mld join-group FF0E::2
ipv6 mld join-group FF0E::3
!
interface Ethernet0/0
no ip address
ipv6 address 2001:192:166:1::7/64
ipv6 enable
ipv6 mld join-group FF0E::5
router eigrp CCIE
!
address-family ipv6 unicast autonomous-system 10
!
topology base
exit-af-topology
eigrp router-id 7.7.7.7
exit-address-family
On R2
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
no ip address
ipv6 address 2002::2:2:2:2/128
!
interface Ethernet0/0
no ip address
ipv6 address 2001:192:166:1::2/64
ipv6 enable
!
interface Ethernet0/1
no ip address
ipv6 address 2001:172:16:24::2/64
ipv6 enable
!
interface Ethernet0/2
no ip address
ipv6 address 2001:172:16:23::2/64
ipv6 enable
router eigrp CCIE
!
address-family ipv6 unicast autonomous-system 10
!
topology base
exit-af-topology
eigrp router-id 2.2.2.2
exit-address-family
ipv6 pim rp-address 2005::5:5:5:5
On R4
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
no ip address
ipv6 address 2004::4:4:4:4/128
!
interface Ethernet0/0
no ip address
ipv6 address 2001:172:16:34::4/64
ipv6 enable
!
interface Ethernet0/1
no ip address
ipv6 address 2001:172:16:24::4/64
ipv6 enable
!
interface Ethernet0/2
no ip address
ipv6 address 2001:172:16:14::4/64
ipv6 enable
router eigrp CCIE
!
address-family ipv6 unicast autonomous-system 10
!
topology base
exit-af-topology
eigrp router-id 4.4.4.4
exit-address-family
ipv6 pim rp-address 2005::5:5:5:5
On R5
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Loopback0
no ip address
ipv6 address 2005::5:5:5:5/128
!
interface Ethernet0/3
no ip address
ipv6 address 2001:172:16:54::5/64
ipv6 enable
router eigrp CCIE
!
address-family ipv6 unicast autonomous-system 10
!
topology base
exit-af-topology
eigrp router-id 5.5.5.5
exit-address-family
ipv6 pim rp-address 2005::5:5:5:5
thanks a lot !!!
08-01-2018 02:53 PM
Thanks, I'll lab this in GNS3 and get back with you...
08-01-2018 02:55 PM
thanks so much !!
08-02-2018 01:50 PM
Did you get a chance to lab in in GNS3 ?
thanks !!
08-02-2018 09:26 AM
The PIM are sent hop by hop from the first hop router (router next to the receiver) towards the RP. To troubleshoot this issue, you should start by doing a "show ipv6 mroute" on the first hop router (R2) and walking your way back to the RP.
Regards,
08-02-2018 10:28 AM
On the receiver: I joined a group
08-02-2018 05:43 PM
One thing I noticed is that your receiver is configred for IPv6 multicast-routing. I have seen it as causing issues in the past. The receiver should be just a host. Could you please do a "no ipv6 multicast-routing" on the receiver and see if you get better results.
Regards,
08-02-2018 07:53 PM
It worked.
thanks a million !!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide